No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DHCP policy VLAN, DNS, mDNS gateway, mDNS relay, UDP Helper, IP performance optimization, IPv6, DHCPv6, IPv6 DNS, IPv6 over IPv4 tunnel, and IPv4 over IPv6 tunnel.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Primary and Secondary IP Addresses for an Interface

Example for Configuring Primary and Secondary IP Addresses for an Interface

Networking Requirements

As shown in Figure 1-6, the switch has only one idle interface GE0/0/1 to connect to a LAN. The hosts on the LAN are located on two network segments: 172.16.1.0/24 and 172.16.2.0/24. The interface needs to be configured with two IP addresses to provide access for hosts on the two network segments.

Figure 1-6  Networking diagram for IP addresses configuration

Configuration Roadmap

The configuration roadmap is as follows:

Configure a primary IP address and a secondary IP address for the interface.

Procedure

  1. Add GE0/0/1 to VLAN 100, and configure a primary IP address and a secondary IP address for VLANIF 100.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type hybrid
    [Switch-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 172.16.1.1 24
    [Switch-Vlanif100] ip address 172.16.2.1 24 sub
    [Switch-Vlanif100] quit
    [Switch] quit

  2. Verify the configuration.

    # Ping a host on network segment 172.16.1.0 from the switch. The ping operation succeeds.

    <Switch> ping 172.16.1.2
      PING 172.16.1.2: 56  data bytes, press CTRL_C to break
        Reply from 172.16.1.2: bytes=56 Sequence=1 ttl=255 time=25 ms
        Reply from 172.16.1.2: bytes=56 Sequence=2 ttl=255 time=27 ms
        Reply from 172.16.1.2: bytes=56 Sequence=3 ttl=255 time=26 ms
        Reply from 172.16.1.2: bytes=56 Sequence=4 ttl=255 time=26 ms
        Reply from 172.16.1.2: bytes=56 Sequence=5 ttl=255 time=26 ms
      --- 172.16.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 25/26/27 ms

    # Ping a host on network segment 172.16.2.0 from the switch. The ping operation succeeds.

    <Switch> ping 172.16.2.2
      PING 172.16.2.2: 56  data bytes, press CTRL_C to break
        Reply from 172.16.2.2: bytes=56 Sequence=1 ttl=255 time=25 ms
        Reply from 172.16.2.2: bytes=56 Sequence=2 ttl=255 time=26 ms
        Reply from 172.16.2.2: bytes=56 Sequence=3 ttl=255 time=26 ms
        Reply from 172.16.2.2: bytes=56 Sequence=4 ttl=255 time=26 ms
        Reply from 172.16.2.2: bytes=56 Sequence=5 ttl=255 time=26 ms
      --- 172.16.2.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 25/25/26 ms

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 100
#
interface Vlanif100
 ip address 172.16.1.1 255.255.255.0
 ip address 172.16.2.1 255.255.255.0 sub
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 100
 port hybrid untagged vlan 100
#
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065678

Views: 30614

Downloads: 230

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next