No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of IP Service, including IP address, ARP, DHCP, DHCP policy VLAN, DNS, mDNS gateway, mDNS relay, UDP Helper, IP performance optimization, IPv6, DHCPv6, IPv6 DNS, IPv6 over IPv4 tunnel, and IPv4 over IPv6 tunnel.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv6 Addresses for Interfaces

Example for Configuring IPv6 Addresses for Interfaces

Networking Requirements

In Figure 10-16, GE0/0/1 of SwitchA connects to GE0/0/1 of SwitchB. The two interfaces correspond to their VLANIF interfaces (VLANIF 100). You need to configure IPv6 addresses for the VLANIF interfaces and check the Layer 3 interconnection between the interfaces.

IPv6 addresses for the VLANIF interfaces are fc00:1::1/64 and fc00:1::2/64.

Figure 10-16  Networking diagram for configuring IPv6 addresses for interfaces

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the IPv6 forwarding function on SwitchA and SwitchB.

  2. Configure IPv6 addresses for the interfaces.

Procedure

  1. Enable the IPv6 forwarding function on switches.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] ipv6

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] ipv6

  2. Configure IPv6 addresses for the interfaces.

    # Configure SwitchA.

    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ipv6 enable
    [SwitchA-Vlanif100] ipv6 address fc00:1::1/64
    [SwitchA-Vlanif100] quit

    # Configure SwitchB.

    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ipv6 enable
    [SwitchB-Vlanif100] ipv6 address fc00:1::2/64
    [SwitchB-Vlanif100] quit

  3. Verify the configuration.

    # Check interface information on SwitchA.

    [SwitchA] display ipv6 interface vlanif 100
    Vlanif100 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::218:20FF:FE00:83
      Global unicast address(es):
        FC00:1::1, subnet is FC00:1::/64
      Joined group address(es):
        FF02::1:FF00:1
        FF02::1:FF00:83
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND DAD is enabled, number of DAD attempts: 1
      ND reachable time is 30000 milliseconds
      ND retransmit interval is 1000 milliseconds
      ND stale time is 1200 seconds 
    

    # Check interface information on SwitchB.

    [SwitchB] display ipv6 interface vlanif 100
    Vlanif100 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::2E0:FCFF:FE33:11
      Global unicast address(es):
        FC00:1::2, subnet is FC00:1::/64
      Joined group address(es):
        FF02::1:FF00:2
        FF02::1:FF33:11
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND DAD is enabled, number of DAD attempts: 1
      ND reachable time is 30000 milliseconds
      ND retransmit interval is 1000 milliseconds
      ND stale time is 1200 seconds 
    

    # Ping the IPv6 address of SwitchB from SwitchA.

    [SwitchA] ping ipv6 FC00:1::2
      PING FC00:1::2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:1::2
        bytes=56 Sequence=1 hop limit=64  time = 12 ms
        Reply from FC00:1::2
        bytes=56 Sequence=2 hop limit=64  time = 3 ms
        Reply from FC00:1::2
        bytes=56 Sequence=3 hop limit=64  time = 3 ms
        Reply from FC00:1::2
        bytes=56 Sequence=4 hop limit=64  time = 3 ms
        Reply from FC00:1::2
        bytes=56 Sequence=5 hop limit=64  time = 3 ms
    
      --- FC00:1::2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/4/12 ms
    

Configuration File

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 100
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:1::1/64
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    ipv6
    #
    vlan batch 100
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00:1::2/64
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065678

Views: 25377

Downloads: 165

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next