No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, NetStream, sFlow, TWAMP Light, NETCONF, ECA, Intelligent Video O&M, eMDI, and Network Deception.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LSP Ping Test for a Common Tunnel

Example for Configuring LSP Ping Test for a Common Tunnel

Networking Requirements

In Figure 6-34:

  • The OSPF protocol runs on SwitchA, SwitchB, and SwitchC. They have learned the 32-bit host routes of each other on their loopback interfaces.

  • MPLS and MPLS LDP are enabled on SwitchA, SwitchB, and SwitchC.

  • MPLS and MPLS LDP are enabled on VLANIF interfaces on SwitchA, SwitchB, and SwitchC to trigger the establishment of an LDP LSP.

The NQA LSP Ping test needs to be performed to check the connectivity of the LSP between SwitchA and SwitchC.

Figure 6-34  Networking diagram of an LSP Ping test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as the NQA client.

  2. Configure SwitchC as the NQA server.

  3. Create an LSP Ping test on SwitchA.

Procedure

  1. Configure SwitchA, SwitchB, and SwitchC and run OSPF to implement reachable routes between them.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] interface loopback 1
    [SwitchA-LoopBack1] ip address 10.4.4.9 32
    [SwitchA-LoopBack1] quit
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.4.4.9 0.0.0.0
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] interface loopback 1
    [SwitchB-LoopBack1] ip address 10.2.2.9 32
    [SwitchB-LoopBack1] quit
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.1.2 24
    [SwitchB-Vlanif100] quit
    [SwitchB] vlan 110
    [SwitchB-vlan110] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 110
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface vlanif 110
    [SwitchB-Vlanif110] ip address 10.2.1.1 24
    [SwitchB-Vlanif110] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.2.2.9 0.0.0.0
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] interface loopback 1
    [SwitchC-LoopBack1] ip address 10.3.3.9 32
    [SwitchC-LoopBack1] quit
    [SwitchC] vlan 110
    [SwitchC-vlan110] quit
    [SwitchC] interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1] port link-type trunk
    [SwitchC-GigabitEthernet0/0/1] port trunk allow-pass vlan 110
    [SwitchC-GigabitEthernet0/0/1] quit
    [SwitchC] interface vlanif 110
    [SwitchC-Vlanif110] ip address 10.2.1.2 24
    [SwitchC-Vlanif110] quit
    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.3.3.9 0.0.0.0
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

  2. Configure MPLS LDP on SwitchA, SwitchB, and SwitchC.

    # Configure SwitchA.

    [SwitchA] mpls lsr-id 10.4.4.9
    [SwitchA] mpls
    [SwitchA-mpls] quit
    [SwitchA] mpls ldp
    [SwitchA-mpls-ldp] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] mpls
    [SwitchA-Vlanif100] mpls ldp
    [SwitchA-Vlanif100] quit
    

    # Configure SwitchB.

    [SwitchB] mpls lsr-id 10.2.2.9
    [SwitchB] mpls
    [SwitchB-mpls] quit
    [SwitchB] mpls ldp
    [SwitchB-mpls-ldp] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] mpls
    [SwitchB-Vlanif100] mpls ldp
    [SwitchB-Vlanif100] quit
    [SwitchB] interface vlanif 110
    [SwitchB-Vlanif110] mpls
    [SwitchB-Vlanif110] mpls ldp
    [SwitchB-Vlanif110] quit
    

    # Configure SwitchC.

    [SwitchC] mpls lsr-id 10.3.3.9
    [SwitchC] mpls
    [SwitchC-mpls] quit
    [SwitchC] mpls ldp
    [SwitchC-mpls-ldp] quit
    [SwitchC] interface vlanif 110
    [SwitchC-Vlanif110] mpls
    [SwitchC-Vlanif110] mpls ldp
    [SwitchC-Vlanif110] quit
    

  3. View session information between LDP peers to check whether LDP sessions have been established.

    # When the status of an LDP session is Operational, the LDP session is successfully established. The display on SwitchA is used as an example.

    [SwitchA] display mpls ldp session
     
     LDP Session(s) in Public Network   
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)    
     A '*' before a session means the session is being deleted.   
     ------------------------------------------------------------------------------  
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv    
     ------------------------------------------------------------------------------ 
     10.2.2.9:0         Operational DU   Active   0000:00:03  15/15             
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.    
    

  4. Configure SwitchA.

    # Enable the NQA client and create an LSP Ping test instance for checking the common tunnel.

    [SwitchA] nqa test-instance admin lspping
    [SwitchA-nqa-admin-lspping] test-type lspping
    [SwitchA-nqa-admin-lspping] lsp-type ipv4
    [SwitchA-nqa-admin-lspping] destination-address ipv4 10.3.3.9 lsp-masklen 32

  5. Start the test instance.

    [SwitchA-nqa-admin-lspping] start now

  6. Verify the test result.

    [SwitchA-nqa-admin-lspping] display nqa results test-instance admin lspping
    
     NQA entry(admin, lspping) :testflag is inactive ,testtype is  lspping
      1 . Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3               
       Completion:success                   RTD OverThresholds number: 0            
       Attempts number:1                    Drop operation number:0                 
       Disconnect operation number:0        Operation timeout number:0              
       System busy operation number:0       Connection fail number:0                
       Operation sequence errors number:0   RTT Status errors number:0              
       Destination ip address:10.3.3.9                                               
       Min/Max/Average Completion Time: 3/9/7                                       
       Sum/Square-Sum  Completion Time: 21/171                                      
       Last Good Probe Time: 2012-11-16 21:52:57.3                                  
       Lost packet ratio: 0 %    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    mpls lsr-id 10.4.4.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 10.4.4.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.4.4.9 0.0.0.0
    #
    nqa test-instance admin lspping
     test-type lspping
     destination-address ipv4 10.3.3.9 lsp-masklen 32
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    # 
    vlan batch 100 110
    #
    mpls lsr-id 10.2.2.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 110
    #
    interface LoopBack1
     ip address 10.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
      network 10.2.2.9 0.0.0.0
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    mpls lsr-id 10.3.3.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 110
    #
    interface LoopBack1
     ip address 10.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.2.1.0 0.0.0.255
      network 10.3.3.9 0.0.0.0
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065680

Views: 58871

Downloads: 516

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next