No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, NetStream, sFlow, TWAMP Light, NETCONF, ECA, Intelligent Video O&M, eMDI, and Network Deception.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the NMS to Manage Switches in NETCONF over SSH Callhome Mode

Example for Configuring the NMS to Manage Switches in NETCONF over SSH Callhome Mode

Networking Requirements

On an enterprise network shown in Figure 13-4, the Huawei Agile Controller-Campus is used as the NMS. The administrator configures and manages the switches on the NMS, improving network configuration and maintenance efficiency.

Figure 13-4  Enterprise network topology

Configuration Roadmap

Configure NETCONF connections between the NMS and switches so that you can configure and manage the switches using NETCONF. The following uses SwitchA as an example. The configuration of SwitchB is similar to that of SwitchA, and is not mentioned here.

  1. Configure interfaces and VLANs. Configure reachable routes between switches and NMS. The configuration procedure is not provided here.
  2. Configure NETCONF on the switch.
  3. Configure Agile Controller-Campus.

Procedure

  1. Configure interfaces and VLANs.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface Vlanif10
    [SwitchA-Vlanif10] ip address 192.168.10.1 24
    [SwitchA-Vlanif10] quit

  2. Configure NETCONF on the switch.

    [SwitchA] netconf
    [SwitchA-netconf] source ip 192.168.10.1
    [SwitchA-netconf] callhome controller
    [SwitchA-netconf-callhome-controller] ip address 192.168.30.1 port 830   //The port number must be the same as that used by the Agile Controller-Campus.
    [SwitchA-netconf-callhome-controller] return

  3. Configure the Agile Controller-Campus.
    1. Log in to the Agile Controller-Campus. Open Internet Explorer and enter Agile Controller-Campus in the address box. On the login page, enter the user name and password to log in to the Agile Controller-Campus.
    2. Run the display esn command in any view to obtain the Equipment Serial Number (ESN) of the switch.

      <SwitchA> display esn
      ESN of slot 0: 2102350DMP10XXXXXXXX

    3. Choose Network > Physical Resources > Device Management. Click Add Device, configure Device name and Device ESN, and click OK. The device is added.

    4. Refresh the page after a few seconds. The Status of SwitchA is Normal, indicating that SwitchA communicates with the Agile Controller-Campus normally.

Configuration Files

  • #
    sysname SwitchA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.10.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    netconf
     callhome controller
      ip address 192.168.30.1 port 830
     source ip 192.168.10.1
    #
    return
  • Switch B configuration file
    #
    sysname SwitchB
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 192.168.20.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    netconf
     callhome controller
      ip address 192.168.30.1 port 830
     source ip 192.168.20.1
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065680

Views: 50991

Downloads: 485

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next