No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, NetStream, sFlow, TWAMP Light, NETCONF, ECA, Intelligent Video O&M, eMDI, and Network Deception.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a DNS Test Instance

Example for Configuring a DNS Test Instance

Networking Requirements

In Figure 6-20, SwitchA functions as a DNS client to access the host 10.2.1.1/24, using a domain name server.com.

Figure 6-20  Networking diagram for configuring a DNS test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client.

  2. Create and start a DNS test instance on the SwitchA to check whether SwitchA can set up a connection with the DNS server and to obtain the speed of responding to an address resolution request.

Procedure

  1. Configure IP addresses for the interfaces on the SwitchA and ensure reachable routes between SwitchA and server.com, SwitchA and the DNS server.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit

  2. Configure an NQA DNS test instance.

    [SwitchA] dns resolve
    [SwitchA] dns server 10.3.1.1
    [SwitchA] nqa test-instance admin dns
    [SwitchA-nqa-admin-dns] test-type dns
    [SwitchA-nqa-admin-dns] dns-server ipv4 10.3.1.1
    [SwitchA-nqa-admin-dns] destination-address url server.com

  3. Start the test instance.

    [SwitchA-nqa-admin-dns] start now

  4. Verify the configuration.

    [SwitchA-nqa-admin-dns] display nqa results test-instance admin dns
    [SwitchA-nqa-admin-dns] display nqa results test-instance admin dns
    
     NQA entry(admin, dns) :testflag is inactive ,testtype is dns
      1 . Test 1 result   The test is finished
       Send operation times: 1              Receive response times: 1
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:1                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Status errors number:0
       Destination ip address: 10.3.1.1
       Min/Max/Average Completion Time: 1/1/1
       Sum/Square-Sum  Completion Time: 1/1
       Last Good Probe Time: 2012-07-20 16:23:49.1
       Lost packet ratio: 0 %

Configuration Files

SwitchA configuration file

#
sysname SwitchA
#
dns resolve
dns server 10.3.1.1
#
vlan batch 100
#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 100
 port hybrid untagged vlan 100
#
nqa test-instance admin dns
 test-type dns
 destination-address url server.com
 dns-server ipv4 10.3.1.1
#
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065680

Views: 51026

Downloads: 485

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next