No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, NetStream, sFlow, TWAMP Light, NETCONF, ECA, Intelligent Video O&M, eMDI, and Network Deception.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Trace Test Instance

Example for Configuring a Trace Test Instance

Networking Requirements

In Figure 6-28, a trace test needs to be performed to trace the IP address of VLANIF110 of SwitchC on SwitchA.

Figure 6-28  Networking diagram for configuring a trace test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client.

  2. Create and start a trace test instance on SwitchA to obtain statistics about each hop from SwitchA to SwitchC.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between switches.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] vlan 110
    [SwitchB-vlan110] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.1.2 24
    [SwitchB-Vlanif100] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet0/0/2] port hybrid pvid vlan 110
    [SwitchB-GigabitEthernet0/0/2] port hybrid untagged vlan 110
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface vlanif 110
    [SwitchB-Vlanif110] ip address 10.2.1.1 24
    [SwitchB-Vlanif110] quit
    

    # Configure SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan 110
    [SwitchC-vlan110] quit
    [SwitchC] interface gigabitethernet 0/0/1
    [SwitchC-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchC-GigabitEthernet0/0/1] port hybrid pvid vlan 110
    [SwitchC-GigabitEthernet0/0/1] port hybrid untagged vlan 110
    [SwitchC-GigabitEthernet0/0/1] quit
    [SwitchC] interface vlanif 110
    [SwitchC-Vlanif110] ip address 10.2.1.2 24
    [SwitchC-Vlanif110] quit
    [SwitchC] ip route-static 10.1.1.0 255.255.255.0 10.2.1.1

  2. Create an NQA trace test instance on SwitchA and set the destination IP address to 10.2.1.2.

    [SwitchA] nqa test-instance admin trace
    [SwitchA-nqa-admin-trace] test-type trace
    [SwitchA-nqa-admin-trace] destination-address ipv4 10.2.1.2

  3. Start the test instance.

    [SwitchA-nqa-admin-trace] start now

  4. Check the configuration.

    # Check NQA test results on SwitchA.

    [SwitchA-nqa-admin-trace] display nqa results test-instance admin trace
     NQA entry(admin, trace) :testflag is inactive ,testtype is trace
      1 . Test 1 result   The test is finished
       Completion:success                   Attempts number:1
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Status errors number:0
       Drop operation number:0
       Last good path Time:2012-07-17 11:21:27.2
       1 . Hop 1
        Send operation times: 3              Receive response times: 3
        Min/Max/Average Completion Time: 1/1/1
        Sum/Square-Sum  Completion Time: 3/3
        RTD OverThresholds number: 0
        Last Good Probe Time: 2012-07-17 11:21:27.2
        Destination ip address:10.1.1.2
        Lost packet ratio: 0 %  
       2 . Hop 2 
        Send operation times: 3              Receive response times: 3              
        Min/Max/Average Completion Time: 15/30/23                                 
        Sum/Square-Sum  Completion Time: 70/1750                                  
        RTD OverThresholds number: 0                                              
        Last Good Probe Time: 2012-07-17 11:22:13.2                               
        Destination ip address:10.2.1.2                                           
        Lost packet ratio: 0 % 
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin trace
     test-type trace
     destination-address ipv4 10.2.1.2
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065680

Views: 57685

Downloads: 514

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next