No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Network Management and Monitoring

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of Network Management and Monitoring, including SNMP, RMON, RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, NetStream, sFlow, TWAMP Light, NETCONF, ECA, Intelligent Video O&M, eMDI, and Network Deception.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the PWE3 Trace Test on a Single-Hop PW

Example for Configuring the PWE3 Trace Test on a Single-Hop PW

Networking Requirements

In Figure 6-41, CE-A and CE-B are respectively connected to PE-A and PE-B through VLAN. PE-A and PE-B are connected through the MPLS backbone network. A dynamic PW needs to be set up between PE-A and PE-B through the LSP tunnel.

The PWE3 Trace function of the single-hop PW needs to be performed to test the connectivity of the PW between PE-A and PE-B.

Figure 6-41  Networking diagram for configuring the PWE3 Trace test on a single-hop PW

Configuration Roadmap

The configuration roadmap is as follows:

  1. Run the IGP protocol on the backbone network to make the routes between Switches on the backbone network reachable.

  2. Configure the basic MPLS functions on the backbone network and set up an LSP tunnel. Set up the MPLS LDP peer relationship between the two PE devices on the two ends of the PW.

  3. Create an MPLS L2VC connection between the two PE devices.

  4. Configure a PWE3 Trace test on a single-hop PW on PE-A.

Procedure

  1. Configure a dynamic single-hop PW.

    Configure a dynamic single-hop PW on the MPLS backbone network. For the detailed configuration procedure, see PWE3 Configuration in the S2720, S5700, and S6720 V200R013C00 Configuration Guide - VPN.

  2. Configure a PWE3 Trace test of the single-hop PW.

    # Configure PE-A.

    <HUAWEI> system-view
    [HUAWEI] sysname PE-A
    [PE-A] nqa test-instance test pwe3trace
    [PE-A-nqa-test-pwe3trace] test-type pwe3trace
    [PE-A-nqa-test-pwe3trace] local-pw-type vlan
    [PE-A-nqa-test-pwe3trace] local-pw-id 100

  3. Perform the test.

    [PE-A-nqa-test-pwe3trace] start now

  4. Verify the test result.

    Run the display nqa history command on the PE device, and you can see that the status is success.

    [PE-A-nqa-test-pwe3trace] display nqa history
     NQA entry(test, pwe3trace) history:                                                       
     Index  T/H/P     Response Status        Address        Time                    
     1      1/1/1          4ms success       10.1.1.2       2012-09-30 09:33:03.301    
     2      1/1/2          5ms success       10.1.1.2       2012-09-30 09:33:03.307    
     3      1/1/3          3ms success       10.1.1.2       2012-09-30 09:33:03.311    
     4      1/2/1          6ms success       10.3.3.3      2012-09-30 09:33:03.318    
     5      1/2/2          6ms success       10.3.3.3      2012-09-30 09:33:03.324    
     6      1/2/3          6ms success       10.3.3.3      2012-09-30 09:33:03.331    
    

    After running the display nqa results command on the PE device, you can see that the test is success.

    [PE-A-nqa-test-pwe3trace] display nqa results
    NQA entry(test, pwe3trace) :testflag is inactive ,testtype is  pwe3trace
      1 . Test 1 result   The test is finished
       Completion:success                    Attempts number:1
       Disconnect operation number:0         Operation timeout number:0
       System busy operation number:0        Connection fail number:0
       Operation sequence errors number:0    RTT Status errors number:0
       Drop operation number:0
       Last good path Time:2012-09-24 11:22:21.2
       1 . Hop 1
        Send operation times: 3              Receive response times: 3
        Min/Max/Average Completion Time: 1050/1090/1053
        Sum/Square-Sum  Completion Time: 3160/3331000
        RTD OverThresholds number: 0
        Last Good Probe Time: 2012-09-24 11:22:17.2
        Destination ip address:10.1.1.2
        Lost packet ratio: 0 %
       2 . Hop 2
        Send operation times: 3               Receive response times: 3
        Min/Max/Average Completion Time: 1050/1490/1323
        Sum/Square-Sum  Completion Time: 3970/5367500
        RTD OverThresholds number: 0
        Last Good Probe Time: 2012-09-24 11:22:21.2
        Destination ip address:10.3.3.3
        Lost packet ratio: 0 %

Configuration Files

  • CE-A configuration file

    #    
    sysname CE-A
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.10.1.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 110
    #
    return
    
  • PE-A configuration file

    #
    sysname PE-A
    #
    vlan batch 110 120
    #
    mpls lsr-id 10.2.2.2
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
    #
    mpls ldp remote-peer 10.3.3.3
     remote-ip 10.3.3.3 
    #
    interface Vlanif110
     mpls l2vc 10.3.3.3 100 control-word
    #
    interface Vlanif120
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface  GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    interface  GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 120
     port hybrid untagged vlan 120
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
    #
    nqa test-instance test pwe3trace
     test-type pwe3trace
     local-pw-id 100
     local-pw-type vlan
    #
    ospf 1
     area 0.0.0.0
      network 10.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • P configuration file

    #
    sysname P
    #
    vlan batch 120 130
    #
    mpls lsr-id 10.4.4.4
    mpls
    #
    mpls ldp
    #
    interface Vlanif120
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif130
     ip address 10.2.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface  GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 120
     port hybrid untagged vlan 120
    #
    interface  GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 130
     port hybrid untagged vlan 130
    #
    interface LoopBack0
     ip address 10.4.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.4.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
  • PE-B configuration file

    #
    sysname PE-B
    #
    vlan batch 130 140
    #
    mpls lsr-id 10.3.3.3
    mpls
    #
    mpls l2vpn
    #
    mpls ldp
    #
    mpls ldp remote-peer 10.2.2.2
     remote-ip 10.2.2.2
    #
    interface Vlanif130
     ip address 10.2.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif140
     mpls l2vc 10.2.2.2 100 control-word
    #
    interface  GigabitEthernet0/0/1
     port link-type hybrid
     port hybrid pvid vlan 140
     port hybrid untagged vlan 140
    #
    interface  GigabitEthernet0/0/2
     port link-type hybrid
     port hybrid pvid vlan 130
     port hybrid untagged vlan 130
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.3.3.3 0.0.0.0
      network 10.2.2.0 0.0.0.255
    #
    return
    
  • CE-B configuration file

    #
    sysname CE-B
    #
    vlan batch 140
    #
    interface Vlanif140
     ip address 10.10.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 140
    #
    return
    
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065680

Views: 59541

Downloads: 516

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next