No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

S2720, S5700, and S6720 V200R013C00

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, MAC Swap Loopback Configuration, EFM Configuration, CFM Configuration, Y.1731 Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Single-ended SLM in a VLAN

Example for Configuring Single-ended SLM in a VLAN

Networking Requirements

As networks rapidly develop, various value-added services, such as Internet Protocol television (IPTV), video conferencing, and voice over Internet Protocol (VoIP), are more widely used than ever before. Any link connectivity fault or network performance deterioration directly affects service quality on a live network, making performance monitoring on the pipes that transmit these services absolutely essential.

On the point-to-multipoint network shown in Figure 9-14, PE1 and PE2 are connected through a VLAN. A carrier wants to collect accurate performance statistics about LM on the link between CE1 and CE2. To monitor network performance in real time, the carrier can configure single-ended SLM on the VLAN. This configuration allows the carrier to immediately adjust the network in case of voice quality deterioration.

Figure 9-14  Single-ended SLM in VLAN networking

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure on-demand single-ended SLM on the link between CEs to periodically detect and count packet loss ratios.

  2. Configure proactive single-ended SLM on the link between CEs to continuously detect and count packet loss ratios.

Procedure

  1. Configure on-demand single-ended SLM.

    1. Configure basic Ethernet connectivity fault management (CFM) functions and set the maintenance association end point (MEP) type to outward.

      Configure basic Ethernet CFM functions on each CE. Specify the Ethernet CFM protocol as IEEE Standard 802.1ag-2007. Create an MD named md3 and an MA named ma3, and bind the MA to the VLAN.

      # Configure CE1.

      <HUAWEI> system-view
      [HUAWEI] sysname CE1
      [CE1] vlan batch 2
      [CE1] interface gigabitethernet 0/0/1
      [CE1-GigabitEthernet0/0/1] port link-type trunk
      [CE1-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
      [CE1-GigabitEthernet0/0/1] quit
      [CE1] set service-mode enhanced
      Warning: This command will effect forward performance. Continue? [Y/N]:y
      [CE1] cfm enable
      [CE1] cfm version standard
      [CE1] cfm md md3
      [CE1-md-md3] ma ma3
      [CE1-md-md3-ma-ma3] map vlan 2
      [CE1-md-md3-ma-ma3] mep mep-id 3 interface gigabitethernet 0/0/1 outward
      [CE1-md-md3-ma-ma3] mep ccm-send mep-id 3 enable
      [CE1-md-md3-ma-ma3] remote-mep mep-id 4
      [CE1-md-md3-ma-ma3] remote-mep ccm-receive mep-id 4 enable
      [CE1-md-md3-ma-ma3] test-id 1 mep 3 remote-mep 4

      # Configure CE2.

      <HUAWEI> system-view
      [HUAWEI] sysname CE2
      [CE2] vlan batch 2
      [CE2] interface gigabitethernet 0/0/1
      [CE2-GigabitEthernet0/0/1] port link-type trunk
      [CE2-GigabitEthernet0/0/1] port trunk allow-pass vlan 2
      [CE2-GigabitEthernet0/0/1] quit
      [CE2] set service-mode enhanced
      Warning: This command will effect forward performance. Continue? [Y/N]:y
      [CE2] cfm enable
      [CE2] cfm version standard
      [CE2] cfm md md3
      [CE2-md-md3] ma ma3
      [CE2-md-md3-ma-ma3] map vlan 2
      [CE2-md-md3-ma-ma3] mep mep-id 4 interface gigabitethernet 0/0/1 outward
      [CE2-md-md3-ma-ma3] mep ccm-send mep-id 4 enable
      [CE2-md-md3-ma-ma3] remote-mep mep-id 3
      [CE2-md-md3-ma-ma3] remote-mep ccm-receive mep-id 3 enable
      [CE2-md-md3-ma-ma3] test-id 1 mep 4 remote-mep 3
    2. Enable CE2 to receive SLM frames.

      [CE2-md-md3-ma-ma3] loss-measure single-ended-synthetic receive test-id 1 time-out 300
      [CE2-md-md3-ma-ma3] quit
      [CE2-md-md3] quit
    3. Configure on-demand single-ended SLM on CE1.

      [CE1-md-md3-ma-ma3] loss-measure single-ended-synthetic send test-id 1 interval 1000 sending-count 10 time-out 2
      [CE1-md-md3-ma-ma3] quit
      [CE1-md-md3] quit
    4. Verify the configuration.

      # Run the display y1731 statistic-type command on CE1 to view statistics about on-demand single-ended SLM.

      [CE1] display y1731 statistic-type single-synthetic-loss test-id 1
      Measurement Start Time : 2017-07-29 13:22:49
      --------------------------------------------------------------------------------
      Index       L-send R-send L-recv Unack  L-loss R-loss L-loss-ratio R-loss-ratio
      --------------------------------------------------------------------------------
      1           10     10     10     0           0      0      0.0000%      0.0000%
      --------------------------------------------------------------------------------
      Average Local-loss  :          0    Average Local-loss Ratio  :         0.0000%
      Maximum Local-loss  :          0    Maximum Local-loss Ratio  :         0.0000%
      Minimum Local-loss  :          0    Minimum Local-loss Ratio  :         0.0000%
      Average Remote-loss :          0    Average Remote-loss Ratio :         0.0000%
      Maximum Remote-loss :          0    Maximum Remote-loss Ratio :         0.0000%
      Minimum Remote-loss :          0    Minimum Remote-loss Ratio :         0.0000%

  2. Configure proactive single-ended SLM.

    1. Configure proactive single-ended SLM on CE1.

      [CE1] cfm md md3
      [CE1-md-md3] ma ma3
      [CE1-md-md3-ma-ma3] loss-measure single-ended-synthetic continual send test-id 1 interval 1000
      [CE1-md-md3-ma-ma3] quit
      [CE1-md-md3] quit
    2. Verify the configuration.

      # Run the display y1731 statistic-type command on CE1 to view statistics about proactive single-ended SLM.

      [CE1] display y1731 statistic-type single-synthetic-loss test-id 1
      --------------------------------------------------------------------------------
      Index       L-send R-send L-recv Unack  L-loss R-loss L-loss-ratio R-loss-ratio
      --------------------------------------------------------------------------------
      1           10     10     10     0           0      0      0.0000%      0.0000%
      2           10     10     10     0           0      0      0.0000%      0.0000%
      3           10     10     10     0           0      0      0.0000%      0.0000%
      4           10     10     10     0           0      0      0.0000%      0.0000%
      5           10     10     10     0           0      0      0.0000%      0.0000%
      6           10     10     10     0           0      0      0.0000%      0.0000%
      --------------------------------------------------------------------------------
      Average Local-loss  :          0    Average Local-loss Ratio  :         0.0000%
      Maximum Local-loss  :          0    Maximum Local-loss Ratio  :         0.0000%
      Minimum Local-loss  :          0    Minimum Local-loss Ratio  :         0.0000%
      Average Remote-loss :          0    Average Remote-loss Ratio :         0.0000%
      Maximum Remote-loss :          0    Maximum Remote-loss Ratio :         0.0000%
      Minimum Remote-loss :          0    Minimum Remote-loss Ratio :         0.0000%

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 3 interface GigabitEthernet0/0/1 outward
      mep ccm-send mep-id 3 enable
      remote-mep mep-id 4
      remote-mep ccm-receive mep-id 4 enable
      test-id 1 mep 3 remote-mep 4
      loss-measure single-ended-synthetic continual send test-id 1 interval 1000 
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 4 interface GigabitEthernet0/0/1 outward
      mep ccm-send mep-id 4 enable
      remote-mep mep-id 3
      remote-mep ccm-receive mep-id 3 enable
      test-id 1 mep 4 remote-mep 3
      loss-measure single-ended-synthetic receive test-id 1
    #
    return
Translation
Download
Updated: 2019-04-04

Document ID: EDOC1100065682

Views: 26800

Downloads: 235

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next