No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Device Management

S7700 and S9700 V200R013C00

This document describes the configurations of Device Management, including device status query, hardware management, CSS, SVF, PoE, OPS, OIDS, energy-saving management, information center, fault management, NTP, synchronous ethernet, PTP.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the NTP Multicast Mode

Example for Configuring the NTP Multicast Mode

Networking Requirements

In Figure 12-14, SwitchA, SwitchB, and SwitchC are located within the same LAN. SwitchC synchronizes its clock with GPS through radio.

To ensure accounting accuracy, all switches on the LAN require clock synchronization with the clock of SwitchC.

Figure 12-14  Configuring the NTP multicast mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchC as the master clock server, use its local clock as the NTP master clock, and set the clock stratum to 2.

  2. Configure SwitchC as the NTP multicast server that sends multicast packets through VLANIF 10 (the corresponding physical interface is GE1/0/1).

  3. Configure SwitchA and SwitchB as NTP multicast clients. Configure SwitchA to listen to multicast packets on VLANIF 10 (the corresponding physical interface is GE1/0/2). Configure SwitchB to listen to multicast packets on VLANIF 10 (the corresponding physical interface is GE1/0/1).

Procedure

  1. Configure an IP address for each interface according to Figure 12-14 and ensure that the switches have reachable routes to each other.

    # Configure an IP address and a routing protocol on SwitchB. The configurations of SwitchC and SwitchA are similar to the configuration of SwitchB, and are not mentioned here. For details, see the configuration files.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 10 
    [SwitchB-vlan10] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ip address 10.1.1.1 24
    [SwitchB-Vlanif10] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit
    

  2. Configure Layer 2 forwarding on the Switch.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type hybrid
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type hybrid
    [Switch-GigabitEthernet1/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet1/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet1/0/3] quit

  3. Configure the NTP multicast server.

    # Configure the local clock of SwitchC as the NTP master clock, and set the clock stratum to 2.

    [SwitchC] ntp-service refclock-master 2

    # Configure SwitchC as the NTP multicast server that sends NTP multicast packets through VLANIF 10.

    [SwitchC] interface vlanif 10
    [SwitchC-Vlanif10] ntp-service multicast-server
    [SwitchC-Vlanif10] quit

    # Enable the NTP server function on SwitchC.

    [SwitchC] undo ntp-service server disable

  4. Configure SwitchA and SwitchB as NTP multicast clients, which are on the same network segment as the NTP multicast server.

    # Configure SwitchA as an NTP multicast client that listens to NTP multicast packets on VLANIF 10.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ntp-service multicast-client
    [SwitchA-Vlanif10] quit

    # Configure SwitchB as an NTP multicast client that listens to NTP multicast packets on VLANIF 10.

    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ntp-service multicast-client
    [SwitchB-Vlanif10] quit

  5. Verify the configuration.

    After the configuration is complete, SwitchA and SwitchB can synchronize their clocks with the clock of SwitchC.

    # Check the NTP status of SwitchC. The clock stratum is 2 and the reference clock is LOCAL, indicating that the local clock functions as the reference clock.

    [SwitchC] display ntp-service status
     clock status: synchronized
     clock stratum: 2
     reference clock ID: LOCAL(0)                                                   
     nominal frequency: 100.0000 Hz                                                 
     actual frequency: 100.0000 Hz                                                  
     clock precision: 2^17                                                          
     clock offset: 0.0000 ms                                                        
     root delay: 0.00 ms                                                            
     root dispersion: 10.95 ms                                                      
     peer dispersion: 10.00 ms                                                      
     reference time: 12:25:19.710 UTC Nov 19 2013(D635D72F.B5F41AEF)                
     synchronization state: clock synchronized 

    # Check the NTP status of SwitchA. The clock status is synchronized, indicating that the clock synchronization is complete. The clock stratum is 3, which is one stratum lower than that of the NTP server SwitchC.

    [SwitchA] display ntp-service status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 10.1.3.2
     nominal frequency: 60.0002 Hz
     actual frequency: 60.0002 Hz
     clock precision: 2^18
     clock offset: 0.0000 ms
     root delay: 40.00 ms
     root dispersion: 4.38 ms
     peer dispersion: 34.30 ms
     reference time: 12:17:21.773 UTC Mar 7 2013(C7B7F851.C5EAF25B)
     synchronization state: clock synchronized 

    # Check the NTP status of SwitchB. The clock status is synchronized, indicating that the clock synchronization is complete. The clock stratum is 3, which is one stratum lower than that of the NTP server SwitchC.

    [SwitchB] display ntp-service status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 10.1.3.2
     nominal frequency: 60.0002 Hz
     actual frequency: 60.0002 Hz
     clock precision: 2^18
     clock offset: 0.0000 ms
     root delay: 0.00 ms
     root dispersion: 0.42 ms
     peer dispersion: 0.00 ms
     reference time: 12:17:21.773 UTC Mar 7 2013(C7B7F851.C5EAF25B)
     synchronization state: clock synchronized 

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    ntp-service server disable
    ntp-service ipv6 server disable 
    #
    interface Vlanif10
     ip address 10.1.3.1 255.255.255.0
     ntp-service multicast-client
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    ospf 1     
     area 0.0.0.0   
      network 10.1.1.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    ntp-service server disable
    ntp-service ipv6 server disable 
    #
    interface Vlanif10
     ip address 10.1.3.3 255.255.255.0
     ntp-service multicast-client 
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    ospf 1              
     area 0.0.0.0  
      network 10.1.3.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 10
    #
    ntp-service ipv6 server disable 
    ntp-service refclock-master 2
    #
    interface Vlanif10
     ip address 10.1.3.2 255.255.255.0
     ntp-service multicast-server
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    ospf 1          
     area 0.0.0.0      
      network 10.1.3.0 0.0.0.255
    #
    return
  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface GigabitEthernet1/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065738

Views: 41075

Downloads: 37

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next