No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R013C00

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, IPv4 PIM, IPv6 PIM, MSDP, multicast VPN, layer 3 multicast CAC, IPv4 multicast route management, IPv6 multicast route management, IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, layer 2 multicast CAC, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Interface-based Multicast VLAN Replication

Example for Configuring Interface-based Multicast VLAN Replication

Networking Requirements

In Figure 14-4, GE1/0/0 on SwitchA is connected to the Router. GE2/0/0 provides services for ISP1, and GE3/0/0 provides services for ISP2. ISP1 and ISP2 use multicast VLAN 2 and VLAN 3 respectively to provide multicast services for users. GE2/0/0 and GE3/0/0 have the same user VLAN (VLAN 10).

To ensure that multicast packets of each ISP are sent only to users of the ISP, interface-based multicast VLAN replication is required. After the configuration is complete, multicast data of an ISP will be sent only to the interface connected to the ISP.

Figure 14-4  Configuring interface-based multicast VLAN replication

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable Internet Group Management Protocol (IGMP) snooping in the system view.
  2. Create user VLAN 10.
  3. Create multicast VLANs 2 and 3 and enable IGMP snooping in the multicast VLANs.
  4. Bind user VLAN 10 to multicast VLANs on GE2/0/0 and GE3/0/0 respectively.
  5. Add the network-side interface and user-side interfaces to the VLANs as hybrid interfaces.

Procedure

  1. Create user VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10

  2. Create multicast VLANs 2 and 3, and enable the IGMP snooping and IGMP snooping querier functions in the multicast VLANs.

    NOTE:
    It is recommended that you configure igmp-snooping querier enable in the multicast VLAN view. If the Router is the gateway with IGMP enabled, you do not need to perform this configuration.
    [SwitchA] igmp-snooping enable
    [SwitchA] vlan 2
    [SwitchA-vlan2] igmp-snooping enable
    [SwitchA-vlan2] igmp-snooping querier enable
    [SwitchA-vlan2] quit
    [SwitchA] vlan 3
    [SwitchA-vlan3] igmp-snooping enable
    [SwitchA-vlan3] igmp-snooping querier enable
    [SwitchA-vlan3] quit

  3. Bind user VLAN 10 to multicast VLANs on GE2/0/0 and GE3/0/0 respectively.

    [SwitchA] interface gigabitethernet 2/0/0
    [SwitchA-GigabitEthernet2/0/0] l2-multicast-bind vlan 10 mvlan 2
    [SwitchA-GigabitEthernet2/0/0] quit
    [SwitchA] interface gigabitethernet 3/0/0
    [SwitchA-GigabitEthernet3/0/0] l2-multicast-bind vlan 10 mvlan 3
    [SwitchA-GigabitEthernet3/0/0] quit

  4. Add GE1/0/0 to the multicast VLANs. Add GE2/0/0 and GE3/0/0 to the user VLAN.

    # Add GE1/0/0 to multicast VLANs 2 and 3 as a trunk interface.

    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 2 3 
    [SwitchA-GigabitEthernet1/0/0] quit

    # Add GE2/0/0 and GE3/0/0 respectively to user VLAN 10 as hybrid interfaces.

    [SwitchA] interface gigabitethernet 2/0/0
    [SwitchA-GigabitEthernet2/0/0] port link-type hybrid
    [SwitchA-GigabitEthernet2/0/0] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet2/0/0] port hybrid untagged vlan 10 
    [SwitchA-GigabitEthernet2/0/0] quit
    [SwitchA] interface gigabitethernet 3/0/0
    [SwitchA-GigabitEthernet3/0/0] port link-type hybrid
    [SwitchA-GigabitEthernet3/0/0] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet3/0/0] port hybrid untagged vlan 10 
    [SwitchA-GigabitEthernet3/0/0] quit

  5. Verify the configuration.

    Run the display l2-multicast-bind command on SwitchA to view binding between the user VLAN and multicast VLANs.

    [SwitchA] display l2-multicast-bind
     -------------------------------------------------------------------            
     Port                          Startvlan        Endvlan        Mvlan            
     -------------------------------------------------------------------            
     GigabitEthernet2/0/0                 10             --            2            
     GigabitEthernet3/0/0                 10             --            3            
     -------------------------------------------------------------------            
     Total Table(s) : 2

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 2 to 3 10
    #
    igmp-snooping enable
    #
    vlan 2
     igmp-snooping enable
     igmp-snooping querier enable
    vlan 3
     igmp-snooping enable
     igmp-snooping querier enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface GigabitEthernet2/0/0
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast-bind vlan 10 mvlan 2
    #
    interface GigabitEthernet3/0/0
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast-bind vlan 10 mvlan 3
    #
    return
    
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065742

Views: 48014

Downloads: 46

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next