No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R013C00

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, IPv4 PIM, IPv6 PIM, MSDP, multicast VPN, layer 3 multicast CAC, IPv4 multicast route management, IPv6 multicast route management, IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, layer 2 multicast CAC, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Layer 2 Multicast Through Static Ports in a VLAN

Example for Configuring Layer 2 Multicast Through Static Ports in a VLAN

Networking Requirements

As shown in Figure 11-10, the router connects to user hosts through a Layer 2 switch. The user-side VLANIF interface of the router is bound to static groups 225.1.1.1-225.1.1.5 and does not run IGMP. HostA and HostB expect to receive data of multicast groups 225.1.1.1-225.1.1.3 for a long time. HostC and HostD expect to receive data of multicast groups 225.1.1.4 and 225.1.1.5.

Figure 11-10  Network diagram for static port configuration

Configuration Roadmap

To meet the preceding requirements, configure a static router port and static member ports of IGMP snooping on the Layer 2 switch. The configuration roadmap is as follows:

  1. Create a VLAN and add interfaces to the VLAN.
  2. Enable IGMP snooping globally and in the VLAN.
  3. Configure a static router port.
  4. Configure static member ports.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/2
    [Switch-GigabitEthernet2/0/2] port link-type hybrid
    [Switch-GigabitEthernet2/0/2] port hybrid pvid vlan 10
    [Switch-GigabitEthernet2/0/2] port hybrid untagged vlan 10
    [Switch-GigabitEthernet2/0/2] quit
    [Switch] interface gigabitethernet 3/0/3
    [Switch-GigabitEthernet3/0/3] port link-type hybrid
    [Switch-GigabitEthernet3/0/3] port hybrid pvid vlan 10
    [Switch-GigabitEthernet3/0/3] port hybrid untagged vlan 10
    [Switch-GigabitEthernet3/0/3] quit

  2. Enable IGMP snooping.

    # Enable IGMP snooping globally.

    [Switch] igmp-snooping enable

    # Enable IGMP snooping in VLAN 10.

    [Switch] vlan 10
    [Switch-vlan10] igmp-snooping enable
    [Switch-vlan10] quit

  3. Configure a static router port.

    [Switch] interface gigabitethernet 3/0/3
    [Switch-GigabitEthernet3/0/3] igmp-snooping static-router-port vlan 10
    [Switch-GigabitEthernet3/0/3] quit
    

  4. Configure static member ports.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] l2-multicast static-group group-address 225.1.1.1 to 225.1.1.3 vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/2
    [Switch-GigabitEthernet2/0/2] l2-multicast static-group group-address 225.1.1.4 to 225.1.1.5 vlan 10
    [Switch-GigabitEthernet2/0/2] quit
    

  5. Verify the configuration.

    # Check the router port information on the switch.

    [Switch] display igmp-snooping router-port vlan 10 
     Port Name                       UpTime        Expires       Flags
     ---------------------------------------------------------------------
     VLAN 10, 1 router-port(s)
     GE3/0/3                         00:20:09      --            STATIC

    The command output shows that GE3/0/3 has been configured as a static router port.

    # Check the member port information on the switch.

    [Switch] display igmp-snooping port-info vlan 10
     --------------------------------------------------------------------------------
                         (Source, Group)  Port                          Flag
      Flag: S:Static     D:Dynamic     M: Ssm-mapping                       
     --------------------------------------------------------------------------------
     VLAN 10, 5 Entry(s)
                          (*, 225.1.1.1)  GE1/0/1                        S--
                                                    1 port(s)                       
                          (*, 225.1.1.2)  GE1/0/1                        S--
                                                    1 port(s)                       
                          (*, 225.1.1.3)  GE1/0/1                        S--
                                                    1 port(s)                       
                          (*, 225.1.1.4)  GE2/0/2                        S--
                                                    1 port(s)                       
                          (*, 225.1.1.5)  GE2/0/2                        S--
                                                    1 port(s)
     --------------------------------------------------------------------------------

    The command output shows that multicast groups 225.1.1.1-225.1.1.3 have a static member port GE1/0/1, and multicast groups 225.1.1.4 and 225.1.1.5 have a static member port GE2/0/2.

    # Check the Layer 2 multicast forwarding table on the switch.

    [Switch] display l2-multicast forwarding-table vlan 10
    VLAN ID : 10, Forwarding Mode : IP                                         
    --------------------------------------------------------------------------------
                         (Source, Group)    Interface                  Out-Vlan
    --------------------------------------------------------------------------------
                             Router-port    GigabitEthernet3/0/3          10
                          (*, 225.1.1.1)    GigabitEthernet1/0/1          10
                                            GigabitEthernet3/0/3          10
                          (*, 225.1.1.2)    GigabitEthernet1/0/1          10
                                            GigabitEthernet3/0/3          10
                          (*, 225.1.1.3)    GigabitEthernet1/0/1          10
                                            GigabitEthernet3/0/3          10
                          (*, 225.1.1.4)    GigabitEthernet2/0/2          10
                                            GigabitEthernet3/0/3          10
                          (*, 225.1.1.5)    GigabitEthernet2/0/2          10
                                            GigabitEthernet3/0/3          10
    --------------------------------------------------------------------------------
    Total Group(s) : 5

    The command output shows that multicast groups 225.1.1.1-225.1.1.5 have forwarding entries on the switch.

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 10
    #
    igmp-snooping enable
    #
    vlan 10
     igmp-snooping enable
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast static-group group-address 225.1.1.1 to 225.1.1.3 vlan 10 
    #
    interface GigabitEthernet2/0/2
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     l2-multicast static-group group-address 225.1.1.4 to 225.1.1.5 vlan 10 
    #
    interface GigabitEthernet3/0/3
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
     igmp-snooping static-router-port vlan 10 
    #
    return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065742

Views: 48441

Downloads: 46

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next