No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

S7700 and S9700 V200R013C00

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, IPv4 PIM, IPv6 PIM, MSDP, multicast VPN, layer 3 multicast CAC, IPv4 multicast route management, IPv6 multicast route management, IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN replication, layer 2 multicast CAC, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an SPT Switchover in the PIM-SM Domain

Example for Configuring an SPT Switchover in the PIM-SM Domain

Networking Requirements

Receivers can receive the VoD information in multicast mode. The entire PIM network adopts a single BSR administrative domain. By default, after receiving the first multicast data packet, the RP and the receiver DR perform an SPT switchover immediately and choose the optimal path to receive multicast information from multicast source. If the receiver requires that the SPT switchover be performed after the traffic reaches the threshold, perform SPT switchover configurations.

In Figure 4-21, configure switches so that HostA on the leaf network can receive multicast data from the RP (GE1/0/0 of SwitchA), and an SPT switchover is performed when the rate for forwarding multicast packets reaches 1024 kbit/s. (After the SPT switchover, multicast data is sent to HostA along the path Source→SwitchB→SwitchC→HostA.)

NOTE:

In this scenario, to avoid loops, ensure that all connected interfaces have STP disabled and connected interfaces are removed from VLAN 1. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 4-21  Network diagram of an SPT switchover in the PIM-SM domain

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface and a unicast routing protocol.

  2. Enable the multicast function, enable PIM-SM on all interfaces, and enable IGMP on the interface that connects the switch and hosts.

  3. Configure the same static RPs on switches.

  4. Perform the SPT switchover configuration on SwitchC.

Procedure

  1. Configure an IP address for each interface and a unicast routing protocol.

    # Configure the IP address and mask for each interface shown in Figure 4-21, and configure OSPF on each switch to ensure that SwitchA, SwitchB, and SwitchC can communicate at the network layer and can dynamically update routes using the unicast routing protocol. The configuration of SwitchA and SwitchB are similar to the configuration of SwitchC, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 100 102 300
    [SwitchC] interface gigabitethernet1/0/0
    [SwitchC-GigabitEthernet1/0/0] port link-type trunk
    [SwitchC-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [SwitchC-GigabitEthernet1/0/0] quit
    [SwitchC] interface gigabitethernet2/0/0
    [SwitchC-GigabitEthernet2/0/0] port link-type trunk
    [SwitchC-GigabitEthernet2/0/0] port trunk allow-pass vlan 102
    [SwitchC-GigabitEthernet2/0/0] quit
    [SwitchC] interface gigabitethernet3/0/0
    [SwitchC-GigabitEthernet3/0/0] port link-type trunk
    [SwitchC-GigabitEthernet3/0/0] port trunk allow-pass vlan 300
    [SwitchC-GigabitEthernet3/0/0] quit
    [SwitchC] interface vlanif 100
    [SwitchC-Vlanif100] ip address 192.168.1.2 24
    [SwitchC-Vlanif100] quit
    [SwitchC] interface vlanif 102
    [SwitchC-Vlanif102] ip address 10.110.2.1 24
    [SwitchC-Vlanif102] quit
    [SwitchC] interface vlanif 300
    [SwitchC-Vlanif300] ip address 192.168.2.2 24
    [SwitchC-Vlanif300] quit
    [SwitchC] ospf
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.110.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

  2. Enable the multicast function, enable PIM-SM on all interfaces, and enable IGMP on the interface that connects the switch and hosts.

    # Enable the multicast function on all switches and PIM-SM on all interfaces, and enable IGMP on the interface that connects SwitchC and the leaf network. The configuration of SwitchA and SwitchB are similar to the configuration of SwitchC, and are not mentioned here.

    [SwitchC] multicast routing-enable
    [SwitchC] interface vlanif 102
    [SwitchC-Vlanif102] pim sm
    [SwitchC-Vlanif102] igmp enable
    [SwitchC-Vlanif102] quit
    [SwitchC] interface vlanif 300
    [SwitchC-Vlanif300] pim sm
    [SwitchC-Vlanif300] quit
    [SwitchC] interface vlanif 100
    [SwitchC-Vlanif100] pim sm
    [SwitchC-Vlanif100] quit

  3. Configure the static RP.

    # Configure the static RP on SwitchA, SwitchB, and SwitchC. The configuration of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned here.

    [SwitchA] pim
    [SwitchA-pim] static-rp 192.168.1.1

  4. Configure the threshold for SPT switchover.

    # Configure SwitchC to perform an SPT switchover when the rate of multicast packets reaches 1024 kbit/s.

    [SwitchC] pim
    [SwitchC-pim] spt-switch-threshold 1024
    [SwitchC-pim] quit

  5. Verify the configuration.

    # The multicast source begins to send data to the multicast group and HostA can receive the data from the source. When the rate is smaller than 1024 kbit/s, run the display pim routing-table command on SwitchC to view the PIM routing table. You can see that SwitchA is the upstream neighbor. The following information is displayed.

    [SwitchC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
     
    (*, 225.1.1.1)
         RP: 192.168.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:13:46
         Upstream interface: Vlanif100
             Upstream neighbor: 192.168.1.1
             RPF prime neighbor: 192.168.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif102
                 Protocol: igmp, UpTime: 00:13:46, Expires:-
    (10.110.5.100, 225.1.1.1)
         RP: 192.168.1.1
         Protocol: pim-sm, Flag: ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif100
             Upstream neighbor: 192.168.1.1
             RPF prime neighbor: 192.168.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif102
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-

    # When the rate is higher than 1024 kbit/s, run the display pim routing-table command on SwitchC to view the PIM routing table. You can see that SwitchB is the upstream neighbor. The following information is displayed.

    [SwitchC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
     
    (*, 225.1.1.1)
         RP: 192.168.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 00:13:46
         Upstream interface: Vlanif100 
             Upstream neighbor: 192.168.1.1
             RPF prime neighbor: 192.168.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif102,
                 Protocol: igmp, UpTime: 00:13:46, Expires:-
    (10.110.5.100, 225.1.1.1)
         RP: 192.168.1.1
         Protocol: pim-sm, Flag:RPT SPT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif300
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif102
                 Protocol: pim-sm, UpTime: 00:00:42, Expires:-

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    ospf 1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     static-rp 192.168.1.1 
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 101 200 300
    #
    multicast routing-enable
    #
    interface Vlanif101
     ip address 10.110.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif300
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    ospf 1
     area 0.0.0.0
      network 10.110.5.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255 
    #
    pim
     static-rp 192.168.1.1 
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 100 102 300
    #
    multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif102
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif300
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 102
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255 
    #
    pim
     static-rp 192.168.1.1
     spt-switch-threshold 1024
    #
    return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065742

Views: 48001

Downloads: 46

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next