No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

S7700 and S9700 V200R013C00

This document describes the configurations of IP service, including IP address, ARP, DHCP, DNS, mDNS gateway, mDNS relay, UDP Helper, IP performance optimization, IPv6, DHCPv6, IPv6 DNS, IPv6 over IPv4 tunnel and IPv4 over IPv6 tunnel.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a Manual IPv6 over IPv4 Tunnel

Example for Configuring a Manual IPv6 over IPv4 Tunnel

Networking Requirements

Figure 12-12 shows two IPv6 networks connected to SwitchB on an IPv4 backbone network through SwitchA and SwitchC respectively. A manual IPv6 over IPv4 tunnel needs to be set up between SwitchA and SwitchC so that hosts on the two IPv6 networks can communicate.

Figure 12-12  Networking diagram for configuring a manual IPv6 over IPv4 tunnel

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces so that devices can communicate on the IPv4 backbone network.

  2. Configure IPv6 addresses, source interfaces, and destination addresses for tunnel interfaces so that devices can communicate with hosts on the two IPv6 networks.

  3. Set the tunnel protocol to IPv6-IPv4 so that hosts on the two IPv6 networks can communicate through the IPv4 backbone network.

Procedure

  1. Configure SwitchA.

    # Enable the service loopback function on an Eth-Trunk.

    NOTE:

    This step is optional for cards supporting internal loopback interfaces. For details, see (Optional) Enabling the Service Loopback Function on an Eth-Trunk.

    The interface must be idle and not transmitting services.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] service type tunnel
    [SwitchA-Eth-Trunk1] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] eth-trunk 1
    [SwitchA-GigabitEthernet1/0/3] quit
    

    # Configure an IP address for an interface.

    [SwitchA] ipv6
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 192.168.50.2 255.255.255.0
    [SwitchA-Vlanif100] quit

    # Set the tunnel protocol to IPv6-IPv4.

    [SwitchA] interface tunnel 1
    [SwitchA-Tunnel1] tunnel-protocol ipv6-ipv4
    [SwitchA-Tunnel1] eth-trunk 1

    # Configure an IPv6 address and a destination address for the tunnel interface.

    [SwitchA-Tunnel1] ipv6 enable
    [SwitchA-Tunnel1] ipv6 address fc00:3::1 64
    [SwitchA-Tunnel1] source vlanif 100
    [SwitchA-Tunnel1] destination 192.168.51.2
    [SwitchA-Tunnel1] quit

    # Configure a static route.

    [SwitchA] ip route-static 192.168.51.2 255.255.255.0 192.168.50.1

  2. Configure SwitchB.

    # Configure IP addresses for interfaces.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] vlan 200
    [SwitchB-vlan200] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/2] port hybrid pvid vlan 200
    [SwitchB-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 192.168.50.1 255.255.255.0
    [SwitchB-Vlanif100] quit
    [SwitchB] interface vlanif 200
    [SwitchB-Vlanif200] ip address 192.168.51.1 255.255.255.0
    [SwitchB-Vlanif200] quit

  3. Configure SwitchC.

    # Enable the service loopback function on an Eth-Trunk.

    NOTE:

    This step is optional for cards supporting internal loopback interfaces. For details, see (Optional) Enabling the Service Loopback Function on an Eth-Trunk.

    The interface must be idle and not transmitting services.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] interface eth-trunk 1
    [SwitchC-Eth-Trunk1] service type tunnel
    [SwitchC-Eth-Trunk1] quit
    [SwitchC] interface gigabitethernet 1/0/3
    [SwitchC-GigabitEthernet1/0/3] eth-trunk 1
    [SwitchC-GigabitEthernet1/0/3] quit
    

    # Configure an IP address for an interface.

    [SwitchC] ipv6
    [SwitchC] vlan 200
    [SwitchC-vlan200] quit
    [SwitchC] interface gigabitethernet1/0/1
    [SwitchC-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchC-GigabitEthernet1/0/1] port hybrid pvid vlan 200
    [SwitchC-GigabitEthernet1/0/1] port hybrid untagged vlan 200
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface vlanif 200
    [SwitchC-Vlanif200] ip address 192.168.51.2 255.255.255.0
    [SwitchC-Vlanif200] quit

    # Set the tunnel protocol to IPv6-IPv4.

    [SwitchC] interface tunnel 1
    [SwitchC-Tunnel1] tunnel-protocol ipv6-ipv4
    [SwitchC-Tunnel1] eth-trunk 1

    # Configure an IPv6 address and a destination address for the tunnel interface.

    [SwitchC-Tunnel1] ipv6 enable
    [SwitchC-Tunnel1] ipv6 address fc00:3::2 64
    [SwitchC-Tunnel1] source vlanif 200
    [SwitchC-Tunnel1] destination 192.168.50.2
    [SwitchC-Tunnel1] quit

    # Configure a static route.

    [SwitchC] ip route-static 192.168.50.2 255.255.255.0 192.168.51.1

  4. Verify the configuration.

    # Ping the IPv4 address of VLANIF 100 on SwitchA from SwitchC.

    [SwitchC] ping 192.168.50.2
      PING 192.168.50.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.50.2: bytes=56 Sequence=1 ttl=253 time=84 ms
        Reply from 192.168.50.2: bytes=56 Sequence=2 ttl=253 time=27 ms
        Reply from 192.168.50.2: bytes=56 Sequence=3 ttl=253 time=25 ms
        Reply from 192.168.50.2: bytes=56 Sequence=4 ttl=253 time=3 ms
        Reply from 192.168.50.2: bytes=56 Sequence=5 ttl=253 time=24 ms
    
      --- 192.168.50.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/32/84 ms

    SwitchC can receive Reply packets from SwitchA.

    # Ping the IPv6 address of Tunnel1 on SwitchA from SwitchC.

    [SwitchC] ping ipv6 FC00:3::1
      PING FC00:3::1 : 56  data bytes, press CTRL_C to break
        Reply from FC00:3::1
        bytes=56 Sequence=1 hop limit=64  time = 28 ms
        Reply from FC00:3::1
        bytes=56 Sequence=2 hop limit=64  time = 27 ms
        Reply from FC00:3::1
        bytes=56 Sequence=3 hop limit=64  time = 26 ms
        Reply from FC00:3::1
        bytes=56 Sequence=4 hop limit=64  time = 27 ms
        Reply from FC00:3::1
        bytes=56 Sequence=5 hop limit=64  time = 26 ms
    
      --- FC00:3::1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 26/26/28 ms

    SwitchC can receive Reply packets from SwitchA.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    ipv6
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 192.168.50.2 255.255.255.0
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:3::1/64
     tunnel-protocol ipv6-ipv4
     source Vlanif100
     destination 192.168.51.2
     eth-trunk 1
    #
    ip route-static 192.168.51.0 255.255.255.0 192.168.50.1
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 192.168.50.1 255.255.255.0
    #
    interface Vlanif200
     ip address 192.168.51.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    ipv6
    #
    vlan batch 200
    #
    interface Vlanif200
     ip address 192.168.51.2 255.255.255.0
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:3::2/64
     tunnel-protocol ipv6-ipv4
     source Vlanif200
     destination 192.168.50.2
     eth-trunk 1
    #
    ip route-static 192.168.50.0 255.255.255.0 192.168.51.1
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065743

Views: 26826

Downloads: 31

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next