No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Service

S7700 and S9700 V200R013C00

This document describes the configurations of IP service, including IP address, ARP, DHCP, DNS, mDNS gateway, mDNS relay, UDP Helper, IP performance optimization, IPv6, DHCPv6, IPv6 DNS, IPv6 over IPv4 tunnel and IPv4 over IPv6 tunnel.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an ISATAP Tunnel

Example for Configuring an ISATAP Tunnel

Networking Requirements

Figure 12-14 shows how an IPv6 host on the IPv4 network needs to connect to the IPv6 network through a border device. The IPv6 host and border device support ISATAP, so an ISATAP tunnel can be set up between the IPv6 host and the border device.

Figure 12-14  Networking diagram for configuring an ISATAP tunnel

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IPv4/IPv6 dual stack on Switch_1 so that Switch_1 can access the IPv4 and IPv6 networks.

  2. Configure an ISATAP tunnel on Switch_1 so that IPv6 hosts on the IPv4 network can communicate with Switch_2 on the IPv6 network.

  3. Configure a static route from Switch_2 to the ISATAP host.

Procedure

  1. Configure the ISATAP border device.

    # Enable the service loopback function on an Eth-Trunk.

    NOTE:

    The interface must be idle and not transmitting services.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] interface eth-trunk 1
    [Switch_1-Eth-Trunk1] service type tunnel
    [Switch_1-Eth-Trunk1] quit
    [Switch_1] interface gigabitethernet 1/0/3
    [Switch_1-GigabitEthernet1/0/3] eth-trunk 1
    [Switch_1-GigabitEthernet1/0/3] quit
    

    # Enable the IPv4/IPv6 dual stack and configure an IP address for each interface.

    [Switch_1] ipv6
    [Switch_1] vlan batch 100 200
    [Switch_1] interface gigabitethernet 1/0/1
    [Switch_1-GigabitEthernet1/0/1] port link-type hybrid
    [Switch_1-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch_1-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch_1-GigabitEthernet1/0/1] quit
    [Switch_1] interface gigabitethernet 1/0/2
    [Switch_1-GigabitEthernet1/0/2] port link-type hybrid
    [Switch_1-GigabitEthernet1/0/2] port hybrid pvid vlan 200
    [Switch_1-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [Switch_1-GigabitEthernet1/0/2] quit
    [Switch_1] interface vlanif 100
    [Switch_1-Vlanif100] ipv6 enable
    [Switch_1-Vlanif100] ipv6 address fc00:2::1/64
    [Switch_1-Vlanif100] quit
    [Switch_1] interface vlanif 200
    [Switch_1-Vlanif200] ip address 10.1.1.1 255.0.0.0
    [Switch_1-Vlanif200] quit

    # Configure an ISATAP tunnel.

    [Switch_1] interface tunnel 1
    [Switch_1-Tunnel1] tunnel-protocol ipv6-ipv4 isatap
    [Switch_1-Tunnel1] eth-trunk 1
    [Switch_1-Tunnel1] ipv6 enable
    [Switch_1-Tunnel1] ipv6 address fc00:1::/64 eui-64
    [Switch_1-Tunnel1] source vlanif 200
    [Switch_1-Tunnel1] undo ipv6 nd ra halt
    [Switch_1-Tunnel1] quit

  2. Configure the ISATAP host.

    # Run the following command to add a static route to the border device. The IPv4 address of the host is 10.1.1.2/8.

    C:\> netsh interface ipv6 isatap set router 10.1.1.1
    C:\> netsh
    netsh> interface
    netsh interface> ipv6
    netsh interface ipv6>isatap
    netsh interface ipv6 isatap>set router 10.1.1.1 enabled 1440

  3. Configure Switch_2.

    # Configure the IPv6 address for the interface.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] ipv6
    [Switch_2] vlan batch 100
    [Switch_2] interface gigabitethernet 1/0/1
    [Switch_2-GigabitEthernet1/0/1] port link-type hybrid
    [Switch_2-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch_2-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch_2-GigabitEthernet1/0/1] quit
    [Switch_2] interface vlanif 100
    [Switch_2-Vlanif100] ipv6 enable
    [Switch_2-Vlanif100] ipv6 address fc00:2::2/64
    [Switch_2-Vlanif100] quit
    

    # Configure a static route.

    [Switch_2] ipv6 route-static fc00:1:: 64 fc00:2::1
    

  4. Verify the configuration.

    # Check the IPv6 status of Tunnel1 on the ISATAP device.

    [Switch_1] display ipv6 interface tunnel 1
    Tunnel1 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::5EFE:A01:101
      Global unicast address(es):
        FC00:1::5EFE:A01:101, subnet is FC00:1::/64
      Joined group address(es):
        FF02::1:FF01:101
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND reachable time is 30000 milliseconds
      ND retransmit interval is 1000 milliseconds
      ND stale time is 1200 seconds
      ND advertised reachable time is 0 milliseconds
      ND advertised retransmit interval is 0 milliseconds
      ND router advertisement max interval 600 seconds, min interval 200 seconds
      ND router advertisements live for 1800 seconds
      ND router advertisements hop-limit 64 
      Hosts use stateless autoconfig for addresses

    You can see that the tunnel status is Up.

    # Ping the global unicast address of the tunnel interface on the ISATAP host from the ISATAP device.

    [Switch_1] ping ipv6 FC00:1::5EFE:10.1.1.2
      PING FC00:1::5EFE:10.1.1.2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=1 hop limit=64  time = 4 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=2 hop limit=64  time = 3 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=3 hop limit=64  time = 2 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=4 hop limit=64  time = 2 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=5 hop limit=64  time = 2 ms
    
      --- FC00:1::5EFE:10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 2/2/4 ms

    # Ping the global unicast address of the ISATAP device from the ISATAP host.

    C:\> ping fc00:1::5efe:10.1.1.1
    
    Pinging fc00:1::5efe:10.1.1.1
    from fc00:1::5efe:10.1.1.2 with 32 bytes of data:
    
    Reply from fc00:1::5efe:10.1.1.1: time=1ms
    Reply from fc00:1::5efe:10.1.1.1: time=1ms
    Reply from fc00:1::5efe:10.1.1.1:  time=1ms
    Reply from fc00:1::5efe:10.1.1.1: time=1ms
    Ping statistics for fc00:1::5efe:10.1.1.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 1ms, Average = 1ms

    # Ping the global unicast address of the tunnel interface on the ISATAP host from Switch_2.

    [Switch_2] ping ipv6 FC00:1::5EFE:10.1.1.2
      PING FC00:1::5EFE:10.1.1.2 : 56  data bytes, press CTRL_C to break
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=1 hop limit=64  time = 4 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=2 hop limit=64  time = 3 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=3 hop limit=64  time = 2 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=4 hop limit=64  time = 2 ms
        Reply from FC00:1::5EFE:A01:102
        bytes=56 Sequence=5 hop limit=64  time = 2 ms
    
      --- FC00:1::5EFE:10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 2/2/4 ms

Configuration Files

  • Switch_1 configuration file

    #
    sysname Switch_1
    #
    ipv6
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ipv6 enable 
     ipv6 address FC00:2::1/64
    #
    interface Vlanif200
     ip address 10.1.1.1 255.0.0.0
    #
    interface Eth-Trunk1
     service type tunnel
    #
    interface Tunnel1
     ipv6 enable
     ipv6 address FC00:1::/64 eui-64
     undo ipv6 nd ra halt
     tunnel-protocol ipv6-ipv4 isatap
     source Vlanif200
     eth-trunk 1
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    return
  • Switch_2 configuration file

    #
    sysname Switch_2
    #
    ipv6
    #
    vlan batch 100
    #
    interface Vlanif100
     ipv6 enable 
     ipv6 address FC00:2::2/64
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ipv6 route-static FC00:1:: 64 FC00:2::1 
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100065743

Views: 30080

Downloads: 31

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next