No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R013C00

This document describes the configurations of MPLS, including Static LSP, MPLS LDP, MPLS QoS, MPLS TE, MPLS OAM, Seamless MPLS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MPLS OAM Protection Switching

Example for Configuring MPLS OAM Protection Switching

Networking Requirements

On the MPLS network shown in Figure 6-4, there are three bidirectional LSPs bound to three tunnel interface (Tunnel1, Tunnel2, and Tunnel3), from PE1 to PE2. Tunnel1 and Tunnel2 function as working tunnels, and Tunnel3 functions as the protection tunnel.

MPLS OAM protection switching must be configured. Tunnel3 protects Tunnel1 and Tunnel2. When one of the working tunnels fails, the traffic on that tunnel is switched to the protection tunnel.

NOTE:

In this scenario, to avoid loops, ensure that all connected interfaces have STP disabled and connected interfaces are removed from VLAN 1. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 6-4  Configuring an MPLS OAM protection group

Switch

Interface

VLANIF Interface

IP Address

PE1

GE1/0/0

VLANIF10

10.1.1.1/24

PE1

GE2/0/0

VLANIF20

10.1.2.1/24

PE1

GE3/0/0

VLANIF30

10.1.3.1/24

PE1

GE3/0/1

VLANIF40

10.1.4.1/24

P1

GE1/0/0

VLANIF80

10.1.8.1/24

P1

GE2/0/0

VLANIF20

10.1.2.2/24

P1

GE3/0/0

VLANIF30

10.1.3.2/24

P1

GE3/0/1

VLANIF70

10.1.7.2/24

P2

GE1/0/0

VLANIF10

10.1.1.2/24

P2

GE2/0/0

VLANIF50

10.1.5.2/24

P3

GE1/0/0

VLANIF40

10.1.4.2/24

P3

GE2/0/0

VLANIF60

10.1.6.2/24

PE2

GE1/0/0

VLANIF50

10.1.5.1/24

PE2

GE2/0/0

VLANIF70

10.1.7.1/24

PE2

GE3/0/0

VLANIF80

10.1.8.2/24

PE2

GE3/0/1

VLANIF60

10.1.6.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs and VLANIF interfaces on the nodes, assign IP addresses to the VLANIF interfaces, and configure OSPF on the VLANIF interfaces.
  2. Enable MPLS, MPLS TE, and MPLS OAM on the nodes.
  3. Create three TE tunnel interfaces (Tunnel1, Tunnel2, and Tunnel3) on PE1 and PE2. Set two as working tunnels and the last as the protection tunnel.
  4. Configure two static CR-LSPs on PE1. Bind one to Tunnel1 and the other to Tunnel3.
  5. On PE1, configure an RSVP-TE tunnel to PE2.
  6. On PE2, configure three static CR-LSPs as the reverse LSPs to PE1 and bind the three static CR-LSPs to Tunnel1, Tunnel2, and Tunnel3 respectively.
  7. Set the MPLS OAM parameters and enable MPLS OAM to detect bidirectional LSPs.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of the interface on each node, name of the tunnel interface, and tunnel ID
  • Type of MPLS OAM detection packets
  • Parameters of the protection group, including delay in protection switching, revertive mode, and WTR time

Procedure

  1. Configure an IP address and routing protocol for each interface.

    # Configure PE1. Configure IP addresses for interfaces of PE2, P1, P2 and P3 and OSPF according to Figure 6-4. The configurations of PE2, P1, P2 and P3 are similar to the configuration of PE1, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname PE1
    [PE1] vlan batch 10 20 30 40
    [PE1] interface vlanif 10
    [PE1-Vlanif10] ip address 10.1.1.1 255.255.255.0
    [PE1-Vlanif10] quit
    [PE1] interface vlanif 20
    [PE1-Vlanif20] ip address 10.1.2.1 255.255.255.0
    [PE1-Vlanif20] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] ip address 10.1.3.1 255.255.255.0
    [PE1-Vlanif30] quit
    [PE1] interface vlanif 40
    [PE1-Vlanif40] ip address 10.1.4.1 255.255.255.0
    [PE1-Vlanif40] quit
    [PE1] interface gigabitEthernet 1/0/0
    [PE1-GigabitEthernet1/0/0] port link-type access
    [PE1-GigabitEthernet1/0/0] port default vlan 10
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface gigabitEthernet 2/0/0
    [PE1-GigabitEthernet2/0/0] port link-type access
    [PE1-GigabitEthernet2/0/0] port default vlan 20
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] interface gigabitEthernet 3/0/0
    [PE1-GigabitEthernet3/0/0] port link-type access
    [PE1-GigabitEthernet3/0/0] port default vlan 30
    [PE1-GigabitEthernet3/0/0] quit
    [PE1] interface gigabitEthernet 3/0/1
    [PE1-GigabitEthernet3/0/1] port link-type access
    [PE1-GigabitEthernet3/0/1] port default vlan 40
    [PE1-GigabitEthernet3/0/1] quit
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.1 255.255.255.255
    [PE1-LoopBack1] quit
    [PE1] ospf 100
    [PE1-ospf-100] area 0
    [PE1-ospf-100-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [PE1-ospf-100-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [PE1-ospf-100-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [PE1-ospf-100-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [PE1-ospf-100-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [PE1-ospf-100-area-0.0.0.0] quit
    [PE1-ospf-100] quit
    

    After the configuration is complete, LSRs can ping each other. Run the display ip routing-table command on each LSR, and you can view the routing entries to the LSRs.

  2. Enable MPLS and MPLS TE globally and on the physical interfaces.

    # Configure PE1. The configurations of PE2, P1, P2 and P3 are similar to the configuration of PE1, and are not mentioned here.

    [PE1] mpls lsr-id 1.1.1.1
    [PE1] mpls
    [PE1-mpls] mpls te
    [PE1-mpls] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] mpls
    [PE1-Vlanif10] mpls te
    [PE1-Vlanif10] quit
    [PE1] interface vlanif 20
    [PE1-Vlanif20] mpls
    [PE1-Vlanif20] mpls te
    [PE1-Vlanif20] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] mpls
    [PE1-Vlanif30] mpls te
    [PE1-Vlanif30] quit
    [PE1] interface vlanif 40
    [PE1-Vlanif40] mpls
    [PE1-Vlanif40] mpls te
    [PE1-Vlanif40] quit
    

  3. Configure tunnel interfaces.

    # On PE1 and PE2, configure Tunnel1 and Tunnel2 as working tunnels and Tunnel3 as the protection tunnel. Tunnel3 protects both Tunnel1 and Tunnel2. RSVP-TE is used on Tunnel2 and CR-static is used on Tunnel1 and Tunnel2.

    # Configure PE1.

    [PE1] interface tunnel 1
    [PE1-Tunnel1] description Working tunnel-1 to PE2
    [PE1-Tunnel1] ip address unnumbered interface loopback 1
    [PE1-Tunnel1] tunnel-protocol mpls te
    [PE1-Tunnel1] destination 5.5.5.5
    [PE1-Tunnel1] mpls te signal-protocol cr-static
    [PE1-Tunnel1] mpls te tunnel-id 100
    [PE1-Tunnel1] mpls te commit
    [PE1-Tunnel1] quit
    [PE1] interface tunnel 2
    [PE1-Tunnel2] description Working tunnel-2 to PE2
    [PE1-Tunnel2] ip address unnumbered interface loopback 1
    [PE1-Tunnel2] tunnel-protocol mpls te
    [PE1-Tunnel2] destination 5.5.5.5
    [PE1-Tunnel2] mpls te signal-protocol rsvp-te
    [PE1-Tunnel2] mpls te tunnel-id 101
    [PE1-Tunnel2] mpls te commit
    [PE1-Tunnel2] quit
    [PE1] interface tunnel 3
    [PE1-Tunnel3] description Protection tunnel to PE2
    [PE1-Tunnel3] ip address unnumbered interface loopback 1
    [PE1-Tunnel3] tunnel-protocol mpls te
    [PE1-Tunnel3] destination 5.5.5.5
    [PE1-Tunnel3] mpls te signal-protocol cr-static
    [PE1-Tunnel3] mpls te tunnel-id 102
    [PE1-Tunnel3] mpls te commit
    [PE1-Tunnel3] quit

    # Configure PE2.

    [PE2] interface tunnel 1
    [PE2-Tunnel1] description Working tunnel-1 to PE1
    [PE2-Tunnel1] ip address unnumbered interface loopback 1
    [PE2-Tunnel1] tunnel-protocol mpls te
    [PE2-Tunnel1] destination 1.1.1.1
    [PE2-Tunnel1] mpls te signal-protocol cr-static
    [PE2-Tunnel1] mpls te tunnel-id 100
    [PE2-Tunnel1] mpls te commit
    [PE2-Tunnel1] quit
    [PE2] interface tunnel 2
    [PE2-Tunnel2] description Working tunnel-2 to PE1
    [PE2-Tunnel2] ip address unnumbered interface loopback 1
    [PE2-Tunnel2] tunnel-protocol mpls te
    [PE2-Tunnel2] destination 1.1.1.1
    [PE2-Tunnel2] mpls te signal-protocol rsvp-te
    [PE2-Tunnel2] mpls te tunnel-id 101
    [PE2-Tunnel2] mpls te commit
    [PE2-Tunnel2] quit
    [PE2] interface tunnel 3
    [PE2-Tunnel3] description Protection tunnel to PE1
    [PE2-Tunnel3] ip address unnumbered interface loopback 1
    [PE2-Tunnel3] tunnel-protocol mpls te
    [PE2-Tunnel3] destination 1.1.1.1
    [PE2-Tunnel3] mpls te signal-protocol cr-static
    [PE2-Tunnel3] mpls te tunnel-id 102
    [PE2-Tunnel3] mpls te commit
    [PE2-Tunnel3] quit

  4. Configure two static CR-LSPs from PE1 to PE2, and bind them to the tunnel interfaces on PE1.

    # Configure PE1.

    [PE1] static-cr-lsp ingress Tunnel1 destination 5.5.5.5 nexthop 10.1.2.2 out-label 16
    [PE1] static-cr-lsp ingress Tunnel3 destination 5.5.5.5 nexthop 10.1.4.2 out-label 30

    # Configure P1.

    [P1] static-cr-lsp transit PE1toPE2-1 incoming-interface vlanif 20 in-label 16 nexthop 10.1.7.1 out-label 17

    # Configure P3.

    [P3] static-cr-lsp transit PE1toPE2-3 incoming-interface vlanif 40 in-label 30 nexthop 10.1.6.1 out-label 31

    # Configure PE2.

    [PE2] static-cr-lsp egress PE1toPE2-1 incoming-interface vlanif 70 in-label 17 lsrid 1.1.1.1 tunnel-id 100
    [PE2] static-cr-lsp egress PE1toPE2-3 incoming-interface vlanif 60 in-label 31 lsrid 1.1.1.1 tunnel-id 102

    After the configuration is complete, run the display mpls te tunnel command on PE1 and PE2, and you can view the created TE tunnel.

    The command output of PE1 is used as an example.

    [PE1] display mpls te tunnel
    ------------------------------------------------------------------------------
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name     
    ------------------------------------------------------------------------------
    1.1.1.1          5.5.5.5          1       --/16            I  Tunnel1         
    1.1.1.1          5.5.5.5          1       --/30            I  Tunnel3

  5. Configure an RSVP-TE tunnel.

    # Configure PE1.

    [PE1] mpls
    [PE1-mpls] mpls rsvp-te
    [PE1-mpls] mpls te cspf
    [PE1-mpls] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] mpls rsvp-te
    [PE1-Vlanif30] quit
    [PE1] ospf 100
    [PE1-ospf-100] opaque-capability enable
    [PE1-ospf-100] area 0
    [PE1-ospf-100-area-0.0.0.0] mpls-te enable
    [PE1-ospf-100-area-0.0.0.0] quit
    [PE1-ospf-100] quit

    # Configure P1.

    [P1] mpls
    [P1-mpls] mpls rsvp-te
    [P1-mpls] mpls te cspf
    [P1-mpls] quit
    [P1] interface vlanif 30
    [P1-Vlanif30] mpls rsvp-te
    [P1-Vlanif30] quit
    [P1] interface vlanif 80
    [P1-Vlanif80] mpls rsvp-te
    [P1-Vlanif80] quit
    [P1] ospf 100
    [P1-ospf-100] opaque-capability enable
    [P1-ospf-100] area 0
    [P1-ospf-100-area-0.0.0.0] mpls-te enable
    [P1-ospf-100-area-0.0.0.0] quit
    [P1-ospf-100] quit

    # Configure PE2.

    [PE2] mpls
    [PE2-mpls] mpls rsvp-te
    [PE2-mpls] mpls te cspf
    [PE2-mpls] quit
    [PE2] interface vlanif 80
    [PE2-Vlanif80] mpls rsvp-te
    [PE2-Vlanif80] quit
    [PE2] ospf 100
    [PE2-ospf-100] opaque-capability enable
    [PE2-ospf-100] area 0
    [PE2-ospf-100-area-0.0.0.0] mpls-te enable
    [PE2-ospf-100-area-0.0.0.0] quit
    [PE2-ospf-100] quit

    Run the display mpls te tunnel-interface tunnel 2 command on PE1, and you can view information about Tunnel2.

    [PE1] display mpls te tunnel-interface tunnel 2
        ----------------------------------------------------------------            
                                   Tunnel2                                          
        ----------------------------------------------------------------            
        Tunnel State Desc   :  UP                                                   
        Active LSP          :  Primary LSP                                          
        Session ID          :  101                                                  
        Ingress LSR ID      :  1.1.1.1          Egress LSR ID:  5.5.5.5             
        Admin State         :  UP               Oper State   :  UP                  
        Primary LSP State      : UP                                                 
          Main LSP State       : READY               LSP ID  : 1
    

  6. Configure three static CR-LSPs from PE2 to PE1, and bind them to the tunnel interfaces.

    # Configure PE2.

    [PE2] static-cr-lsp ingress Tunnel1 destination 1.1.1.1 nexthop 10.1.8.1 out-label 17
    [PE2] static-cr-lsp ingress Tunnel2 destination 1.1.1.1 nexthop 10.1.7.2 out-label 21
    [PE2] static-cr-lsp ingress Tunnel3 destination 1.1.1.1 nexthop 10.1.5.2 out-label 31

    # Configure P1.

    [P1] static-cr-lsp transit PE2toPE1-2 incoming-interface vlanif 70 in-label 21 nexthop 10.1.2.1 out-label 16
    [P1] static-cr-lsp transit PE2toPE1-1 incoming-interface vlanif 80 in-label 17 nexthop 10.1.3.1 out-label 20

    # Configure P2.

    [P2] static-cr-lsp transit PE2toPE1-3 incoming-interface vlanif 50 in-label 31 nexthop 10.1.1.1 out-label 30

    # Configure PE1.

    [PE1] static-cr-lsp egress PE2toPE1-2 incoming-interface vlanif 20 in-label 16 lsrid 5.5.5.5 tunnel-id 101
    [PE1] static-cr-lsp egress PE2toPE1-1 incoming-interface vlanif 30 in-label 20 lsrid 5.5.5.5 tunnel-id 100
    [PE1] static-cr-lsp egress PE2toPE1-3 incoming-interface vlanif 10 in-label 30 lsrid 5.5.5.5 tunnel-id 102

  7. Enable MPLS OAM and configure MPLS OAM to detect the LSP.

    # Configure PE1.

    [PE1] mpls
    [PE1-mpls] mpls oam
    [PE1-mpls] quit
    [PE1] mpls oam ingress Tunnel1
    [PE1] mpls oam ingress Tunnel2
    [PE1] mpls oam ingress Tunnel3
    [PE1] mpls oam ingress enable all
    [PE1] mpls oam egress lsp-name PE2toPE1-1
    [PE1] mpls oam egress lsp-name PE2toPE1-2
    [PE1] mpls oam egress lsp-name PE2toPE1-3
    [PE1] mpls oam egress enable all

    # Configure PE2.

    [PE2] mpls
    [PE2-mpls] mpls oam
    [PE2-mpls] quit
    [PE2] mpls oam ingress Tunnel1
    [PE2] mpls oam ingress Tunnel2
    [PE2] mpls oam ingress Tunnel3
    [PE2] mpls oam ingress enable all
    [PE2] mpls oam egress lsr-id 1.1.1.1 tunnel-id 101
    [PE2] mpls oam egress lsp-name PE1toPE2-1
    [PE2] mpls oam egress lsp-name PE1toPE2-3
    [PE2] mpls oam egress enable all

    # After the configuration is complete, run the display mpls oam ingress all verbose command to check the MPLS OAM parameters and the status of the LSP. You can view that the detected LSP is in Non-defect state.

    The command output of PE1 is used as an example.

    [PE1] display mpls oam ingress all verbose
                                                                                                                                        
    --------------------------------------------------------------------------------                                                    
                                                                                                                                        
    Verbose information about NO.1 OAM at the ingress                                                                                   
    --------------------------------------------------------------------------------                                                    
                                                                                                                                        
                                                                                                                                        
    LSP basic information:                    OAM basic information:                                                                    
    ---------------------------------------   --------------------------------------                                                    
    Tunnel-name         : Tunnel1             OAM-Index           : 1024                                                                
    Lsp signal status   : Up                  OAM select board    : 0                                                                   
    Lsp establish type  : Static-cr-lsp       Enable-state        : Manual enable                                                       
    Lsp ingress lsr-id  : 1.1.1.1             Ttsi/lsr-id         : 1.1.1.1                                                             
    Lsp tnl-id          : 100                 Ttsi/tunnel-id      : 100                                                                 
    Lsp-id              : 1                   Compatibility Mode  : Router Mode                                                         
                                                                                                                                        
    OAM detect information:                   OAM backward information:                                                                 
    ---------------------------------------   --------------------------------------                                                    
    Type                : CV                  Share attribute     : Share                                                               
    Frequency           : 1 s                 Lsp-name            : --                                                                  
    Detect-state        : Start               Lsp ingress lsr-id  : --                                                                  
    Defect-state        : Non-defect          Lsp tnl-id          : --                                                                  
    Available-state     : Available           Lsp-id              : --                                                                  
    Unavailable time (s): 0                   Lsp-inLabel         : --                                                                  
    Packet-priority     : 7                   Lsp signal status   : --                                                                  
    Bdi-frequency       : Detect frequency                                                                                              
    Hardware Error Info : No error                                                                                                      
                                                                                                                                        
    --------------------------------------------------------------------------------                                                    
                                                                                                                                        
    Verbose information about NO.2 OAM at the ingress                                                                                   
    --------------------------------------------------------------------------------                                                    
                                                                                                                                        
                                                                                                                                        
    LSP basic information:                    OAM basic information:                                                                    
    ---------------------------------------   --------------------------------------                                                    
    Tunnel-name         : Tunnel2             OAM-Index           : 1025                                                                
    Lsp signal status   : Up                  OAM select board    : 0                                                                   
    Lsp establish type  : Rsvp lsp            Enable-state        : Manual enable                                                       
    Lsp ingress lsr-id  : 1.1.1.1             Ttsi/lsr-id         : 1.1.1.1                                                             
    Lsp tnl-id          : 101                 Ttsi/tunnel-id      : 101                                                                 
    Lsp-id              : 1                   Compatibility Mode  : Router Mode                                                         
                                                                                                                                        
    OAM detect information:                   OAM backward information:                                                                 
    ---------------------------------------   --------------------------------------                                                    
    Type                : CV                  Share attribute     : Share                                                               
    Frequency           : 1 s                 Lsp-name            : --                                                                  
    Detect-state        : Start               Lsp ingress lsr-id  : --                                                                  
    Defect-state        : Non-defect          Lsp tnl-id          : --                                                                  
    Available-state     : Available           Lsp-id              : --                                                                  
    Unavailable time (s): 0                   Lsp-inLabel         : --                                                                  
    Packet-priority     : 7                   Lsp signal status   : --                                                                  
    Bdi-frequency       : Detect frequency                                                                                              
    Hardware Error Info : No error                                                                                                      
                                                                                                                                        
    --------------------------------------------------------------------------------                                                    
                                                                                                                                        
    Verbose information about NO.3 OAM at the ingress                                                                                   
    --------------------------------------------------------------------------------                                                    
                                                                                                                                        
                                                                                                                                        
    LSP basic information:                    OAM basic information:                                                                    
    ---------------------------------------   --------------------------------------                                                    
    Tunnel-name         : Tunnel3             OAM-Index           : 1026                                                                
    Lsp signal status   : Up                  OAM select board    : 0                                                                   
    Lsp establish type  : Static-cr-lsp       Enable-state        : Manual enable                                                       
    Lsp ingress lsr-id  : 1.1.1.1             Ttsi/lsr-id         : 1.1.1.1                                                             
    Lsp tnl-id          : 102                 Ttsi/tunnel-id      : 102                                                                 
    Lsp-id              : 1                   Compatibility Mode  : Router Mode                                                         
                                                                                                                                        
    OAM detect information:                   OAM backward information:                                                                 
    ---------------------------------------   --------------------------------------                                                    
    Type                : CV                  Share attribute     : Share                                                               
    Frequency           : 1 s                 Lsp-name            : --                                                                  
    Detect-state        : Start               Lsp ingress lsr-id  : --                                                                  
    Defect-state        : Non-defect          Lsp tnl-id          : --                                                                  
    Available-state     : Available           Lsp-id              : --                                                                  
    Unavailable time (s): 0                   Lsp-inLabel         : --                                                                  
    Packet-priority     : 7                   Lsp signal status   : --                                                                  
    Bdi-frequency       : Detect frequency                                                                                              
    Hardware Error Info : No error                                                                                                      
                                                                                                                                        
    --------------------------------------------------------------------------------                                                    
                                                                                                                                        
    Total OAM Num:                   3                                                                                                  
    Total Start OAM Num:             3                                                                                                  
    Total Defect OAM Num:            0                                                                                                  
    Total Unavailable OAM Num:       0 

  8. Configure the protection group.

    # On PE1, configure Tunnel1 and Tunnel2 as working tunnels and Tunnel3 as the protection tunnel, use the revertive mode, and set WTR time to 2 minutes.

    [PE1] interface tunnel 1
    [PE1-Tunnel1] mpls te protection tunnel 102 mode revertive wtr 4
    [PE1-Tunnel1] mpls te commit
    [PE1-Tunnel1] quit
    [PE1] interface tunnel 2
    [PE1-Tunnel2] mpls te protection tunnel 102 mode revertive wtr 4
    [PE1-Tunnel2] mpls te commit
    [PE1-Tunnel2] quit

    # After this step, run the display mpls te protection tunnel all commands on PE devices, and you can view that all tunnels are in Non-defect state and the working tunnels forward traffic.

    Take the display on PE1 as an example.

    [PE1] display mpls te protection tunnel all
    ------------------------------------------------------------------------                                                            
    No. Work-tunnel status  /id  Protect-tunnel status /id    Switch-Result                                                             
    ------------------------------------------------------------------------                                                            
    1          non-defect   /100        non-defect     /102     work-tunnel                                                             
    2          non-defect   /101        non-defect     /102     work-tunnel

    # Run the display mpls te protection binding protect-tunnel commands on PE devices, and you can view that Tunnel3 protects Tunnel1 and Tunnel2.

    The command output of PE1 is used as an example.

    [PE1] display mpls te protection binding protect-tunnel 102
    ------------------------------------------------------------------------                                                            
    Binding information of( tunnel id:  102 )                                                                                           
    ------------------------------------------------------------------------                                                            
        Protect-tunnel id                    :102                                                                                       
        Protect-tunnel name                  :Tunnel3                                                                                   
        Maximum number of bound work-tunnels :16                                                                                        
        Currently bound work-tunnels         :Total( 2 )                                                                                
                                             :Tunnel1                                                                                   
                                             :Tunnel2

  9. Verify the configuration.

    Run the display mpls te protection tunnel interface tunnel interface-number verbose commands on PE devices, and you can view detailed information about the protection group. The command output of Tunnel1 on PE1 is used as an example.
    [PE1]display mpls te protection tunnel interface tunnel 1 verbose
    ----------------------------------------------------------------                                                                    
    Verbose information about the No.1 protection-group                                                                                 
    ----------------------------------------------------------------                                                                    
    Work-tunnel id                           : 100                                                                                      
    Protect-tunnel id                        : 102                                                                                      
    Work-tunnel name                         : Tunnel1                                                                                  
    Protect-tunnel name                      : Tunnel3                                                                                  
    Work-tunnel reverse-lsp                  : -                                                                                        
    Protect-tunnel reverse-lsp               : -                                                                                        
    Bridge type                              : 1:1                                                                                      
    Switch type                              : unidirectional                                                                           
    Switch result                            : work-tunnel                                                                              
    Tunnel using Best-Effort                 : none                                                                                     
    Tunnel using Ordinary                    : none                                                                                     
    Work-tunnel frr in use                   : none                                                                                     
    Work-tunnel defect state                 : non-defect                                                                               
    Protect-tunnel defect state              : non-defect                                                                               
    Work-tunnel forward-lsp defect state     : non-defect                                                                               
    Protect-tunnel forward-lsp defect state  : non-defect                                                                               
    Work-tunnel reverse-lsp defect state     : non-defect                                                                               
    Protect-tunnel reverse-lsp defect state  : non-defect                                                                               
    HoldOff config time                      : 0ms                                                                                      
    HoldOff remain time                      : -                                                                                        
    WTR config time                          : 120s                                                                                     
    WTR remain time                          : -                                                                                        
    Mode                                     : revertive                                                                                
    Using same path                          : -                                                                                        
    Local state                              : no request                                                                               
    Far end request                          : no request                                                                               

    # Run the mpls te protect-switch manual command on Tunnel1 of PE1 to manually trigger protection switching.

    [PE1] interface tunnel 1
    [PE1-Tunnel1] mpls te protect-switch manual
    [PE1-Tunnel1] quit

    # Run the display mpls te protection tunnel all command on PE1, and you can view that the "Switch-Result" field on Tunnel1 is displayed as protect-tunnel.

    [PE1] display mpls te protection tunnel all
    ------------------------------------------------------------------------
    No. Work-tunnel status  /id  Protect-tunnel status /id      Switch-Result
    ------------------------------------------------------------------------
    1          non-defect   /100       non-defect     /102   protect-tunnel
    2          non-defect   /101       non-defect     /102      work-tunnel

    # Run the shutdown command on VLANIF 40 of PE1 to simulate a fault on a physical link of the protection tunnel.

    [PE1] interface vlanif 40
    [PE1-Vlanif40] shutdown
    [PE1-Vlanif40] quit

    # Run the display mpls te protection tunnel all command on PE1, and you can view that the Protect-tunnel status field on Tunnel1 is displayed as in-defect and the Switch-Result field is displayed as work-tunnel.

    [PE1] display mpls te protection tunnel all
    ------------------------------------------------------------------------                                                            
    No. Work-tunnel status  /id  Protect-tunnel status /id    Switch-Result                                                             
    ------------------------------------------------------------------------                                                            
    1          non-defect   /100         in defect     /102     work-tunnel                                                             
    2          non-defect   /101         in defect     /102     work-tunnel                                                             
    NOTE:

    When no faults occur on any tunnel, and the mpls te protect-switch manual command is used in the tunnel interface view of the working tunnel, traffic is switched to the protection tunnel. In this case, if the link of the protection tunnel fails later, traffic is switched back to the working tunnel and the mpls te protect-switch manual command in the tunnel interface view of the working tunnel is deleted. This is because the link fault triggers the switch request Signal Failure, and Signal Failure takes precedence over Manual Switch.

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 10 20 30 40
    #
    mpls lsr-id 1.1.1.1
    mpls
     mpls te
     mpls rsvp-te
     mpls oam
     mpls te cspf
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif30
     ip address 10.1.3.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif40
     ip address 10.1.4.1 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet3/0/0
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet3/0/1
     port link-type access
     port default vlan 40
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    interface Tunnel1
     description Working tunnel-1 to PE2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 5.5.5.5
     mpls te signal-protocol cr-static
     mpls te tunnel-id 100
     mpls te protection tunnel 102 mode revertive wtr 4
     mpls te commit
    #
    interface Tunnel2
     description Working tunnel-2 to PE2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 5.5.5.5
     mpls te tunnel-id 101
     mpls te protection tunnel 102 mode revertive wtr 4
     mpls te commit
    #
    interface Tunnel3
     description Protection tunnel to PE2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 5.5.5.5
     mpls te signal-protocol cr-static
     mpls te tunnel-id 102
     mpls te commit
    #
    ospf 100
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      mpls-te enable
    #
    static-cr-lsp ingress Tunnel1 destination 5.5.5.5 nexthop 10.1.2.2 out-label 16 bandwidth ct0 0
    static-cr-lsp ingress Tunnel3 destination 5.5.5.5 nexthop 10.1.4.2 out-label 30 bandwidth ct0 0
    static-cr-lsp egress PE2toPE1-2 incoming-interface Vlanif20 in-label 16 lsrid 5.5.5.5 tunnel-id 101
    static-cr-lsp egress PE2toPE1-1 incoming-interface Vlanif30 in-label 20 lsrid 5.5.5.5 tunnel-id 100
    static-cr-lsp egress PE2toPE1-3 incoming-interface Vlanif10 in-label 30 lsrid 5.5.5.5 tunnel-id 102
    #
    mpls oam ingress Tunnel1
    mpls oam ingress enable Tunnel1
    mpls oam ingress Tunnel2
    mpls oam ingress enable Tunnel2
    mpls oam ingress Tunnel3
    mpls oam ingress enable Tunnel3
    mpls oam egress lsp-name PE2toPE1-1
    mpls oam egress lsp-name PE2toPE1-2
    mpls oam egress lsp-name PE2toPE1-3
    #
    return
  • P2 configuration file

    #
    sysname P2
    #
    vlan batch 10 50
    #
    mpls lsr-id 2.2.2.2
    mpls
     mpls te
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif50
     ip address 10.1.5.2 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 50
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 100
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
    #
    static-cr-lsp transit PE2toPE1-3 incoming-interface Vlanif50 in-label 31 nexthop 10.1.1.1 out-label 30 bandwidth ct0 0
    #
    return
  • P1 configuration file

    #
    sysname P1
    #
    vlan batch 20 30 70 80
    #
    mpls lsr-id 3.3.3.3
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif30
     ip address 10.1.3.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif70
     ip address 10.1.7.2 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif80
     ip address 10.1.8.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 80
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet3/0/0
     port link-type access
     port default vlan 30
    #
    interface GigabitEthernet3/0/1
     port link-type access
     port default vlan 70
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 100
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.7.0 0.0.0.255
      network 10.1.8.0 0.0.0.255
      mpls-te enable
    #
    static-cr-lsp transit PE1toPE2-1 incoming-interface Vlanif20 in-label 16 nexthop 10.1.7.1 out-label 17 bandwidth ct0 0
    static-cr-lsp transit PE2toPE1-2 incoming-interface Vlanif70 in-label 21 nexthop 10.1.2.1 out-label 16 bandwidth ct0 0
    static-cr-lsp transit PE2toPE1-1 incoming-interface Vlanif80 in-label 17 nexthop 10.1.3.1 out-label 20 bandwidth ct0 0
    #
    return
  • P3 configuration file

    #
    sysname P3
    #
    vlan batch 40 60
    #
    mpls lsr-id 4.4.4.4
    mpls
     mpls te
    #
    interface Vlanif40
     ip address 10.1.4.2 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif60
     ip address 10.1.6.2 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 40
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 60
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    ospf 100
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.1.4.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
    #
    static-cr-lsp transit PE1toPE2-3 incoming-interface Vlanif40 in-label 30 nexthop 10.1.6.1 out-label 31 bandwidth ct0 0
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 50 60 70 80
    #
    mpls lsr-id 5.5.5.5
    mpls
     mpls te
     mpls rsvp-te
     mpls oam
     mpls te cspf
    #
    interface Vlanif50
     ip address 10.1.5.1 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif60
     ip address 10.1.6.1 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif70
     ip address 10.1.7.1 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif80
     ip address 10.1.8.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 50
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 70
    #
    interface GigabitEthernet3/0/0
     port link-type access
     port default vlan 80
    #
    interface GigabitEthernet3/0/1
     port link-type access
     port default vlan 60
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
    #
    interface Tunnel1
     description Working tunnel-1 to PE1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.1
     mpls te signal-protocol cr-static
     mpls te tunnel-id 100
     mpls te commit
    #
    interface Tunnel2
     description Working tunnel-2 to PE1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.1
     mpls te tunnel-id 101
     mpls te commit
    #
    interface Tunnel3
     description Protection tunnel to PE1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.1
     mpls te signal-protocol cr-static
     mpls te tunnel-id 102
     mpls te commit
    #
    ospf 100
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.5 0.0.0.0
      network 10.1.5.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
      network 10.1.7.0 0.0.0.255
      network 10.1.8.0 0.0.0.255
      mpls-te enable
    #
    static-cr-lsp egress PE1toPE2-1 incoming-interface Vlanif70 in-label 17 lsrid 1.1.1.1 tunnel-id 100
    static-cr-lsp egress PE1toPE2-3 incoming-interface Vlanif60 in-label 31 lsrid 1.1.1.1 tunnel-id 102
    static-cr-lsp ingress Tunnel1 destination 1.1.1.1 nexthop 10.1.8.1 out-label 17 bandwidth ct0 0
    static-cr-lsp ingress Tunnel2 destination 1.1.1.1 nexthop 10.1.7.2 out-label 21 bandwidth ct0 0
    static-cr-lsp ingress Tunnel3 destination 1.1.1.1 nexthop 10.1.5.2 out-label 31 bandwidth ct0 0
    #
    mpls oam ingress Tunnel1
    mpls oam ingress enable Tunnel1
    mpls oam ingress Tunnel2
    mpls oam ingress enable Tunnel2
    mpls oam ingress Tunnel3
    mpls oam ingress enable Tunnel3
    mpls oam egress lsr-id 1.1.1.1 tunnel-id 101
    mpls oam egress lsp-name PE1toPE2-1
    mpls oam egress lsp-name PE1toPE2-3
    #
    return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065745

Views: 20270

Downloads: 14

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next