No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R013C00

This document describes the configurations of MPLS, including Static LSP, MPLS LDP, MPLS QoS, MPLS TE, MPLS OAM, Seamless MPLS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MPLS OAM to Detect the Connectivity of the Static LSP

Example for Configuring MPLS OAM to Detect the Connectivity of the Static LSP

Networking Requirements

On an MPLS network shown in Figure 6-3, a static LSP is set up from LSRA to LSRB and then to LSRC.

MPLS OAM must be used to detect the connectivity of the static LSP. When a connectivity fault occurs, the egress node LSRC can notify the ingress node LSRA of the fault.

NOTE:

In this scenario, to avoid loops, ensure that all connected interfaces have STP disabled and connected interfaces are removed from VLAN 1. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 6-3  Configuring basic MPLS OAM functions

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create a TE tunnel that is based on the static LSP between LSRA and LSRC.
  2. Create a static CR-LSP from LSRC to LSRD and then to LSRA as the reverse tunnel to notify the ingress node of the fault.
  3. Set OAM parameters on the ingress node LSRA and enable MPLS OAM.
  4. Set OAM parameters on the egress node LSRC and enable the MPLS OAM auto protocol.

Data Preparation

To complete the configuration, you need the following data:

  • IP address of the interface on each node, name of each tunnel interface, and tunnel ID
  • Type of detection packets
  • Mode of the reverse tunnel

Procedure

  1. Configure an IP address and routing protocol for each interface.

    # Configure LSRA. Configure IP addresses for interfaces of LSRB, LSRC and LSRD and OSPF according to Figure 6-3. The configurations of LSRB, LSRC and LSRD are similar to the configuration of LSRA, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRA
    [LSRA] vlan batch 10 20
    [LSRA] interface Vlanif10
    [LSRA-Vlanif10] ip address 10.1.1.1 255.255.255.0
    [LSRA-Vlanif10] quit
    [LSRA] interface Vlanif20
    [LSRA-Vlanif20] ip address 10.1.2.1 255.255.255.0
    [LSRA-Vlanif20] quit
    [LSRA] interface gigabitEthernet1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type access
    [LSRA-GigabitEthernet1/0/0] port default vlan 10
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitEthernet2/0/0
    [LSRA-GigabitEthernet2/0/0] port link-type access
    [LSRA-GigabitEthernet2/0/0] port default vlan 20
    [LSRA-GigabitEthernet2/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.1 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit
    

    After the configuration is complete, LSRs can ping each other. Run the display ip routing-table command on each LSR, and you can view the routing entries to the LSRs.

    The command output of LSRA is used as an example.

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 12       Routes : 13
    
    Destination/Mask    Proto  Pre  Cost      Flags  NextHop         Interface
    
            1.1.1.1/32    Direct 0    0         D    127.0.0.1       LoopBack1
            2.2.2.2/32    OSPF   10   1         D    10.1.2.2        Vlanif20
            3.3.3.3/32    OSPF   10   2         D    10.1.1.2        Vlanif10
                          OSPF   10   2         D    10.1.2.2        Vlanif20
            4.4.4.4/32    OSPF   10   1         D    10.1.1.2        Vlanif10
           10.1.1.0/24    Direct 0    0         D    10.1.1.1        Vlanif10
           10.1.1.1/32    Direct 0    0         D    127.0.0.1       Vlanif10
           10.1.2.0/24    Direct 0    0         D    10.1.2.1        Vlanif20
           10.1.2.1/32    Direct 0    0         D    127.0.0.1       Vlanif20
           10.1.3.0/24    OSPF   10   2         D    10.1.2.2        Vlanif20
           10.1.4.0/24    OSPF   10   2         D    10.1.1.2        Vlanif10
          127.0.0.0/8     Direct 0    0         D    127.0.0.1       InLoopBack0
          127.0.0.1/32    Direct 0    0         D    127.0.0.1       InLoopBack0

  2. Set up a static LSP to be detected.

    # Configure basic MPLS functions and enable MPLS TE on LSRA. The configurations on LSRB, LSRC, and LSRD are similar to the configuration on LSRA, and are not mentioned here.

    [LSRA] mpls lsr-id 1.1.1.1
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] quit
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] mpls
    [LSRA-Vlanif10] mpls te
    [LSRA-Vlanif10] quit
    [LSRA] interface vlanif 20
    [LSRA-Vlanif20] mpls
    [LSRA-Vlanif20] mpls te
    [LSRA-Vlanif20] quit

    # On LSRA, configure a static LSP (MPLS TE tunnel) destined for LSRC.

    [LSRA] interface tunnel 2
    [LSRA-Tunnel2] ip address unnumbered interface loopback 1
    [LSRA-Tunnel2] tunnel-protocol mpls te
    [LSRA-Tunnel2] destination 3.3.3.3
    [LSRA-Tunnel2] mpls te tunnel-id 200
    [LSRA-Tunnel2] mpls te signal-protocol static
    [LSRA-Tunnel2] mpls te commit
    [LSRA-Tunnel2] quit

    # Configure LSRA as the ingress node of the static LSP and use the TE tunnel.

    [LSRA] static-lsp ingress tunnel-interface tunnel 2 destination 3.3.3.3 nexthop 10.1.2.2 out-label 20

    # Configure LSRB as the transit node of the static LSP.

    [LSRB] static-lsp transit oamlsp incoming-interface vlanif 20 in-label 20 nexthop 10.1.3.2 out-label 30

    # Configure LSRC as the egress node of the static LSP and specify lsr-id and tunnel-id.

    [LSRC] static-lsp egress oamlsp incoming-interface vlanif 30 in-label 30 lsrid 1.1.1.1 tunnel-id 200

    After the configuration is complete, run the display mpls te tunnel-interface command on LSRA. You can view that the TE tunnel is UP and uses the static signaling protocol. The command output of LSRA is used as an example.

    [LSRA] display mpls te tunnel-interface
    ----------------------------------------------------------------
                               Tunnel2                          
    ----------------------------------------------------------------
    Tunnel State Desc   :  UP                             
    Active LSP          :  Primary LSP                              
    Session ID          :  200                                      
    Ingress LSR ID      :  1.1.1.1          Egress LSR ID:  3.3.3.3 
    Admin State         :  UP               Oper State   :  UP      
    Primary LSP State      : UP                                     
      Main LSP State       : READY               LSP ID  : 1        
    

    Run the display mpls static-lsp command on LSRA, and you can view that the static LSP corresponding to Tunnel2 is Up.

    [LSRA] display mpls static-lsp
    TOTAL          : 1       STATIC LSP(S)
    UP             : 1       STATIC LSP(S)
    DOWN           : 0       STATIC LSP(S)   
    Name            FEC           I/O Label  I/O If                     Status
    Tunnel2         3.3.3.3/32     NULL/20    -/Vlanif20                 Up

  3. Set up a reverse tunnel.

    # On LSRC, configure a static LSP (MPLS TE tunnel) destined to LSRA.

    [LSRC] interface tunnel 1
    [LSRC-Tunnel1] ip address unnumbered interface loopback 1
    [LSRC-Tunnel1] tunnel-protocol mpls te
    [LSRC-Tunnel1] destination 1.1.1.1
    [LSRC-Tunnel1] mpls te tunnel-id 100
    [LSRC-Tunnel1] mpls te signal-protocol cr-static
    [LSRC-Tunnel1] mpls te commit
    [LSRC-Tunnel1] quit

    # Configure LSRC as the ingress node of the static CR-LSP.

    [LSRC] static-cr-lsp ingress tunnel-interface tunnel 1 destination 1.1.1.1 nexthop 10.1.4.1 out-label 70

    # Configure LSRD as the transit node of the static CR-LSP.

    [LSRD] static-cr-lsp transit tunnel1 incoming-interface vlanif 40 in-label 70 nexthop 10.1.1.1 out-label 80

    # Configure LSRA as the egress node of the static LSP and specify lsr-id and tunnel-id.

    [LSRA] static-cr-lsp egress tunnel1 incoming-interface vlanif 10 in-label 80 lsrid 3.3.3.3 tunnel-id 100

    After the configuration is complete, run the display mpls te tunnel-interface command on LSRC. You can view that the reverse TE tunnel is UP. The command output of LSRC is used as an example.

    [LSRC] display mpls te tunnel-interface
    ----------------------------------------------------------------
                               Tunnel1                          
    ----------------------------------------------------------------
    Tunnel State Desc   :  UP                             
    Active LSP          :  Primary LSP                              
    Session ID          :  100                                      
    Ingress LSR ID      :  3.3.3.3          Egress LSR ID:  1.1.1.1 
    Admin State         :  UP               Oper State   :  UP      
    Primary LSP State      : UP                                     
      Main LSP State       : READY               LSP ID  : 1        
    

    Run the display mpls static-cr-lsp command on LSRC, and you can view that the static CR-LSP is Up.

    [LSRC] display mpls static-cr-lsp
    TOTAL          : 1     STATIC CRLSP(S)
    UP             : 1     STATIC CRLSP(S)
    DOWN           : 0     STATIC CRLSP(S)
    Name            FEC            I/O Label  I/O If                      Status
    Tunnel1          1.1.1.1/32     NULL/70    -/Vlanif40                  Up

  4. Configure MPLS OAM functions.

    # On LSRA, configure MPLS OAM functions on the ingress node. Use the default configuration, so that CV packets are used. The parameters of the reverse tunnel depend on the configuration of the egress node.

    [LSRA] mpls
    [LSRA-mpls] mpls oam
    [LSRA-mpls] quit
    [LSRA] mpls oam ingress tunnel2 backward-lsp lsr-id 3.3.3.3 tunnel-id 100
    [LSRA] mpls oam ingress enable all

    # On LSRC, configure MPLS OAM functions on the egress node.

    [LSRC] mpls
    [LSRC-mpls] mpls oam
    [LSRC-mpls] quit

    # Enable the MPLS OAM auto protocol on the egress node. Detect the LSP named oamlsp. The reverse LSP that is configured on Tunnel1 is in private mode.

    [LSRC] mpls oam egress lsp-name oamlsp auto-protocol backward-lsp tunnel 1 private

    After the MPLS OAM auto protocol is configured on the egress node, the egress node starts OAM upon receiving the first valid detection packet.

    After the configuration is complete, check the MPLS OAM parameters and status of the LSP on ingress node LSRA and on egress node LSRC. You can view that the ingress and egress nodes are in normal detection state and no faults have occurred.

    [LSRA] display mpls oam ingress all verbose
    
    --------------------------------------------------------------------------------
    
    Verbose information about NO.1 OAM at the ingress
    --------------------------------------------------------------------------------
    
    
    LSP basic information:                    OAM basic information:
    ---------------------------------------   --------------------------------------
    Tunnel-name         : Tunnel2             OAM-Index           : 256
    Lsp signal status   : Up                  OAM select board    : 1
    Lsp establish type  : Static lsp          Enable-state        : Manual enable
    Lsp ingress lsr-id  : 1.1.1.1             Ttsi/lsr-id         : 1.1.1.1
    Lsp tnl-id          : 200                 Ttsi/tunnel-id      : 200
    Lsp-id              : 1                   Compatibility Mode  : Router Mode
    
    OAM detect information:                   OAM backward information:
    ---------------------------------------   --------------------------------------
    Type                : CV                  Share attribute     : Private
    Frequency           : 1 s                 Lsp-name            : tunnel1
    Detect-state        : Start               Lsp ingress lsr-id  : 3.3.3.3
    Defect-state        : Non-defect          Lsp tnl-id          : 100
    Available-state     : Available           Lsp-id              : --
    Unavailable time (s): 0                   Lsp-inLabel         : 80
    Packet-priority     : 7                   Lsp signal status   : Up
    Bdi-frequency       : Detect frequency 
    Hardware Error Info : No error
    
    --------------------------------------------------------------------------------
    
    Total OAM Num:           	 1
    Total Start OAM Num:     	 1
    Total Defect OAM Num:    	 0
    Total Unavailable OAM Num:	 0
    
    [LSRC] display mpls oam egress all verbose
    
    --------------------------------------------------------------------------------
    
    Verbose information about NO.1 OAM at the egress
    --------------------------------------------------------------------------------
    
    
    LSP basic information:                    OAM basic information:
    ---------------------------------------   --------------------------------------
    Lsp name            : oamlsp              OAM-Index           : 256
    Lsp signal status   : Up                  OAM select board    : 1
    Lsp establish type  : Static lsp          Enable-state        : --
    Lsp incoming Label  : 30                  Auto-protocol       : Enable
    Lsp ingress lsr-id  : 1.1.1.1             Auto-overtime (s)   : 300
    Lsp tnl-id          : 200                 Ttsi/lsr-id         : 1.1.1.1
    Lsp-id              : --                  Ttsi/tunnel-id      : 200
    Lsp Incoming-int    : Vlanif30 
    
    OAM detect information:                   OAM backward information:
    ---------------------------------------   --------------------------------------
    Type                : CV                  Tunnel name         : Tunnel1
    Frequency           : 1 s                 Share attribute     : Private
    Detect-state        : Start               Lsp signal status   : Up
    Defect-state        : Non-defect          Bdi-frequency       : Detect frequency
    Available-state     : Available
    Unavailable time (s): 0
    Hardware Error Info : No error
    
    --------------------------------------------------------------------------------
    
    Total OAM Num:           	 1
    Total Start OAM Num:     	 1
    Total Defect OAM Num:    	 0
    Total Unavailable OAM Num:	 0
    

  5. Verify the configuration.

    # Run the shutdown command on VLANIF30 of LSRB to simulate a fault on the link.

    [LSRB] interface vlanif 30
    [LSRB-Vlanif30] shutdown

    # Run the display mpls oam egress all verbose command on LSRC, and you can view that LSRC detects the fault with the status as dLocv.

    [LSRC] display mpls oam egress all verbose
    
    --------------------------------------------------------------------------------
    
    Verbose information about NO.1 OAM at the egress
    --------------------------------------------------------------------------------
    
    
    LSP basic information:                    OAM basic information:
    ---------------------------------------   --------------------------------------
    Lsp name            : oamlsp              OAM-Index           : 256
    Lsp signal status   : Up                  OAM select board    : 1
    Lsp establish type  : Static lsp          Enable-state        : --
    Lsp incoming Label  : 30                  Auto-protocol       : Enable
    Lsp ingress lsr-id  : 1.1.1.1             Auto-overtime (s)   : 300
    Lsp tnl-id          : 200                 Ttsi/lsr-id         : 1.1.1.1
    Lsp-id              : --                  Ttsi/tunnel-id      : 200
    Lsp Incoming-int    : Vlanif30 
    
    OAM detect information:                   OAM backward information:
    ---------------------------------------   --------------------------------------
    Type                : CV                  Tunnel name         : Tunnel1
    Frequency           : 1 s                 Share attribute     : Private
    Detect-state        : Start               Lsp signal status   : Up
    Defect-type         : dLocv               Bdi-frequency       : Detect frequency
    Available-state     : Unavailable
    Unavailable time (s): 42
    Hardware Error Info : No error
    
    --------------------------------------------------------------------------------
    
    Total OAM Num:           	 1
    Total Start OAM Num:     	 1
    Total Defect OAM Num:    	 1
    Total Unavailable OAM Num:	 1

Configuration Files

  • LSRA configuration file

    #
    sysname LSRA
    #
    vlan batch 10 20
    #
    mpls lsr-id 1.1.1.1
    mpls
     mpls te
     mpls oam
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 20
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    interface Tunnel2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.3
     mpls te signal-protocol static
     mpls te tunnel-id 200
     mpls te commit
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    static-lsp ingress tunnel-interface Tunnel2 destination 3.3.3.3 nexthop 10.1.2.2 out-label 20
    static-cr-lsp egress tunnel1 incoming-interface Vlanif10 in-label 80 lsrid 3.3.3.3 tunnel-id 100
    #
    mpls oam ingress Tunnel2 backward-lsp lsr-id 3.3.3.3 tunnel-id 100
    mpls oam ingress enable Tunnel2
    #
    return
  • LSRB configuration file

    #
    sysname LSRB
    #
    vlan batch 20 30
    #
    mpls lsr-id 2.2.2.2
    mpls
     mpls te
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif30
     ip address 10.1.3.1 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 30
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    static-lsp transit oamlsp incoming-interface Vlanif20 in-label 20 nexthop 10.1.3.2 out-label 30
    #
    return
  • LSRC configuration file

    #
    sysname LSRC
    #
    vlan batch 30 40
    #
    mpls lsr-id 3.3.3.3
    mpls
     mpls te
     mpls oam
    #
    interface Vlanif30
     ip address 10.1.3.2 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif40
     ip address 10.1.4.2 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 40
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 30
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 1.1.1.1
     mpls te signal-protocol cr-static
     mpls te tunnel-id 100
     mpls te commit
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    static-lsp egress oamlsp incoming-interface Vlanif30 in-label 30 lsrid 1.1.1.1 tunnel-id 200
    static-cr-lsp ingress tunnel-interface Tunnel1 destination 1.1.1.1 nexthop 10.1.4.1 out-label 70 bandwidth ct0 0
    #
    mpls oam egress lsp-name oamlsp backward-lsp Tunnel1 private
    #
    return
  • LSRD configuration file

    #
    sysname LSRD
    #
    vlan batch 10 40
    #
    mpls lsr-id 4.4.4.4
    mpls
     mpls te
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls te
    #
    interface Vlanif40
     ip address 10.1.4.1 255.255.255.0
     mpls
     mpls te
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 40
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    static-cr-lsp transit tunnel1 incoming-interface Vlanif40 in-label 70 nexthop 10.1.1.1 out-label 80 bandwidth ct0 0
    #
    return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065745

Views: 25940

Downloads: 28

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next