No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R013C00

This document describes the configurations of MPLS, including Static LSP, MPLS LDP, MPLS QoS, MPLS TE, MPLS OAM, Seamless MPLS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Automatic Triggering of a Request for a Label Mapping Message in DoD Mode

Example for Configuring Automatic Triggering of a Request for a Label Mapping Message in DoD Mode

Networking Requirements

As shown in Figure 3-22, LSRA and LSRD are edge devices of the IP/MPLS backbone network and have low performance. MPLS L2VPN services need to be deployed on LSRA and LSRD to connect VPN sites at Layer 2. Because the network scale is large (this example provides two devices on intermediate nodes), burden on edge devices needs to be reduced.

Figure 3-22  Example for configuring automatic triggering of a request for a Label Mapping message in DoD mode

Configuration Roadmap

To meet the preceding requirements, configure label mapping message in DoD mode. The configuration roadmap is as follows:
  1. Configure local LDP sessions to establish LDP LSPs to transmit L2VPN services.
  2. Configured remote LDP sessions to exchange VC labels so that PWs are set up.
  3. To reduce the burden of edge devices, configure the default static route with the next hop address as the neighbor on the edge device.
  4. The label advertisement mode is set up DoD to reduce unnecessary MPLS entries.
  5. Configure automatic triggering of a request for a Label Mapping message in DoD mode so that LDP LSPs can be set up.

Procedure

  1. Configure IP addresses for interfaces on each node and configure the loopback addresses that are used as LSR IDs.

    # Configure LSRA. The configurations of LSRB, LSRC, and LSRD are similar to the configuration of LSRA, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRA
    [LSRA] interface loopback 0
    [LSRA-LoopBack0] ip address 1.1.1.1 32
    [LSRA-LoopBack0] quit
    [LSRA] interface gigabitethernet 1/0/1
    [LSRA-GigabitEthernet1/0/1] port link-type trunk
    [LSRA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [LSRA-GigabitEthernet1/0/1] quit
    [LSRA] vlan 10
    [LSRA-vlan10] quit
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] ip address 10.1.1.1 24
    [LSRA-Vlanif10] quit

  2. Configure basic IS-IS functions for backbone devices. Configure static routes for PEs and their neighbors.

    # Configure basic IS-IS functions for LSRB and import a static route.

    [LSRB] isis 1
    [LSRB-isis-1] network-entity 10.0000.0000.0001.00
    [LSRB-isis-1] import-route static
    [LSRB-isis-1] quit
    [LSRB] interface vlanif 20
    [LSRB-Vlanif20] isis enable 1
    [LSRB-Vlanif20] quit
    [LSRB] interface loopback 0
    [LSRB-LoopBack0] isis enable 1
    [LSRB-LoopBack0] quit

    # Configure basic IS-IS functions for LSRC and import a static route.

    [LSRC] isis 1
    [LSRC-isis-1] network-entity 10.0000.0000.0002.00
    [LSRC-isis-1] import-route static
    [LSRC-isis-1] quit
    [LSRC] interface vlanif 20
    [LSRC-Vlanif20] isis enable 1
    [LSRC-Vlanif20] quit
    [LSRC] interface loopback 0
    [LSRC-LoopBack0] isis enable 1
    [LSRC-LoopBack0] quit

    # Configure a default route whose next hop IP address is 10.1.1.2 on LSRA.

    [LSRA] ip route-static 0.0.0.0 0.0.0.0 10.1.1.2

    # On LSRB, configure a static route to LSRA.

    [LSRB] ip route-static 1.1.1.1 255.255.255.255 10.1.1.1

    # On LSRC, configure a static route to LSRD.

    [LSRC] ip route-static 4.4.4.4 255.255.255.255 10.1.3.2

    # Configure a default route whose next hop IP address is 10.1.3.1 on LSRD.

    [LSRD] ip route-static 0.0.0.0 0.0.0.0 10.1.3.1

    # Run the display ip routing-table command on LSRA to view the configure default route.

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 9        Routes : 9
    
    Destination/Mask    Proto  Pre  Cost       Flags NextHop         Interface
    
            0.0.0.0/0   Static 60   0           RD   10.1.1.2        Vlanif10
            1.1.1.1/32  Direct 0    0            D   127.0.0.1       LoopBack0
           10.1.1.0/24  Direct 0    0            D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct 0    0            D   127.0.0.1       Vlanif10
         10.1.1.255/32  Direct 0    0            D   127.0.0.1       Vlanif10
          127.0.0.0/8   Direct 0    0            D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0            D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct 0    0            D   127.0.0.1       InLoopBack0
    255.255.255.255/32  Direct 0    0            D   127.0.0.1       InLoopBack0 

    # Run the display ip routing-table command on LSRB to view the route to LSRA.

    [LSRB] display ip routing-table
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 14      Routes : 14
    
    Destination/Mask    Proto    Pre  Cost       Flags NextHop         Interface
    
            1.1.1.1/32  Static   60   0           RD   10.1.1.1        Vlanif10
            2.2.2.2/32  Direct   0    0            D   127.0.0.1       LoopBack0
            3.3.3.3/32  ISIS-L1  15   10           D   10.1.2.2        Vlanif20
            4.4.4.4/32  ISIS-L2  15   74           D   10.1.2.2        Vlanif20
           10.1.1.0/24  Direct   0    0            D   10.1.1.2        Vlanif10
           10.1.1.2/32  Direct   0    0            D   127.0.0.1       Vlanif10
         10.1.1.255/32  Direct   0    0            D   127.0.0.1       Vlanif10
           10.1.2.0/24  Direct   0    0            D   10.1.2.1        Vlanif20
           10.1.2.1/32  Direct   0    0            D   127.0.0.1       Vlanif20
         10.1.2.255/32  Direct   0    0            D   127.0.0.1       Vlanif20
          127.0.0.0/8   Direct   0    0            D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct   0    0            D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct   0    0            D   127.0.0.1       InLoopBack0 
    255.255.255.255/32  Direct   0    0            D   127.0.0.1       InLoopBack0 

  3. Enable MPLS and MPLS LDP on each node globally and on the interfaces.

    # Configure LSRA. The configurations of LSRB, LSRC, and LSRD are similar to the configuration of LSRA, and are not mentioned here.

    [LSRA] mpls lsr-id 1.1.1.1
    [LSRA] mpls
    [LSRA-mpls] quit
    [LSRA] mpls ldp
    [LSRA-mpls-ldp] quit
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] mpls
    [LSRA-Vlanif10] mpls ldp
    [LSRA-Vlanif10] quit

  4. Configure the label advertisement mode as DoD.

    # Configure LSRA.

    [LSRA] interface Vlanif 10
    [LSRA-Vlanif10] mpls ldp advertisement dod
    Warning: All the related sessions will be deleted if the operation is performed!Continue? (y/n)y
    [LSRA-Vlanif10] quit

    # Configure LSRB.

    [LSRB] interface vlanif 10
    [LSRB-Vlanif10] mpls ldp advertisement dod
    Warning: All the related sessions will be deleted if the operation is performed!Continue? (y/n)y
    [LSRB-Vlanif10] quit

    # Configure LSRC.

    [LSRC] interface vlanif 30
    [LSRC-Vlanif30] mpls ldp advertisement dod
    Warning: All the related sessions will be deleted if the operation is performed!Continue? (y/n)y
    [LSRC-Vlanif30] quit

    # Configure LSRD.

    [LSRD] interface vlanif 30
    [LSRD-Vlanif30] mpls ldp advertisement dod
    Warning: All the related sessions will be deleted if the operation is performed!Continue? (y/n)y
    [LSRD-Vlanif30] quit

  5. Configure LDP extensions for inter-area LSPs.

    # Run the longest-match command on LSRA to configure LDP to search for a route according to the longest match rule to establish an inter-area LDP LSP.

    [LSRA] mpls ldp
    [LSRA-mpls-ldp] longest-match
    [LSRA-mpls-ldp] quit

    # Run the longest-match command on LSRD to configure LDP to search for a route according to the longest match rule to establish an inter-area LDP LSP.

    [LSRD] mpls ldp
    [LSRD-mpls-ldp] longest-match
    [LSRD-mpls-ldp] quit

  6. Configure a remote LDP session and enable LDP to automatically trigger a request for a Label Mapping message in DoD mode.

    # Configure LSRA.

    [LSRA] mpls ldp remote-peer lsrd
    [LSRA-mpls-ldp-remote-lsrd] remote-ip 4.4.4.4
    [LSRA-mpls-ldp-remote-lsrd] remote-ip auto-dod-request
    [LSRA-mpls-ldp-remote-lsrd] quit

    # Configure LSRD.

    [LSRD] mpls ldp remote-peer lsra
    [LSRD-mpls-ldp-remote-lsra] remote-ip 1.1.1.1
    [LSRD-mpls-ldp-remote-lsra] remote-ip auto-dod-request
    [LSRD-mpls-ldp-remote-lsra] quit

  7. Verify the configuration.

    # After the configuration is complete, run the display ip routing-table 4.4.4.4 command on LSRA to view route information.

    [LSRA] display ip routing-table 4.4.4.4
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Table : Public
    Summary Count : 1
    Destination/Mask    Proto  Pre  Cost       Flags NextHop         Interface
    
            0.0.0.0/0   Static 60   0           RD   10.1.1.2        Vlanif10
    

    The command output shows that only a default route exists in the routing table and the route 4.4.4.4 does not exist.

    # Run the display mpls ldp lsp command on LSRA to view information about the established LSP.

    [LSRA] display mpls ldp lsp
    
     LDP LSP Information
     -------------------------------------------------------------------------------
     Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel    UpstreamPeer    NextHop         OutInterface
     -------------------------------------------------------------------------------
     1.1.1.1/32         3/NULL         4.4.4.4         127.0.0.1       InLoop0 
     4.4.4.4/32         NULL/1026      -               10.1.1.2        Vlanif10
     -------------------------------------------------------------------------------
     TOTAL: 1 Normal LSP(s) Found.
     TOTAL: 0 Liberal LSP(s) Found.
     TOTAL: 0 Frr LSP(s) Found.
     A '*' before an LSP means the LSP is not established
     A '*' before a Label means the USCB or DSCB is stale
     A '*' before a UpstreamPeer means the session is stale
     A '*' before a DS means the session is stale
     A '*' before a NextHop means the LSP is FRR LSP  
    

    The command output shows that the LSP with the destination address of 4.4.4.4 is established. LSRA has obtained a Label Mapping message of 4.4.4.4 from LSRB to establish an LSP.

    [LSRA] display tunnel-info all
     * -> Allocated VC Token
    Tunnel ID           Type                 Destination           Token
    ----------------------------------------------------------------------
    0x10000001          lsp                   4.4.4.4                0
    

    The command output shows that an LSP between LSRA and LSRD is established.

Configuration Files

  • LSRA configuration file

    #
    sysname LSRA
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.1
    mpls
    #
    mpls ldp
     longest-match
    #
    mpls ldp remote-peer lsrd
     remote-ip 4.4.4.4
     remote-ip auto-dod-request
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
     mpls ldp advertisement dod
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
     ip route-static 0.0.0.0 0.0.0.0 10.1.1.2
    #
    return
    
  • LSRB configuration file

    #
    sysname LSRB
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.2
    mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0001.00
     import-route static
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
     mpls ldp advertisement dod
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
     ip route-static 1.1.1.1 255.255.255.255 10.1.1.1
    #
    return
    
  • LSRC configuration file

    #
    sysname LSRC
    #
    vlan batch 20 30
    #
    mpls lsr-id 3.3.3.3
    mpls
    #
    mpls ldp
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     import-route static
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface Vlanif30
     ip address 10.1.3.1 255.255.255.0
     mpls
     mpls ldp
     mpls ldp advertisement dod
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet1/0/2
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
     ip route-static 4.4.4.4 255.255.255.255 10.1.3.2
    #
    return
    
  • LSRD configuration file

    #
    sysname LSRD
    #
    vlan batch 30
    #
    mpls lsr-id 4.4.4.4
    mpls
    #
    mpls ldp
     longest-match
    #
    mpls ldp remote-peer lsra
     remote-ip 1.1.1.1
     remote-ip auto-dod-request
    #
    interface Vlanif30
     ip address 10.1.3.2 255.255.255.0
     mpls
     mpls ldp
     mpls ldp advertisement dod
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 30 
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
    #
     ip route-static 0.0.0.0 0.0.0.0 10.1.3.1
    #
    return
    
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065745

Views: 23414

Downloads: 24

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next