No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R013C00

This document describes the configurations of MPLS, including Static LSP, MPLS LDP, MPLS QoS, MPLS TE, MPLS OAM, Seamless MPLS.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Auto TE FRR

Example for Configuring Auto TE FRR

Networking Requirements

As shown in Figure 5-48, a primary tunnel is set up by using the explicit path LSRA -> LSRB -> LSRC -> LSRD. A bypass tunnel is set up on the ingress node LSRA to protect LSRB, and a bypass tunnel is set up on the transit node LSRB to protect the link between LSRB and LSRC.

NOTE:

In this scenario, to avoid loops, ensure that all connected interfaces have STP disabled and connected interfaces are removed from VLAN 1. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 5-48  Networking for configuring auto TE FRR

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure OSPF to ensure that there are reachable routes between LSRs.

  2. Configure an ID for each LSR and globally enable MPLS, MPLS TE, RSVP-TE, CSPF on each node and interface, and enable OSPF TE.

  3. Enable auto TE FRR in the MPLS view of the ingress node of the primary tunnel and configure node protection. Enable auto TE FRR in the MPLS view of the ingress node of the bypass tunnel and configure link protection.

  4. On the ingress node of the primary tunnel, create a tunnel interface, and specify the IP address, tunneling protocol, destination IP address, tunnel ID, and RSVP-TE for the tunnel interface.

  5. Enable TE FRR on the tunnel interface of the ingress node of the primary tunnel.

Procedure

  1. Assign an IP address to each interface and configure OSPF.

    # Configure LSRA. Configure IP addresses for interfaces on LSRB, LSRC, LSRD, LSRE, and LSRF according to Figure 5-48. The configurations of LSRB, LSRC, LSRD, LSRE, and LSRF are similar to the configuration of LSRA, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRA
    [LSRA] vlan batch 100 600
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] ip address 172.1.1.1 255.255.255.0
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] ip address 172.6.1.1 255.255.255.0
    [LSRA-Vlanif600] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] port link-type trunk
    [LSRA-GigabitEthernet1/0/0] port trunk allow-pass vlan 100
    [LSRA-GigabitEthernet1/0/0] quit
    [LSRA] interface gigabitethernet 2/0/0
    [LSRA-GigabitEthernet2/0/0] port link-type trunk
    [LSRA-GigabitEthernet2/0/0] port trunk allow-pass vlan 600
    [LSRA-GigabitEthernet2/0/0] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.9 255.255.255.255
    [LSRA-LoopBack1] quit
    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] network 172.6.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    After the configurations are complete, run the display ip routing-table command on each LSR. You can see that the LSRs learn the routes to Loopback1 of each other. The display on LSRA is used as an example.

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib, T - to vpn-instance                                     
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 17       Routes : 21                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
            1.1.1.9/32  Direct  0    0           D   127.0.0.1       LoopBack1      
            2.2.2.9/32  OSPF    10   1           D   172.1.1.2       Vlanif100
            3.3.3.9/32  OSPF    10   2           D   172.1.1.2       Vlanif100
                        OSPF    10   2           D   172.6.1.2       Vlanif600
            4.4.4.9/32  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
            5.5.5.9/32  OSPF    10   2           D   172.1.1.2       Vlanif100
            6.6.6.9/32  OSPF    10   1           D   172.6.1.2       Vlanif600
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0    
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0    
          172.1.1.0/24  Direct  0    0           D   172.1.1.1       Vlanif100
          172.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
          172.2.1.0/24  OSPF    10   2           D   172.1.1.2       Vlanif100
          172.3.1.0/24  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
          172.4.1.0/24  OSPF    10   2           D   172.1.1.2       Vlanif100
          172.5.1.0/24  OSPF    10   3           D   172.1.1.2       Vlanif100
                        OSPF    10   3           D   172.6.1.2       Vlanif600
          172.6.1.0/24  Direct  0    0           D   172.6.1.1       Vlanif600
          172.6.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif600
          172.7.1.0/24  OSPF    10   2           D   172.6.1.2       Vlanif600
    

  2. Configure basic MPLS functions and enable MPLS TE, RSVP-TE, and CSPF.

    # Configure LSRA. The configurations of LSRB, LSRC, LSRD, LSRE, and LSRF are similar to the configuration of LSRA, and are not mentioned here. CSPF only needs to be configured on the ingress nodes of the primary tunnel and bypass tunnel. That is, CSPF needs to be enabled on only LSRA and LSRB.

    [LSRA] mpls lsr-id 1.1.1.9
    [LSRA] mpls
    [LSRA-mpls] mpls te
    [LSRA-mpls] mpls rsvp-te
    [LSRA-mpls] mpls te cspf
    [LSRA-mpls] quit
    [LSRA] interface vlanif 100
    [LSRA-Vlanif100] mpls
    [LSRA-Vlanif100] mpls te
    [LSRA-Vlanif100] mpls rsvp-te
    [LSRA-Vlanif100] quit
    [LSRA] interface vlanif 600
    [LSRA-Vlanif600] mpls
    [LSRA-Vlanif600] mpls te
    [LSRA-Vlanif600] mpls rsvp-te
    [LSRA-Vlanif600] quit
    

  3. Configure OSPF TE.

    # Configure LSRA. The configurations of LSRB, LSRC, LSRD, LSRE, and LSRF are similar to the configuration of LSRA, and are not mentioned here.

    [LSRA] ospf
    [LSRA-ospf-1] opaque-capability enable
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] mpls-te enable
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

  4. Enable auto TE FRR.

    # Configure LSRA.

    [LSRA] mpls
    [LSRA-mpls] mpls te auto-frr
    [LSRA-mpls] quit

    # Configure LSRB.

    [LSRB] mpls
    [LSRB-mpls] mpls te auto-frr
    [LSRB-mpls] quit
    [LSRB] interface vlanif 200
    [LSRB-Vlanif200] mpls te auto-frr link
    [LSRB-Vlanif200] quit

  5. On LSRA, create an MPLS TE tunnel for the primary CR-LSP.

    # Configure the explicit path of the primary CR-LSP.

    [LSRA] explicit-path pri-path
    [LSRA-explicit-path-pri-path] next hop 172.1.1.2
    [LSRA-explicit-path-pri-path] next hop 172.2.1.2
    [LSRA-explicit-path-pri-path] next hop 172.3.1.2
    [LSRA-explicit-path-pri-path] next hop 4.4.4.9
    [LSRA-explicit-path-pri-path] quit

    # Configure the MPLS TE tunnel interface of the primary CR-LSP.

    [LSRA] interface tunnel 1
    [LSRA-Tunnel1] ip address unnumbered interface loopBack 1
    [LSRA-Tunnel1] tunnel-protocol mpls te
    [LSRA-Tunnel1] destination 4.4.4.9
    [LSRA-Tunnel1] mpls te tunnel-id 100
    [LSRA-Tunnel1] mpls te record-route label
    [LSRA-Tunnel1] mpls te path explicit-path pri-path
    [LSRA-Tunnel1] mpls te priority 4 3
    [LSRA-Tunnel1] mpls te fast-reroute
    [LSRA-Tunnel1] mpls te commit
    [LSRA-Tunnel1] quit

  6. Verify the configuration.

    Run the display mpls te tunnel command on all the LSRs. You can view tunnel establishment, and that two tunnels pass through LSRB and LSRC and three tunnels (one primary tunnel and two bypass tunnels) pass through LSRC.

    [LSRA] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          4.4.4.9          34      --/1055          I  Tunnel1       
    1.1.1.9          3.3.3.9          3       --/1024          I  Tunnel16384    
    
    [LSRB] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          4.4.4.9          34      1055/1063        T  Tunnel1       
    2.2.2.9          3.3.3.9          1       --/1033          I  Tunnel16384    
    
    [LSRC] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          4.4.4.9          34      1063/3           T  Tunnel1       
    1.1.1.9          3.3.3.9          3       3/--             E  Tunnel16384    
    2.2.2.9          3.3.3.9          1       3/--             E  Tunnel16384    
    
    [LSRD] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          4.4.4.9          34      3/--             E  Tunnel1       
    
    [LSRE] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    2.2.2.9          3.3.3.9          1       1033/3           T  Tunnel16384    
    
    [LSRF] display mpls te tunnel
    ------------------------------------------------------------------------------  
    Ingress LsrId    Destination      LSPID   In/Out Label     R  Tunnel-name       
    ------------------------------------------------------------------------------  
    1.1.1.9          3.3.3.9          3       1024/3           T  Tunnel16384    
    

    Run the display mpls te tunnel name Tunnel1 verbose command on LSRA and LSRB to view LSP information. You can view information about the primary tunnel and bound bypass tunnels.

    [LSRA] display mpls te tunnel name Tunnel1 verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                      
        Tunnel Interface Name   :  Tunnel1                                      
        TunnelIndex             :  3           LSP Index         :  2050            
        Session ID              :  100         LSP ID            :  34              
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  4.4.4.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif100                                       
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  -                                                
        ER-Hop Table Index      :  0           AR-Hop Table Index:  0               
        C-Hop Table Index       :  0                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8205                                            
        Created Time            :  2013-09-16 16:11:50+00:00                  
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  4           Hold-Priority     :  3               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x63        Protected Flag    :  0x2             
        Bypass In Use           :  Not Used                                         
        Bypass Tunnel Id        :  41                                               
        BypassTunnel            :  Tunnel Index[Tunnel16384], InnerLabel[1063]   
        Bypass LSP ID           :  3           FrrNextHop        :  172.7.1.2       
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
                                                                                    
    
    [LSRB] display mpls te tunnel name Tunnel1 verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel1                                      
        Tunnel Interface Name   :  -                                                
        TunnelIndex             :  3           LSP Index         :  2049            
        Session ID              :  100         LSP ID            :  34              
        LSR Role                :  Transit                                          
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  4.4.4.9                                          
        In-Interface            :  Vlanif100                                      
        Out-Interface           :  Vlanif200                                      
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        ER-Hop Table Index      :  3           AR-Hop Table Index:  1               
        C-Hop Table Index       :  -                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8198                                           
        Created Time            :  2013-09-16 16:12:50+00:00                          
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  4           Hold-Priority     :  3               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x63        Protected Flag    :  0x1             
        Bypass In Use           :  Not Used                                         
        Bypass Tunnel Id        :  65                                               
        BypassTunnel            :  Tunnel Index[Tunnel16384], InnerLabel[1063]   
        Bypass LSP ID           :  1           FrrNextHop        :  172.5.1.2       
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -           CT1 Unbound Bandwidth:  -            
        CT2 Unbound Bandwidth   :  -           CT3 Unbound Bandwidth:  -            
        CT4 Unbound Bandwidth   :  -           CT5 Unbound Bandwidth:  -            
        CT6 Unbound Bandwidth   :  -           CT7 Unbound Bandwidth:  -            
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               

    You can see that the primary tunnel on LSRA is bound to Tunnel16384 and the primary tunnel on LSRB is bound to Tunnel16384.

    Run the display mpls te tunnel name Tunnel16384 verbose command on LSRA and the display mpls te tunnel name Tunnel16384 verbose command on LSRB. You can view details of auto bypass tunnels.

    [LSRA] display mpls te tunnel name Tunnel16384 verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel16384                                   
        Tunnel Interface Name   :  Tunnel16384                                   
        TunnelIndex             :  1           LSP Index         :  2048            
        Session ID              :  1025        LSP ID            :  3               
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  1.1.1.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif600                                     
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  -                                                
        ER-Hop Table Index      :  -           AR-Hop Table Index:  0               
        C-Hop Table Index       :  1                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8206                                            
        Created Time            :  2013-09-16 16:11:50+00:00                            
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               
    [LSRB] display mpls te tunnel name Tunnel16384 verbose
        No                      :  1                                                
        Tunnel-Name             :  Tunnel16384                                   
        Tunnel Interface Name   :  Tunnel16384                                   
        TunnelIndex             :  1           LSP Index         :  2050            
        Session ID              :  1026        LSP ID            :  1               
        LSR Role                :  Ingress     LSP Type          :  Primary         
        Ingress LSR ID          :  2.2.2.9                                          
        Egress LSR ID           :  3.3.3.9                                          
        In-Interface            :  -                                                
        Out-Interface           :  Vlanif400                                          
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE              
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0             
        IncludeAllAff           :  0x0                                              
        LspConstraint           :  -                                                
        ER-Hop Table Index      :  -           AR-Hop Table Index:  0               
        C-Hop Table Index       :  0                                                
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -         
        PSB Handle              :  8199                                           
        Created Time            :  2013-09-16 16:12:50+00:00                        
        RSVP LSP Type           :  -                                                
        --------------------------------                                            
                  DS-TE Information                                                 
        --------------------------------                                            
        Bandwidth Reserved Flag :  Unreserved                                       
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0          
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0          
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0          
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0          
        Setup-Priority          :  7           Hold-Priority     :  7               
        --------------------------------                                            
                    FRR Information                                                 
        --------------------------------                                            
        Primary LSP Info                                                            
        TE Attribute Flag       :  0x3         Protected Flag    :  0x0             
        Bypass In Use           :  Not Exists                                       
        Bypass Tunnel Id        :  -                                                
        BypassTunnel            :  -                                                
        Bypass LSP ID           :  -           FrrNextHop        :  -               
        ReferAutoBypassHandle   :  -                                                
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -          
        Bypass Attribute(Not configured)                                            
        Setup Priority          :  -           Hold Priority     :  -               
        HopLimit                :  -           Bandwidth         :  -               
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -               
        IncludeAllGroup         :  -                                                
        Bypass Unbound Bandwidth Info(Kbit/sec)                                     
        CT0 Unbound Bandwidth   :  -         CT1 Unbound Bandwidth:  -              
        CT2 Unbound Bandwidth   :  -         CT3 Unbound Bandwidth:  -              
        CT4 Unbound Bandwidth   :  -         CT5 Unbound Bandwidth:  -              
        CT6 Unbound Bandwidth   :  -         CT7 Unbound Bandwidth:  -              
        --------------------------------                                            
                   BFD Information                                                  
        --------------------------------                                            
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -           
        NextLspId               :  -           PrevLspId         :  -               

    You can see that the outbound interface VLANIF100 is protected by the auto bypass tunnel on LSRA, and LSRB is protected. You can see that the outbound interface VLANIF200 is protected by the auto bypass tunnel on LSRB, and the link between LSRB and LSRC is protected.

    Run the display mpls te tunnel path command on LSRA and LSRB. You can view path information of the primary tunnel and the auto bypass tunnel, and view that node protection and link protection are provided for the outbound interface on the primary tunnel.

    [LSRA] display mpls te tunnel path
     Tunnel Interface Name : Tunnel1                                            
     Lsp ID : 1.1.1.9 :100 :34                                                      
     Hop Information                                                                
      Hop 0   172.1.1.1 Local-Protection available | node                           
      Hop 1   172.1.1.2  Label 1055                                                 
      Hop 2   2.2.2.9  Label 1055                                                   
      Hop 3   172.2.1.1 Local-Protection available                                  
      Hop 4   172.2.1.2  Label 1063                                                 
      Hop 5   3.3.3.9  Label 1063                                                   
      Hop 6   172.3.1.1                                                             
      Hop 7   172.3.1.2  Label 3                                                    
      Hop 8   4.4.4.9  Label 3                                                      
    
     Tunnel Interface Name : Tunnel16384                                         
     Lsp ID : 1.1.1.9 :1025 :3                                                      
     Hop Information                                                                
      Hop 0   172.6.1.1                                                             
      Hop 1   172.6.1.2  Label 1024                                                 
      Hop 2   6.6.6.9  Label 1024                                                   
      Hop 3   172.7.1.1                                                             
      Hop 4   172.7.1.2  Label 3                                                    
      Hop 5   3.3.3.9  Label 3                                                      
    
    [LSRB] display mpls te tunnel path
     Tunnel Interface Name : Tunnel1                                            
     Lsp ID : 1.1.1.9 :100 :34                                                      
     Hop Information                                                                
      Hop 0   1.1.1.9                                                               
      Hop 1   172.1.1.1 Local-Protection available | node                           
      Hop 2   172.1.1.2  Label 1055                                                 
      Hop 3   2.2.2.9                                                               
      Hop 4   172.2.1.1 Local-Protection available                                  
      Hop 5   172.2.1.2  Label 1063                                                 
      Hop 6   3.3.3.9  Label 1063                                                   
      Hop 7   172.3.1.1                                                             
      Hop 8   172.3.1.2  Label 3                                                    
      Hop 9   4.4.4.9  Label 3                                                      
    
     Tunnel Interface Name : Tunnel16384                                         
     Lsp ID : 2.2.2.9 :1026 :1                                                      
     Hop Information                                                                
      Hop 0   172.4.1.1                                                             
      Hop 1   172.4.1.2  Label 1033                                                 
      Hop 2   5.5.5.9  Label 1033                                                   
      Hop 3   172.5.1.1                                                             
      Hop 4   172.5.1.2  Label 3                                                    
      Hop 5   3.3.3.9  Label 3                                                      
    

Configuration Files

  • LSRA configuration file

    #
    sysname LSRA
    #
    vlan batch 100 600
    #
    mpls lsr-id 1.1.1.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls te auto-frr                                                               
     mpls rsvp-te                                                                   
     mpls te cspf 
    #
    explicit-path pri-path                                                          
     next hop 172.1.1.2                                                             
     next hop 172.2.1.2                                                             
     next hop 172.3.1.2                                                             
     next hop 4.4.4.9 
    #    
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #    
    interface Vlanif600
     ip address 172.6.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #    
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 4.4.4.9
     mpls te tunnel-id 100
     mpls te record-route label
     mpls te priority 4 3
     mpls te path explicit-path pri-path
     mpls te fast-reroute
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.6.1.0 0.0.0.255 
      mpls-te enable
    #
    return
  • LSRB configuration file

    #
    sysname LSRB
    #
    vlan batch 100 200 400
    # 
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls te auto-frr
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    # 
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls te auto-frr link
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    # 
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0                                                       
      network 172.1.1.0 0.0.0.255                                                   
      network 172.2.1.0 0.0.0.255                                                   
      network 172.4.1.0 0.0.0.255 
      mpls-te enable
    #
    return
  • LSRC configuration file

    #
    sysname LSRC
    #
    vlan batch 200 300 500 700
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls te 
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0                                                       
      network 172.2.1.0 0.0.0.255                                                   
      network 172.3.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRD configuration file

    #
    sysname LSRD
    #
    vlan batch 300
    #
    mpls lsr-id 4.4.4.9                                                             
    mpls                                                                            
     mpls te                                                                        
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 4.4.4.9 0.0.0.0                                                       
      network 172.3.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRE configuration file

    #
    sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 5.5.5.9 0.0.0.0                                                       
      network 172.4.1.0 0.0.0.255                                                   
      network 172.5.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • LSRF configuration file

    #
    sysname LSRF
    #
    vlan batch 600 700
    #
    mpls lsr-id 6.6.6.9
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif600
     ip address 172.6.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif700
     ip address 172.7.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 600
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 700
    #
    interface LoopBack1
     ip address 6.6.6.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 6.6.6.9 0.0.0.0                                                       
      network 172.6.1.0 0.0.0.255                                                   
      network 172.7.1.0 0.0.0.255
      mpls-te enable
    #
    return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065745

Views: 20198

Downloads: 14

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next