No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R013C00

This document describes the configurations of MPLS, including Static LSP, MPLS LDP, MPLS QoS, MPLS TE, MPLS OAM, Seamless MPLS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Local LDP Sessions

Example for Configuring Local LDP Sessions

Networking Requirements

As shown in Figure 3-19, LSRA and LSRC are PEs of the IP/MPLS backbone network. MPLS L2VPN or L3VPN services need to be deployed on LSRA and LSRC to connect VPN sites, so local LDP sessions need to be established between LSRs to trigger LDP LSP setup. The LDP LSPs then transmit VPN services.

Figure 3-19  Networking diagram for configuring local LDP sessions

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure OSPF between the LSRs to implement IP connectivity on the backbone network.
  2. Configure local LDP sessions on LSRs so that public tunnels can be set up to transmit VPN services.

Procedure

  1. Create VLANs and VLANIF interfaces on the switch, configure IP addresses for the VLANIF interfaces, and add physical interfaces to the VLANs.

    # Configure LSRA. The configurations of LSRB and LSRC are similar to the configuration of LSRA, and are not mentioned here.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRA
    [LSRA] interface loopback 0
    [LSRA-LoopBack0] ip address 1.1.1.1 32
    [LSRA-LoopBack0] quit
    [LSRA] vlan batch 10
    [LSRA] interface vlanif 10
    [LSRA-Vlanif10] ip address 10.1.1.1 24
    [LSRA-Vlanif10] quit
    [LSRA] interface gigabitethernet 1/0/1
    [LSRA-GigabitEthernet1/0/1] port link-type trunk
    [LSRA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [LSRA-GigabitEthernet1/0/1] quit

  2. Configure OSPF to advertise the network segments connecting to interfaces on each node and to advertise the routes of hosts with LSR IDs.

    # Configure LSRA.

    [LSRA] ospf 1
    [LSRA-ospf-1] area 0
    [LSRA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [LSRA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [LSRA-ospf-1-area-0.0.0.0] quit
    [LSRA-ospf-1] quit

    # Configure LSRB.

    [LSRB] ospf 1
    [LSRB-ospf-1] area 0
    [LSRB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [LSRB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [LSRB-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [LSRB-ospf-1-area-0.0.0.0] quit
    [LSRB-ospf-1] quit

    # Configure LSRC.

    [LSRC] ospf 1
    [LSRC-ospf-1] area 0
    [LSRC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [LSRC-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [LSRC-ospf-1-area-0.0.0.0] quit
    [LSRC-ospf-1] quit

    After the configuration is complete, run the display ip routing-table command on each node, and you can view that the nodes learn routes from each other.

  3. Enable global MPLS and MPLS LDP on each LSR.

    # Configure LSRA.

    [LSRA] mpls lsr-id 1.1.1.1
    [LSRA] mpls
    [LSRA-mpls] quit
    [LSRA] mpls ldp
    [LSRA-mpls-ldp] quit

    # Configure LSRB.

    [LSRB] mpls lsr-id 2.2.2.2
    [LSRB] mpls
    [LSRB-mpls] quit
    [LSRB] mpls ldp
    [LSRB-mpls-ldp] quit

    # Configure LSRC.

    [LSRC] mpls lsr-id 3.3.3.3
    [LSRC] mpls
    [LSRC-mpls] quit
    [LSRC] mpls ldp
    [LSRC-mpls-ldp] quit
    

  4. Enable MPLS and MPLS LDP on interfaces of each LSR.

    # Configure LSRA.

    [LSRA] interface vlanif 10 
    [LSRA-Vlanif10] mpls
    [LSRA-Vlanif10] mpls ldp
    [LSRA-Vlanif10] quit

    # Configure LSRB.

    [LSRB] interface vlanif 10 
    [LSRB-Vlanif10] mpls 
    [LSRB-Vlanif10] mpls ldp
    [LSRB-Vlanif10] quit 
    [LSRB] interface vlanif 20 
    [LSRB-Vlanif20] mpls
    [LSRB-Vlanif20] mpls ldp
    [LSRB-Vlanif20] quit
    

    # Configure LSRC.

    [LSRC] interface vlanif 20 
    [LSRC-Vlanif20] mpls 
    [LSRC-Vlanif20] mpls ldp
    [LSRC-Vlanif20] quit

  5. Verify the configuration.

    # After the configuration is complete, run the display mpls ldp session command. The command output shows that the status of local LDP sessions between LSRA and LSRB and between LSRB and LSRC is Operational.

    LSRA is used as an example.

    [LSRA] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.2:0          Operational DU   Passive  0000:00:22   91/91
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    

Configuration Files

  • LSRA configuration file

    #
    sysname LSRA
    #
    vlan batch 10
    #
    mpls lsr-id 1.1.1.1 
    mpls
    #
    mpls ldp
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • LSRB configuration file

    #
    sysname LSRB
    #
    vlan batch 10 20
    #
    mpls lsr-id 2.2.2.2
    mpls
    #
    mpls ldp
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/2
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #
    return
  • LSRC configuration file

    #
    sysname LSRC
    #
    vlan batch 20
    #
    mpls lsr-id 3.3.3.3
    mpls
    #
    mpls ldp
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk 
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 10.2.1.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065745

Views: 24331

Downloads: 25

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next