No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R013C00

This document describes the configurations of MPLS, including Static LSP, MPLS LDP, MPLS QoS, MPLS TE, MPLS OAM, Seamless MPLS.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Srefresh Based on Manual TE FRR

Example for Configuring Srefresh Based on Manual TE FRR

Networking Requirements

As shown in Figure 5-41, the primary CR-LSP is along the path LSRA -> LSRB -> LSRC -> LSRD, and the link between LSRB and LSRC needs to be protected by FRR.

A bypass CR-LSP is set up along the path LSRB -> LSRE -> LSRC. LSRB functions as the PLR and LSRC functions as the MP.

The primary and bypass MPLS TE tunnels are set up by using explicit paths. RSVP-TE is used as the signaling protocol.

The Srefresh function needs to be configured on LSRB and LSRC.

NOTE:

In this scenario, to avoid loops, ensure that all connected interfaces have STP disabled and connected interfaces are removed from VLAN 1. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 5-41  Networking for configuring Srefresh based on manual TE FRR

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure manual TE FRR.

  2. Configure Srefresh on the PLR and MP along a tunnel to enhance transmission reliability of RSVP messages and improve resource use efficiency.

Procedure

  1. Configure manual TE FRR.

    Configure the primary and bypass MPLS TE tunnels according to Example for Configuring Manual TE FRR, and then bind the two tunnels.

  2. Configure the Srefresh function on LSRB and LSRC.

    # Configure the Srefresh function on LSRB.

    [LSRB] mpls
    [LSRB-mpls] mpls rsvp-te srefresh
    [LSRB-mpls] quit

    # Configure the Srefresh function on LSRC.

    [LSRC] mpls
    [LSRC-mpls] mpls rsvp-te srefresh
    [LSRC-mpls] quit

  3. Verify the configuration.

    # Run the display mpls rsvp-te statistics global command on LSRB. You can view the status of the Srefresh function. If the command output shows that the values of SendSrefreshCounter, RecSrefreshCounter, SendAckMsgCounter, and RecAckMsgCounter are not zero, Srefresh packets are successfully transmitted.

    [LSRB] display mpls rsvp-te statistics global
     LSR ID: 2.2.2.9                      LSP Count: 2                              
     PSB Count: 2                         RSB Count: 2                              
     RFSB Count: 1                                                                  
                                                                                    
    Total Statistics Information:                                                   
     PSB CleanupTimeOutCounter: 0         RSB CleanupTimeOutCounter: 0              
     SendPacketCounter: 122613            RecPacketCounter: 127446                  
     SendCreatePathCounter: 25            RecCreatePathCounter: 260                 
     SendRefreshPathCounter: 62209        RecRefreshPathCounter: 62113              
     SendCreateResvCounter: 21            RecCreateResvCounter: 31                  
     SendRefreshResvCounter: 60101        RecRefreshResvCounter: 64792              
     SendResvConfCounter: 0               RecResvConfCounter: 0                     
     SendHelloCounter: 0                  RecHelloCounter: 0                        
     SendAckCounter: 0                    RecAckCounter: 0                          
     SendPathErrCounter: 242              RecPathErrCounter: 0                      
     SendResvErrCounter: 0                RecResvErrCounter: 0                      
     SendPathTearCounter: 11              RecPathTearCounter: 8                     
     SendResvTearCounter: 2               RecResvTearCounter: 0                     
     SendSrefreshCounter: 1               RecSrefreshCounter: 1                     
     SendAckMsgCounter: 1                 RecAckMsgCounter: 1                       
     SendChallengeMsgCounter: 0           RecChallengeMsgCounter: 0                 
     SendResponseMsgCounter: 0            RecResponseMsgCounter: 0                  
     SendErrMsgCounter: 0                 RecErrMsgCounter: 0                       
     SendRecoveryPathMsgCounter: 0        RecRecoveryPathMsgCounter: 0              
     SendGRPathMsgCounter: 0              RecGRPathMsgCounter: 0                    
     ResourceReqFaultCounter: 0           RecGRPathMsgFromLSPMCounter: 0            
     Bfd neighbor count: 3                Bfd session count: 0                      

    # Shut down the protected outbound interface VLANIF200 on LSRB.

    [LSRB] interface vlanif 200
    [LSRB-Vlanif200] shutdown
    [LSRB-Vlanif200] quit
    Run the display interface tunnel 1 command on LSRA. You can view the status of the primary CR-LSP and that the status of the tunnel interface is still Up.
    [LSRA] display interface tunnel 1
    Tunnel1 current state : UP                                                  
    Line protocol current state : UP                                                
    Last line protocol up time : 2013-01-21 10:58:49                                
    Description:
    ...

    Run the tracert lsp te tunnel 1 command on LSRA. You can view the path that the tunnel passes.

    [LSRA] tracert lsp te tunnel 1
      LSP Trace Route FEC: TE TUNNEL IPV4 SESSION QUERY Tunnel1 , press CTRL_C t
    o break.                                                                        
      TTL   Replier            Time    Type      Downstream                         
      0                                Ingress   172.1.1.2/[1034 ]                  
      1     172.1.1.2          1 ms    Transit   172.4.1.2/[1042 1025 ]             
      2     172.4.1.2          1 ms    Transit   172.5.1.2/[3 ]                     
      3     172.5.1.2          2 ms    Transit   172.3.1.2/[3 ]                     
      4     4.4.4.9            2 ms    Egress                                       

    The preceding information shows that services on the link have been switched to the bypass CR-LSP.

    Run the display mpls te tunnel name Tunnel1 verbose command on LSRB. You can see that the bypass CR-LSP is in use.

    [LSRB] display mpls te tunnel name Tunnel1 verbose
        No                      :  1
        Tunnel-Name             :  Tunnel1
        Tunnel Interface Name   :  -                   
        TunnelIndex             :  1           LSP Index         :  2048
        Session ID              :  100         LSP ID            :  5
        LSR Role                :  Transit     
        Ingress LSR ID          :  1.1.1.9
        Egress LSR ID           :  4.4.4.9
        In-Interface            :  Vlanif100
        Out-Interface           :  Vlanif200
        Sign-Protocol           :  RSVP TE     Resv Style        :  SE
        IncludeAnyAff           :  0x0         ExcludeAnyAff     :  0x0
        IncludeAllAff           :  0x0
        ER-Hop Table Index      :  -           AR-Hop Table Index:  0
        C-Hop Table Index       :  -
        PrevTunnelIndexInSession:  -           NextTunnelIndexInSession:  -
        PSB Handle              :  8421
        Created Time            :  2013-09-16 18:27:55+00:00              
        RSVP LSP Type           :  - 
        --------------------------------
                  DS-TE Information
        --------------------------------
        Bandwidth Reserved Flag :  Unreserved
        CT0 Bandwidth(Kbit/sec) :  0           CT1 Bandwidth(Kbit/sec):  0
        CT2 Bandwidth(Kbit/sec) :  0           CT3 Bandwidth(Kbit/sec):  0
        CT4 Bandwidth(Kbit/sec) :  0           CT5 Bandwidth(Kbit/sec):  0
        CT6 Bandwidth(Kbit/sec) :  0           CT7 Bandwidth(Kbit/sec):  0
        Setup-Priority          :  7           Hold-Priority     :  7
        --------------------------------
                    FRR Information
        --------------------------------
        Primary LSP Info
        TE Attribute Flag       :  0x63        Protected Flag    :  0x1
        Bypass In Use           :  In Use
        Bypass Tunnel Id        :  19
        BypassTunnel            :  Tunnel Index[Tunnel2], InnerLabel[1042]
        Bypass LSP ID           :  2           FrrNextHop        :  172.5.1.2
        ReferAutoBypassHandle   :  -
        FrrPrevTunnelTableIndex :  -           FrrNextTunnelTableIndex:  -
        Bypass Attribute(Not configured)
        Setup Priority          :  -           Hold Priority     :  -
        HopLimit                :  -           Bandwidth         :  -
        IncludeAnyGroup         :  -           ExcludeAnyGroup   :  -
        IncludeAllGroup         :  -
        Bypass Unbound Bandwidth Info(Kbit/sec)
        CT0 Unbound Bandwidth   :  -           CT1 Unbound Bandwidth:  -
        CT2 Unbound Bandwidth   :  -           CT3 Unbound Bandwidth:  -
        CT4 Unbound Bandwidth   :  -           CT5 Unbound Bandwidth:  -
        CT6 Unbound Bandwidth   :  -           CT7 Unbound Bandwidth:  -
        --------------------------------
                   BFD Information
        --------------------------------
        NextSessionTunnelIndex  :  -           PrevSessionTunnelIndex:  -
        NextLspId               :  -           PrevLspId         :  -

    Run the display mpls rsvp-te statistics global command on LSRB to view Srefresh statistics.

    [LSRB] display mpls rsvp-te statistics global
     LSR ID: 2.2.2.9                      LSP Count: 2                              
     PSB Count: 2                         RSB Count: 2                              
     RFSB Count: 1                                                                  
                                                                                    
    Total Statistics Information:                                                   
     PSB CleanupTimeOutCounter: 0         RSB CleanupTimeOutCounter: 0              
     SendPacketCounter: 122707            RecPacketCounter: 127580                  
     SendCreatePathCounter: 27            RecCreatePathCounter: 304                 
     SendRefreshPathCounter: 62220        RecRefreshPathCounter: 62122              
     SendCreateResvCounter: 22            RecCreateResvCounter: 32                  
     SendRefreshResvCounter: 60111        RecRefreshResvCounter: 64803              
     SendResvConfCounter: 0               RecResvConfCounter: 0                     
     SendHelloCounter: 0                  RecHelloCounter: 0                        
     SendAckCounter: 0                    RecAckCounter: 0                          
     SendPathErrCounter: 287              RecPathErrCounter: 0                      
     SendResvErrCounter: 0                RecResvErrCounter: 0                      
     SendPathTearCounter: 11              RecPathTearCounter: 8                     
     SendResvTearCounter: 2               RecResvTearCounter: 0                     
     SendSrefreshCounter: 13              RecSrefreshCounter: 14                    
     SendAckMsgCounter: 14                RecAckMsgCounter: 13                      
     SendChallengeMsgCounter: 0           RecChallengeMsgCounter: 0                 
     SendResponseMsgCounter: 0            RecResponseMsgCounter: 0                  
     SendErrMsgCounter: 0                 RecErrMsgCounter: 0                       
     SendRecoveryPathMsgCounter: 0        RecRecoveryPathMsgCounter: 0              
     SendGRPathMsgCounter: 0              RecGRPathMsgCounter: 0                    
     ResourceReqFaultCounter: 0           RecGRPathMsgFromLSPMCounter: 0            
     Bfd neighbor count: 2                Bfd session count: 0                      

    Because the Srefresh function is configured globally on LSRB and LSRC, the Srefresh function takes effect on LSRB and LSRC when the primary tunnel fails.

Configuration Files

  • LSRA configuration file

    #
     sysname LSRA
    #
    vlan batch 100
    #
    mpls lsr-id 1.1.1.9
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path pri-path
     next hop 172.1.1.2
     next hop 172.2.1.2
     next hop 172.3.1.2
     next hop 4.4.4.9
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0001.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 4.4.4.9
     mpls te tunnel-id 100
     mpls te record-route label
     mpls te path explicit-path pri-path
     mpls te fast-reroute
     mpls te commit
    #
    return
  • LSRB configuration file

    #
     sysname LSRB
    #
    vlan batch 100 200 400
    #
    mpls lsr-id 2.2.2.9
    mpls
     mpls te
     mpls te timer fast-reroute 120
     mpls rsvp-te
     mpls rsvp-te srefresh
     mpls te cspf
    #
    explicit-path by-path
     next hop 172.4.1.2
     next hop 172.5.1.2
     next hop 3.3.3.9
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0002.00
     traffic-eng level-2
    #
    interface Vlanif100
     ip address 172.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif400
     ip address 172.4.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
     isis enable 1
    #
    interface Tunnel2
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 3.3.3.9
     mpls te tunnel-id 300
     mpls te record-route
     mpls te path explicit-path by-path
     mpls te bypass-tunnel
     mpls te protected-interface Vlanif200
     mpls te commit
    #
    return
  • LSRC configuration file

    #
     sysname LSRC
    #
    vlan batch 200 300 500
    #
    mpls lsr-id 3.3.3.9
    mpls
     mpls te
     mpls rsvp-te
     mpls rsvp-te srefresh
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0003.00
     traffic-eng level-2
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif300
     ip address 172.3.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
     isis enable 1
    #
    return
  • LSRD configuration file

    #
     sysname LSRD
    #
    vlan batch 300
    #
    mpls lsr-id 4.4.4.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0004.00
     traffic-eng level-2
    #
    interface Vlanif300
     ip address 172.3.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface LoopBack1
     ip address 4.4.4.9 255.255.255.255
     isis enable 1
    #
    return
  • LSRE configuration file

    #
     sysname LSRE
    #
    vlan batch 400 500
    #
    mpls lsr-id 5.5.5.9
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 00.0005.0000.0000.0005.00
     traffic-eng level-2
    #
    interface Vlanif400
     ip address 172.4.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif500
     ip address 172.5.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 500
    #
    interface LoopBack1
     ip address 5.5.5.9 255.255.255.255
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065745

Views: 20412

Downloads: 14

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next