No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - MPLS

S7700 and S9700 V200R013C00

This document describes the configurations of MPLS, including Static LSP, MPLS LDP, MPLS QoS, MPLS TE, MPLS OAM, Seamless MPLS.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LDP over TE

Example for Configuring LDP over TE

Networking Requirements

As shown in Figure 3-26, LDP is run between LSRA and LSRB, and between LSRD and LSRE. LDP is not run among LSRB, LSRC, and LSRD. An RSTP tunnel is configured on LSRB and the egress node of the tunnel is LSRD. An RSVP tunnel is also configured on LSRD and the egress node of the tunnel is LSRB. It is required that traffic between LSRA and LSRE pass through the tunnel.

Figure 3-26  Networking diagram for configuring LDP over TE

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces and configure IGP.

  2. Enable the MPLS TE and RSVP-TE functions on LSRB, LSRC, and LSRD and create an MPLS TE tunnel.

  3. Enable MPLS LDP on LSRA, LSRB, LSRD, and LSRE and configure a remote LDP peer for the edge nodes of the TE domain.

  4. Enable the LDP over TE function on LSRB and LSRD.

  5. Configure the link bandwidth.

  6. Configure a TE tunnel interface and configure the forwarding adjacency function.

Procedure

  1. Configure IP addresses for interfaces.

    # Configure LSRA.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRA
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] ip address 1.1.1.1 32
    [LSRA-LoopBack1] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] undo portswitch
    [LSRA-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [LSRA-GigabitEthernet1/0/0] quit
    

    # Configure LSRB.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRB
    [LSRB] interface loopback 1
    [LSRB-LoopBack1] ip address 2.2.2.2 32
    [LSRB-LoopBack1] quit
    [LSRB] interface gigabitethernet 1/0/0
    [LSRB-GigabitEthernet1/0/0] undo portswitch
    [LSRB-GigabitEthernet1/0/0] ip address 10.1.1.2 24
    [LSRB-GigabitEthernet1/0/0] quit
    [LSRB] interface gigabitethernet 2/0/0
    [LSRB-GigabitEthernet2/0/0] undo portswitch
    [LSRB-GigabitEthernet2/0/0] ip address 20.1.1.1 24
    [LSRB-GigabitEthernet2/0/0] quit
    

    # Configure LSRC.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRC
    [LSRC] interface loopback 1
    [LSRC-LoopBack1] ip address 3.3.3.3 32
    [LSRC-LoopBack1] quit
    [LSRC] interface gigabitethernet 1/0/0
    [LSRC-GigabitEthernet1/0/0] undo portswitch
    [LSRC-GigabitEthernet1/0/0] ip address 20.1.1.2 24
    [LSRC-GigabitEthernet1/0/0] quit
    [LSRC] interface gigabitethernet 2/0/0
    [LSRC-GigabitEthernet2/0/0] undo portswitch
    [LSRC-GigabitEthernet2/0/0] ip address 30.1.1.1 24
    [LSRC-GigabitEthernet2/0/0] quit
    

    # Configure LSRD.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRD
    [LSRD] interface loopback 1
    [LSRD-LoopBack1] ip address 4.4.4.4 32
    [LSRD-LoopBack1] quit
    [LSRD] interface gigabitethernet 1/0/0
    [LSRD-GigabitEthernet1/0/0] undo portswitch
    [LSRD-GigabitEthernet1/0/0] ip address 30.1.1.2 24
    [LSRD-GigabitEthernet1/0/0] quit
    [LSRD] interface gigabitethernet 2/0/0
    [LSRD-GigabitEthernet2/0/0] undo portswitch
    [LSRD-GigabitEthernet2/0/0] ip address 40.1.1.2 24
    [LSRD-GigabitEthernet2/0/0] quit
    

    # Configure LSRE.

    <HUAWEI> system-view
    [HUAWEI] sysname LSRE
    [LSRE] interface loopback 1
    [LSRE-LoopBack1] ip address 5.5.5.5 32
    [LSRE-LoopBack1] quit
    [LSRE] interface gigabitethernet 1/0/0
    [LSRE-GigabitEthernet1/0/0] undo portswitch
    [LSRE-GigabitEthernet1/0/0] ip address 40.1.1.1 24
    [LSRE-GigabitEthernet1/0/0] quit
    

  2. Configure IGP, configure IS-IS on all nodes, and advertise the host routes of the LSR IDs.

    # Configure LSRA.

    [LSRA] isis 1
    [LSRA-isis-1] network-entity 86.1111.1111.1111.00
    [LSRA-isis-1] is-level level-2
    [LSRA-isis-1] cost-style wide
    [LSRA-isis-1] quit
    [LSRA] interface loopback 1
    [LSRA-LoopBack1] isis enable 1
    [LSRA-LoopBack1] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] isis enable 1
    [LSRA-GigabitEthernet1/0/0] quit

    # Configure LSRB.

    [LSRB] isis 1
    [LSRB-isis-1] network-entity 86.2222.2222.2222.00
    [LSRB-isis-1] is-level level-2
    [LSRB-isis-1] cost-style wide
    [LSRB-isis-1] traffic-eng level-2
    [LSRB-isis-1] quit
    [LSRB] interface loopback 1
    [LSRB-LoopBack1] isis enable 1
    [LSRB-LoopBack1] quit
    [LSRB] interface gigabitethernet 1/0/0
    [LSRB-GigabitEthernet1/0/0] isis enable 1
    [LSRB-GigabitEthernet1/0/0] quit
    [LSRB] interface gigabitethernet 2/0/0
    [LSRB-GigabitEthernet2/0/0] isis enable 1
    [LSRB-GigabitEthernet2/0/0] quit

    # Configure LSRC.

    [LSRC] isis 1
    [LSRC-isis-1] network-entity 86.3333.3333.3333.00
    [LSRC-isis-1] is-level level-2
    [LSRC-isis-1] cost-style wide
    [LSRC-isis-1] traffic-eng level-2
    [LSRC-isis-1] quit
    [LSRC] interface loopback 1
    [LSRC-LoopBack1] isis enable 1
    [LSRC-LoopBack1] quit
    [LSRC] interface gigabitethernet 1/0/0
    [LSRC-GigabitEthernet1/0/0] isis enable 1
    [LSRC-GigabitEthernet1/0/0] quit
    [LSRC] interface gigabitethernet 2/0/0
    [LSRC-GigabitEthernet2/0/0] isis enable 1
    [LSRC-GigabitEthernet2/0/0] quit

    # Configure LSRD.

    [LSRD] isis 1
    [LSRD-isis-1] network-entity 86.4444.4444.4444.00
    [LSRD-isis-1] is-level level-2
    [LSRD-isis-1] cost-style wide
    [LSRD-isis-1] traffic-eng level-2
    [LSRD-isis-1] quit
    [LSRD] interface loopback 1
    [LSRD-LoopBack1] isis enable 1
    [LSRD-LoopBack1] quit
    [LSRD] interface gigabitethernet 1/0/0
    [LSRD-GigabitEthernet1/0/0] isis enable 1
    [LSRD-GigabitEthernet1/0/0] quit
    [LSRD] interface gigabitethernet 2/0/0
    [LSRD-GigabitEthernet2/0/0] isis enable 1
    [LSRD-GigabitEthernet2/0/0] quit

    # Configure LSRE.

    [LSRE] isis 1
    [LSRE-isis-1] network-entity 86.5555.5555.5555.00
    [LSRE-isis-1] is-level level-2
    [LSRE-isis-1] cost-style wide
    [LSRE-isis-1] quit
    [LSRE] interface loopback 1
    [LSRE-LoopBack1] isis enable 1
    [LSRE-LoopBack1] quit
    [LSRE] interface gigabitethernet 1/0/0
    [LSRE-GigabitEthernet1/0/0] isis enable 1
    [LSRE-GigabitEthernet1/0/0] quit

    # Run the display ip routing-table command to display the routes that the local device has learned. The command output on LSRA is provided as an example.

    [LSRA] display ip routing-table
    Route Flags: R - relay, D - download to fib, T - to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 12       Routes : 12
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  Direct  0    0           D   127.0.0.1       LoopBack1
            2.2.2.2/32  ISIS-L2 15   10          D   10.1.1.2        GigabitEthernet1/0/0
            3.3.3.3/32  ISIS-L2 15   20          D   10.1.1.2        GigabitEthernet1/0/0
            4.4.4.4/32  ISIS-L2 15   30          D   10.1.1.2        GigabitEthernet1/0/0
            5.5.5.5/32  ISIS-L2 15   40          D   10.1.1.2        GigabitEthernet1/0/0
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        GigabitEthernet1/0/0
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet1/0/0
           20.1.1.0/24  ISIS-L2 15   20          D   10.1.1.2        GigabitEthernet1/0/0
           30.1.1.0/24  ISIS-L2 15   30          D   10.1.1.2        GigabitEthernet1/0/0
           40.1.1.0/24  ISIS-L2 15   40          D   10.1.1.2        GigabitEthernet1/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    

  3. Configure basic MPLS functions. Enable LDP between LSRA and LSRB, and between LSRD and LSRE. Enable RSVP among LSRB, LSRC, and LSRD.

    # Configure LSRA.

    [LSRA] mpls lsr-id 1.1.1.1
    [LSRA] mpls
    [LSRA-mpls] quit
    [LSRA] mpls ldp
    [LSRA-mpls-ldp] quit
    [LSRA] interface gigabitethernet 1/0/0
    [LSRA-GigabitEthernet1/0/0] mpls
    [LSRA-GigabitEthernet1/0/0] mpls ldp
    [LSRA-GigabitEthernet1/0/0] quit

    # Configure LSRB.

    [LSRB] mpls lsr-id 2.2.2.2
    [LSRB] mpls
    [LSRB-mpls] mpls te
    [LSRB-mpls] mpls rsvp-te
    [LSRB-mpls] mpls te cspf
    [LSRB-mpls] quit
    [LSRB] mpls ldp
    [LSRB-mpls-ldp] quit
    [LSRB] interface gigabitethernet 1/0/0
    [LSRB-GigabitEthernet1/0/0] mpls
    [LSRB-GigabitEthernet1/0/0] mpls ldp
    [LSRB-GigabitEthernet1/0/0] quit
    [LSRB] interface gigabitethernet 2/0/0
    [LSRB-GigabitEthernet2/0/0] mpls
    [LSRB-GigabitEthernet2/0/0] mpls te
    [LSRB-GigabitEthernet2/0/0] mpls rsvp-te
    [LSRB-GigabitEthernet2/0/0] quit

    # Configure LSRC.

    [LSRC] mpls lsr-id 3.3.3.3
    [LSRC] mpls
    [LSRC-mpls] mpls te
    [LSRC-mpls] mpls rsvp-te
    [LSRC-mpls] quit
    [LSRC] interface gigabitethernet 1/0/0
    [LSRC-GigabitEthernet1/0/0] mpls
    [LSRC-GigabitEthernet1/0/0] mpls te
    [LSRC-GigabitEthernet1/0/0] mpls rsvp-te
    [LSRC-GigabitEthernet1/0/0] quit
    [LSRC] interface gigabitethernet 2/0/0
    [LSRC-GigabitEthernet2/0/0] mpls
    [LSRC-GigabitEthernet2/0/0] mpls te
    [LSRC-GigabitEthernet2/0/0] mpls rsvp-te
    [LSRC-GigabitEthernet2/0/0] quit

    # Configure LSRD.

    [LSRD] mpls lsr-id 4.4.4.4
    [LSRD] mpls
    [LSRD-mpls] mpls te
    [LSRD-mpls] mpls rsvp-te
    [LSRD-mpls] mpls te cspf
    [LSRD-mpls] quit
    [LSRD] mpls ldp
    [LSRD-mpls-ldp] quit
    [LSRD] interface gigabitethernet 1/0/0
    [LSRD-GigabitEthernet1/0/0] mpls
    [LSRD-GigabitEthernet1/0/0] mpls te
    [LSRD-GigabitEthernet1/0/0] mpls rsvp-te
    [LSRD-GigabitEthernet1/0/0] quit
    [LSRD] interface gigabitethernet 2/0/0
    [LSRD-GigabitEthernet2/0/0] mpls
    [LSRD-GigabitEthernet2/0/0] mpls ldp
    [LSRD-GigabitEthernet2/0/0] quit

    # Configure LSRE.

    [LSRE] mpls lsr-id 5.5.5.5
    [LSRE] mpls
    [LSRE-mpls] quit
    [LSRE] mpls ldp
    [LSRE-mpls-ldp] quit
    [LSRE] interface gigabitethernet 1/0/0
    [LSRE-GigabitEthernet1/0/0] mpls
    [LSRE-GigabitEthernet1/0/0] mpls ldp
    [LSRE-GigabitEthernet1/0/0] quit

    # Run the display mpls ldp session command to display the LDP session status. The command output indicates that the status of the local LDP sessions between LSRA and LSRB and between LSRD and LSRE are Operational, namely, the local LDP sessions between LSRA and LSRB and between LSRD and LSRE have been successfully established. The command outputs on LSRA and LSRB are provided as an example.

    [LSRA] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.2:0          Operational DU   Passive  0000:00:50  201/201
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    
    
    [LSRB] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
     ------------------------------------------------------------------------------
     PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
     ------------------------------------------------------------------------------
     1.1.1.1:0          Operational DU   Active   0000:01:58  474/474
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    
    

    # Run the display mpls ldp peer command to display the LDP peer information. The command outputs on LSRA and LSRB are provided as an example.

    [LSRA] display mpls ldp peer
    
     LDP Peer Information in Public network
     A '*' before a peer means the peer is being deleted.
     ------------------------------------------------------------------------------
     PeerID                 TransportAddress   DiscoverySource
     ------------------------------------------------------------------------------
     2.2.2.2:0              2.2.2.2            GigabitEthernet1/0/0
     ------------------------------------------------------------------------------
     TOTAL: 1 Peer(s) Found.
    
    
    [LSRB] display mpls ldp peer
    
     LDP Peer Information in Public network
     A '*' before a peer means the peer is being deleted.
     ------------------------------------------------------------------------------
     PeerID                 TransportAddress   DiscoverySource
     ------------------------------------------------------------------------------
     1.1.1.1:0              1.1.1.1            GigabitEthernet1/0/0
     ------------------------------------------------------------------------------
     TOTAL: 1 Peer(s) Found.
    
    

    # Run the display mpls lsp command to display the LDP LSP information. The command output indicates that the RSVP LSP has not been established. The command outputs on LSRA and LSRB are provided as an example.

    [LSRA] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    1.1.1.1/32         3/NULL        -/-
    2.2.2.2/32         NULL/3        -/GE1/0/0
    2.2.2.2/32         1024/3        -/GE1/0/0
    [LSRB] display mpls lsp
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    2.2.2.2/32         3/NULL        -/-
    1.1.1.1/32         NULL/3        -/GE1/0/0
    1.1.1.1/32         1024/3        -/GE1/0/0

  4. Configure a remote LDP session between LSRB and LSRD.

    # Configure LSRB.

    [LSRB] mpls ldp remote-peer lsrd
    [LSRB-mpls-ldp-remote-lsrd] remote-ip 4.4.4.4
    [LSRB-mpls-ldp-remote-lsrd] quit

    # Configure LSRD.

    [LSRD] mpls ldp remote-peer lsrb
    [LSRD-mpls-ldp-remote-lsrb] remote-ip 2.2.2.2
    [LSRD-mpls-ldp-remote-lsrb] quit

    # Run the display mpls ldp remote-peer command to display the remote peer information about the LDP session. The command output indicates that a remote session has been established between LSRB and LSRD. The command output on LSRB is provided as an example.

    [LSRB] display mpls ldp remote-peer lsrd
    
                             LDP Remote Entity Information
     ------------------------------------------------------------------------------
     Remote Peer Name  : lsrd
     Remote Peer IP    : 4.4.4.4            LDP ID        : 2.2.2.2:0
     Transport Address : 2.2.2.2            Entity Status : Active
    
     Configured Keepalive Hold Timer : 45 Sec
     Configured Keepalive Send Timer : ---
     Configured Hello Hold Timer     : 45 Sec
     Negotiated Hello Hold Timer     : 45 Sec
     Configured Hello Send Timer     : ---
     Configured Delay Timer          : 10 Sec
     Hello Packet sent/received      : 6/5
     Label Advertisement Mode        : Downstream Unsolicited
     Remote Peer Deletion Status     : No
     Auto-config                     : ---
     ------------------------------------------------------------------------------
    

  5. Enable the LDP over TE function.

    # Enable the LDP over TE function on LSRB that is the ingress node of the TE tunnel.

    [LSRB] mpls ldp
    [LSRB-mpls-ldp] ldp-over-te enable
    [LSRB-mpls-ldp] quit

    # Enable the LDP over TE function on LSRD that is the ingress node of the TE tunnel.

    [LSRD] mpls ldp
    [LSRD-mpls-ldp] ldp-over-te enable
    [LSRD-mpls-ldp] quit

  6. Configure the bandwidth attributes for the outgoing interfaces of links along the TE tunnel.

    # Configure LSRB.

    [LSRB] interface gigabitethernet 2/0/0
    [LSRB-GigabitEthernet2/0/0] mpls te bandwidth max-reservable-bandwidth 20000
    [LSRB-GigabitEthernet2/0/0] mpls te bandwidth bc0 20000
    [LSRB-GigabitEthernet2/0/0] quit

    # Configure LSRC.

    [LSRC] interface gigabitethernet 1/0/0
    [LSRC-GigabitEthernet1/0/0] mpls te bandwidth max-reservable-bandwidth 20000
    [LSRC-GigabitEthernet1/0/0] mpls te bandwidth bc0 20000
    [LSRC-GigabitEthernet1/0/0] quit
    [LSRC] interface gigabitethernet 2/0/0
    [LSRC-GigabitEthernet2/0/0] mpls te bandwidth max-reservable-bandwidth 20000
    [LSRC-GigabitEthernet2/0/0] mpls te bandwidth bc0 20000
    [LSRC-GigabitEthernet2/0/0] quit

    # Configure LSRD.

    [LSRD] interface gigabitethernet 1/0/0
    [LSRD-GigabitEthernet1/0/0] mpls te bandwidth max-reservable-bandwidth 20000
    [LSRD-GigabitEthernet1/0/0] mpls te bandwidth bc0 20000
    [LSRD-GigabitEthernet1/0/0] quit

  7. Configure a tunnel from LSRB to LSRD.

    # Configure LSRB. Enable forwarding adjacency on the tunnel interface and adjust the metric of forwarding adjacency so that traffic destined for LSRD or LSRE passes through the tunnel.

    [LSRB] interface tunnel 1
    [LSRB-Tunnel1] ip address unnumbered interface loopback 1
    [LSRB-Tunnel1] tunnel-protocol mpls te
    [LSRB-Tunnel1] destination 4.4.4.4
    [LSRB-Tunnel1] mpls te tunnel-id 100
    [LSRB-Tunnel1] mpls te bandwidth ct0 10000
    [LSRB-Tunnel1] mpls te igp advertise
    [LSRB-Tunnel1] mpls te igp metric absolute 1
    [LSRB-Tunnel1] mpls te commit
    [LSRB-Tunnel1] isis enable 1
    [LSRB-Tunnel1] quit

  8. Configure a tunnel from LSRD to LSRB.

    # Configure LSRD. Enable forwarding adjacency on the tunnel interface and adjust the metric of forwarding adjacency so that traffic destined for LSRA or LSRB passes through the tunnel.

    [LSRD] interface tunnel 1
    [LSRD-Tunnel1] ip address unnumbered interface loopback 1
    [LSRD-Tunnel1] tunnel-protocol mpls te
    [LSRD-Tunnel1] destination 2.2.2.2
    [LSRD-Tunnel1] mpls te tunnel-id 100
    [LSRD-Tunnel1] mpls te bandwidth ct0 10000
    [LSRD-Tunnel1] mpls te igp advertise
    [LSRD-Tunnel1] mpls te igp metric absolute 1
    [LSRD-Tunnel1] mpls te commit
    [LSRD-Tunnel1] isis enable 1
    [LSRD-Tunnel1] quit

  9. Verify the configuration.

    # Run the display interface tunnel command to display the tunnel status. The command output indicates that the status of tunnel1 is Up. The command output on LSRB is provided as an example.

    [LSRB] display interface tunnel
    Tunnel1 current state : UP
    Line protocol current state : UP
    Last line protocol up time : 2018-09-20 08:18:07
    …
    

    # Run the display mpls lsp command on LSRB, LSRC, and LSRD to display the RSVP LSP information. The command outputs on LSRB and LSRC are provided as an example.

    [LSRB] display mpls lsp
    -------------------------------------------------------------------------------
                     LSP Information: RSVP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    4.4.4.4/32         NULL/1024     -/GE2/0/0
    2.2.2.2/32         3/NULL        GE2/0/0/-
    
    Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
    -------------------------------------------------------------------------------
                     LSP Information: LDP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    2.2.2.2/32         3/NULL        -/-
    1.1.1.1/32         NULL/3        -/GE1/0/0
    1.1.1.1/32         1024/3        -/GE1/0/0
    4.4.4.4/32         NULL/3        -/Tun1
    4.4.4.4/32         1025/3        -/Tun1
    5.5.5.5/32         NULL/1024     -/Tun1
    5.5.5.5/32         1026/1024     -/Tun1
    [LSRC] display mpls lsp
    -------------------------------------------------------------------------------
                     LSP Information: RSVP LSP
    -------------------------------------------------------------------------------
    FEC                In/Out Label  In/Out IF                      Vrf Name
    4.4.4.4/32         1024/3        GE1/0/0/GE2/0/0
    2.2.2.2/32         1025/3        GE2/0/0/GE1/0/0

Configuration Files

  • Configuration file of LSRA

    #
    sysname LSRA
    #
    mpls lsr-id 1.1.1.1
    mpls
    #
    mpls ldp
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 86.1111.1111.1111.00
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
    return
  • Configuration file of LSRB

    #
    sysname LSRB
    #
    mpls lsr-id 2.2.2.2
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    mpls ldp
     ldp-over-te enable
    #
    #
    mpls ldp remote-peer lsrd
     remote-ip 4.4.4.4
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 86.2222.2222.2222.00
     traffic-eng level-2
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     ip address 20.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 20000
     mpls te bandwidth bc0 20000
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 4.4.4.4
     mpls te tunnel-id 100
     mpls te bandwidth ct0 10000
     mpls te igp advertise
     mpls te igp metric absolute 1
     mpls te commit
     isis enable 1
    #
    return
  • Configuration file of LSRC

    #
    sysname LSRC
    #
    mpls lsr-id 3.3.3.3
    mpls
     mpls te
     mpls rsvp-te
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 86.3333.3333.3333.00
     traffic-eng level-2
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 20.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 20000
     mpls te bandwidth bc0 20000
     mpls rsvp-te
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     ip address 30.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 20000
     mpls te bandwidth bc0 20000
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
    return
  • Configuration file of LSRD

    #
    sysname LSRD
    #
    mpls lsr-id 4.4.4.4
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    mpls ldp
     ldp-over-te enable
    #
    #
    mpls ldp remote-peer lsrb
     remote-ip 2.2.2.2
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 86.4444.4444.4444.00
     traffic-eng level-2
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 30.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 20000
     mpls te bandwidth bc0 20000
     mpls rsvp-te
    #
    interface GigabitEthernet2/0/0
     undo portswitch
     ip address 40.1.1.2 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
     isis enable 1
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 2.2.2.2
     mpls te tunnel-id 100
     mpls te bandwidth ct0 10000
     mpls te igp advertise
     mpls te igp metric absolute 1
     mpls te commit
     isis enable 1
    #
    return
  • Configuration file of LSRE

    #
    sysname LSRE
    #
    mpls lsr-id 5.5.5.5
    mpls
    #
    mpls ldp
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 86.5555.5555.5555.00
    #
    interface GigabitEthernet1/0/0
     undo portswitch
     ip address 40.1.1.1 255.255.255.0
     isis enable 1
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
     isis enable 1
    #
    return
Translation
Download
Updated: 2019-04-08

Document ID: EDOC1100065745

Views: 20087

Downloads: 14

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next