No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

S9300, S9300E, and S9300X V200R013C00

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, NSR Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, MAC Swap Loopback Configuration, EFM Configuration, CFM Configuration, Y.1731 Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring AIS

Example for Configuring AIS

Networking Requirements

AIS is used to prevent a MEP in an MD of a higher level from sending the same trap as that sent by a MEP in an MD of a lower level to the NMS.

In Figure 10-13, CE1 is connected to PE1 and CE2 is connected to PE2 through sub-interfaces. A VLAN is created between PEs.

AIS is configured on PEs and alarm suppression is enabled on CEs. In MD nesting scenarios, if a MEP in a low-level MD detects a fault, the MEP sends a trap to the NMS. After a certain period, a MEP in the MD of a higher level also detects the fault and sends the same trap to the NMS. In this case, the MEP in the MD of a higher level must be prevented from sending the same trap to the NMS.

Figure 10-13  Configuring AIS

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add PEs to an MD, add CEs to an MD, and ensure that the level of the MD to which the PEs belong is lower than that to which CEs belong so that the MEP in the MD of a higher level is suppressed from sending the same trap to the NMS.

  2. Configure alarm suppression to suppress MEPs in MDs of different levels from sending the same trap to the NMS.

Procedure

  1. Configure VLANs.

    # Configure PE1.

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] vlan batch 2 10
    [PE1] interface gigabitethernet 1/0/1
    [PE1-GigabitEthernet1/0/1] port link-type trunk
    [PE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 10
    [PE1-GigabitEthernet1/0/1] quit
    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] port link-type trunk
    [PE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 10
    [PE1-GigabitEthernet1/0/2] quit

    # Configure PE2.

    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] vlan batch 2 10
    [PE2] interface gigabitethernet 1/0/1
    [PE2-GigabitEthernet1/0/1] port link-type trunk
    [PE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 10
    [PE2-GigabitEthernet1/0/1] quit
    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] port link-type trunk
    [PE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 10
    [PE2-GigabitEthernet1/0/2] quit

    # Configure CE1.

    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] vlan batch 10
    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] port link-type trunk
    [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [CE1-GigabitEthernet1/0/1] quit

    # Configure CE2.

    <Quidway> system-view
    [Quidway] sysname CE2
    [CE2] vlan batch 10
    [CE2] interface gigabitethernet 1/0/1
    [CE2-GigabitEthernet1/0/1] port link-type trunk
    [CE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [CE2-GigabitEthernet1/0/1] quit

  2. Configure basic Ethernet CFM functions.

    Configure basic Ethernet CFM functions on each PE. Create an MD named md1 and an MA named ma1, and bind the MA to the VLAN.

    # Configure PE1.

    [PE1] cfm enable
    [PE1] cfm md md1 level 3
    [PE1-md-md1] ma ma1
    [PE1-md-md1-ma-ma1] map vlan 2
    [PE1-md-md1-ma-ma1] quit
    [PE1-md-md1] quit

    # Configure PE2.

    [PE2] cfm enable
    [PE2] cfm md md1 level 3
    [PE2-md-md1] ma ma1
    [PE2-md-md1-ma-ma1] map vlan 2
    [PE2-md-md1-ma-ma1] quit
    [PE2-md-md1] quit

    Configure basic Ethernet CFM functions on each CE. Specify CFM version as IEEE Standard 802.1ag-2007, and create an MD named md2 and an MA named ma2.

    # Configure CE1.

    [CE1] cfm enable
    [CE1] cfm md md2 level 6
    [CE1-md-md2] ma ma2
    [CE1-md-md2-ma-ma2] map vlan 10
    [CE1-md-md2-ma-ma2] quit
    [CE1-md-md2] quit

    # Configure CE2.

    [CE2] cfm enable
    [CE2] cfm md md2 level 6
    [CE2-md-md2] ma ma2
    [CE2-md-md2-ma-ma2] map vlan 10
    [CE2-md-md2-ma-ma2] quit
    [CE2-md-md2] quit

  3. Create an inward-facing MEP on the CE interface of each PE.

    # Configure PE1.

    [PE1] cfm md md1
    [PE1-md-md1] ma ma1
    [PE1-md-md1-ma-ma1] mep mep-id 31 interface gigabitethernet 1/0/1 inward
    [PE1-md-md1-ma-ma1] mep ccm-send enable
    [PE1-md-md1-ma-ma1] remote-mep mep-id 32
    [PE1-md-md1-ma-ma1] remote-mep ccm-receive enable
    [PE1-md-md1-ma-ma1] quit
    [PE1-md-md1] quit

    # Configure PE2.

    [PE2] cfm md md1
    [PE2-md-md1] ma ma1
    [PE2-md-md1-ma-ma1] mep mep-id 32 interface gigabitethernet 1/0/1 inward
    [PE2-md-md1-ma-ma1] mep ccm-send enable
    [PE2-md-md1-ma-ma1] remote-mep mep-id 31
    [PE2-md-md1-ma-ma1] remote-mep ccm-receive enable
    [PE2-md-md1-ma-ma1] quit
    [PE2-md-md1] quit

  4. Create an outward-facing MEP on each CE.

    # Configure CE1.

    [CE1] cfm md md2
    [CE1-md-md2] ma ma2
    [CE1-md-md2-ma-ma2] mep mep-id 61 interface gigabitethernet 1/0/1 outward
    [CE1-md-md2-ma-ma2] ccm-interval 10000
    [CE1-md-md2-ma-ma2] mep ccm-send enable
    [CE1-md-md2-ma-ma2] remote-mep mep-id 62
    [CE1-md-md2-ma-ma2] remote-mep ccm-receive enable
    [CE1-md-md2-ma-ma2] quit
    [CE1-md-md2] quit

    # Configure CE2.

    [CE2] cfm md md2
    [CE2-md-md2] ma ma2
    [CE2-md-md2-ma-ma2] mep mep-id 62 interface gigabitethernet 1/0/1 outward
    [CE2-md-md2-ma-ma2] ccm-interval 10000
    [CE2-md-md2-ma-ma2] mep ccm-send enable
    [CE2-md-md2-ma-ma2] remote-mep mep-id 61
    [CE2-md-md2-ma-ma2] remote-mep ccm-receive enable
    [CE2-md-md2-ma-ma2] quit
    [CE2-md-md2] quit

  5. Verify the CFM configuration.

    # Run the display cfm remote-mep command on CE1 and PE1. You can view MEP information.

    [CE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md2
     Level              : 6
     MA Name            : ma2
     RMEP ID            : 62
     VLAN ID            : 10
     VSI Name           : --
     L2VC ID            : --
     MAC                : 00e0-0003-0003
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up  
    [PE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md1
     Level              : 3
     MA Name            : ma1
     RMEP ID            : 32
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5410
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up  

  6. Configure AIS.

    # Configure PE1.

    [PE1] cfm md md1
    [PE1-md-md1] ma ma1
    [PE1-md-md1-ma-ma1] ais enable
    [PE1-md-md1-ma-ma1] ais link-status interface gigabitethernet 1/0/2
    [PE1-md-md1-ma-ma1] ais level 6
    [PE1-md-md1-ma-ma1] ais interval 1
    [PE1-md-md1-ma-ma1] ais vlan vid 10 mep 31
    [PE1-md-md1-ma-ma1] quit
    [PE1-md-md1] quit

    # Configure PE2.

    [PE2] cfm md md1
    [PE2-md-md1] ma ma1
    [PE2-md-md1-ma-ma1] ais enable
    [PE2-md-md1-ma-ma1] ais link-status interface gigabitethernet 1/0/2
    [PE2-md-md1-ma-ma1] ais level 6
    [PE2-md-md1-ma-ma1] ais interval 1
    [PE2-md-md1-ma-ma1] ais vlan vid 10 mep 32
    [PE2-md-md1-ma-ma1] quit
    [PE2-md-md1] quit

  7. Enable alarm suppression.

    # Configure CE1.

    [CE1] cfm md md2
    [CE1-md-md2] ma ma2
    [CE1-md-md2-ma-ma2] ais enable
    [CE1-md-md2-ma-ma2] ais suppress-alarm
    [CE1-md-md2-ma-ma2] quit
    [CE1-md-md2] quit

    # Configure CE2.

    [CE2] cfm md md2
    [CE2-md-md2] ma ma2
    [CE2-md-md2-ma-ma2] ais enable
    [CE2-md-md2-ma-ma2] ais suppress-alarm
    [CE2-md-md2-ma-ma2] quit
    [CE2-md-md2] quit

  8. Verify the configuration.

    # After association functions are configured, run the shutdown command on GE1/0/2 of PE1 to simulate a fault occurs in the VLAN between PE1 and PE2.

    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] shutdown
    [PE1-GigabitEthernet1/0/2] quit

    # Run the display cfm ma md md1 ma ma1 command on PE1. The value of the Sending Ais Packet field is displayed as Yes in the command output. Run the display cfm ma md md2 ma ma2 command on CE1. The value of the Suppressing Alarms field is displayed as Yes in the command output.

    [PE1] display cfm ma md md1 ma ma1
      MD Name            : md1
      MD Name Format     : string
      Level              : 3
      MIP Create-type    : none
      SenderID TLV-type  : defer
      MA Name            : ma1
      MA Name Format     : string
      Interval           : 1000
      Priority           : 7
      VLAN ID            : 2
      VSI Name           : --
      L2VC ID            : --
      MEP Number         : 1
      RMEP Number        : 1
      Suppressing Alarms : No
      Sending AIS Packet : Yes
      Interface TLV      : disabled 
      RDI Track-action   : all-enabled
    [CE1] display cfm ma md md2 ma ma2
      MD Name            : md2
      MD Name Format     : string
      Level              : 6
      MIP Create-type    : none
      SenderID TLV-type  : defer
      MA Name            : ma2
      MA Name Format     : string
      Interval           : 10000
      Priority           : 7
      VLAN ID            : 10
      VSI Name           : --
      L2VC ID            : --
      MEP Number         : 1
      RMEP Number        : 1
      Suppressing Alarms : Yes
      Sending AIS Packet : No
      Interface TLV      : disabled 
      RDI Track-action   : all-enabled

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 2 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 10
    #
    cfm md md1 level 3
     ma ma1
      map vlan 2
      mep mep-id 31 interface GigabitEthernet1/0/1 inward
      mep ccm-send mep-id 31 enable
      remote-mep mep-id 32
      remote-mep ccm-receive mep-id 32 enable
      ais enable
      ais level 6
      ais vlan vid 10 mep 31
      ais link-status interface GigabitEthernet1/0/2
    #
    return 
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 2 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 10
    #
    cfm md md1 level 3
     ma ma1
      map vlan 2
      mep mep-id 32 interface GigabitEthernet1/0/1 inward
      mep ccm-send mep-id 32 enable
      remote-mep mep-id 31
      remote-mep ccm-receive mep-id 31 enable
      ais enable
      ais level 6
      ais vlan vid 10 mep 32
      ais link-status interface GigabitEthernet1/0/2
    #
    return 
  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    cfm md md2 level 6
     ma ma2
      map vlan 10
      ccm-interval 10000
      mep mep-id 61 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 61 enable
      remote-mep mep-id 62
      remote-mep ccm-receive mep-id 62 enable
      ais enable
      ais suppress-alarm
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 10
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    cfm md md2 level 6
     ma ma2
      map vlan 10
      ccm-interval 10000
      mep mep-id 62 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 62 enable
      remote-mep mep-id 61
      remote-mep ccm-receive mep-id 61 enable
      ais enable
      ais suppress-alarm
    #
    return
Translation
Download
Updated: 2019-04-09

Document ID: EDOC1100065868

Views: 18371

Downloads: 11

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next