No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

S9300, S9300E, and S9300X V200R013C00

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, NSR Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, MAC Swap Loopback Configuration, EFM Configuration, CFM Configuration, Y.1731 Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring One-way Frame Delay Measurement in a VLAN

Example for Configuring One-way Frame Delay Measurement in a VLAN

Networking Requirements

As networks continue to rapidly develop and applications become more and more diversified, various value-added services such as IPTV, video conferencing and VOIP are becoming more widely used. Link connectivity and network performance determine QoS on bearer networks. Therefore, performance monitoring is important for service transmission.

As shown in Figure 10-11, CFM is configured between CEs. To provide high-quality video services, carriers need to monitor the one-way delay over mobile bearer links in real time, while monitoring link connectivity. Monitoring the one-way delay over mobile bearer links allows the carriers to respond quickly to video service quality deterioration.

Figure 10-11  Configuring Y.1731 in a VLAN

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure on-demand one-way frame delay measurement for the end-to-end link between the CEs to periodically collect statistics about the delay in frame transmission.

Procedure

  1. Configure VLANs.

    # Configure CE1.

    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] vlan 2
    [CE1-vlan2] quit
    [CE1] interface gigabitethernet 1/0/1
    [CE1-GigabitEthernet1/0/1] port link-type trunk
    [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [CE1-GigabitEthernet1/0/1] quit
    

    # Configure CE2.

    <Quidway> system-view
    [Quidway] sysname CE2
    [CE2] vlan 2
    [CE2-vlan2] quit
    [CE2] interface gigabitethernet 1/0/1
    [CE2-GigabitEthernet1/0/1] port link-type trunk
    [CE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [CE2-GigabitEthernet1/0/1] quit

    # Configure PE1.

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] vlan 2
    [PE1-vlan2] quit
    [PE1] interface gigabitethernet 1/0/1
    [PE1-GigabitEthernet1/0/1] port link-type trunk
    [PE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [PE1-GigabitEthernet1/0/1] quit
    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] port link-type trunk
    [PE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [PE1-GigabitEthernet1/0/2] quit

    # Configure the PE2.

    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] vlan 2
    [PE2-vlan2] quit
    [PE2] interface gigabitethernet 1/0/1
    [PE2-GigabitEthernet1/0/1] port link-type trunk
    [PE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [PE2-GigabitEthernet1/0/1] quit
    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] port link-type trunk
    [PE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [PE2-GigabitEthernet1/0/2] quit

  2. Configure basic Ethernet CFM functions and specify the MEP type as outward.

    Configure basic Ethernet CFM functions on each CE. Create an MD named md3 and an MA named ma3, and bind the MA to the VLAN.

    # Configure CE1.

    [CE1] cfm enable
    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] map vlan 2
    [CE1-md-md3-ma-ma3] mep mep-id 3 interface gigabitethernet 1/0/1 outward
    [CE1-md-md3-ma-ma3] mep ccm-send mep-id 3 enable
    [CE1-md-md3-ma-ma3] remote-mep mep-id 4
    [CE1-md-md3-ma-ma3] remote-mep ccm-receive mep-id 4 enable
    [CE1-md-md3-ma-ma3] quit
    [CE1-md-md3] quit

    # Configure CE2.

    [CE2] cfm enable
    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] map vlan 2
    [CE2-md-md3-ma-ma3] mep mep-id 4 interface gigabitethernet 1/0/1 outward
    [CE2-md-md3-ma-ma3] mep ccm-send mep-id 4 enable
    [CE2-md-md3-ma-ma3] remote-mep mep-id 3
    [CE2-md-md3-ma-ma3] remote-mep ccm-receive mep-id 3 enable
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  3. Verify the CFM configuration.

    # Run the display cfm remote-mep command on CE1 and CE2. You can view MEP information.

    [CE1] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable        
    --------------------------------------------------
     MD Name            : md3
     Level              : 0
     MA Name            : ma3
     RMEP ID            : 4
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 4c1f-cc6b-c208
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up
    [CE2] display cfm remote-mep
    The total number of RMEPs is : 1
    The status of RMEPs : 1 up, 0 down, 0 disable
    --------------------------------------------------
     MD Name            : md3
     Level              : 0
     MA Name            : ma3
     RMEP ID            : 3
     VLAN ID            : 2
     VSI Name           : --
     L2VC ID            : --
     MAC                : 0044-0141-5410
     CCM Receive        : enabled
     Trigger-If-Down    : disabled
     CFM Status         : up
     Alarm Status       : none
     Interface TLV      : --
     Connect Status     : up 

  4. Configure CE2 to receive DM frames.

    # Configure CE2.

    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] delay-measure one-way receive mep 4
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  5. Enable one-way frame delay measurement.

    # Configure CE1.

    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] delay-measure one-way send mep 3 remote-mep 4 interval 1000 count 20
    [CE1-md-md3-ma-ma3] quit
    [CE1-md-md3] quit

  6. Verify the configuration.

    # After the configuration is complete, run the display y1731 statistic-type oneway-delay md md3 ma ma3 command on CE2. You can see statistics about the one-way frame delay.

    [CE2] display y1731 statistic-type oneway-delay md md3 ma ma3
    Measurement Start Time : 2014-11-01 15:41:27
    Latest one-way delay statistics:
    --------------------------------------------------------------------------------
    Index    Delay(usec)    Delay variation(usec)
    --------------------------------------------------------------------------------
        1          10000                        -
        2          10000                        0
        3          10000                        0
        4          10000                        0
        5          10000                        0
        6          10000                        0
        7          10000                        0
        8          10000                        0
        9          10000                        0
       10          10000                        0
       11          10000                        0
       12          40000                    30000
       13          10000                    30000
       14          10000                        0
       15          10000                        0
       16          10000                        0
       17          10000                        0
       18          10000                        0
       19          10000                        0
       20          10000                        0
    --------------------------------------------------------------------------------
    Average delay(usec) :      11764    Average delay variation(usec) :       3750
    Maximum delay(usec) :      40000    Maximum delay variation(usec) :      30000
    Minimum delay(usec) :      10000    Minimum delay variation(usec) :          0

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 3 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 3 enable
      remote-mep mep-id 4
      remote-mep ccm-receive mep-id 4 enable
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 2
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 4 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 4 enable
      remote-mep mep-id 3
      remote-mep ccm-receive mep-id 3 enable
      delay-measure one-way receive mep 4
    #
    return
  • PE1 configuration file

    #                                                                               
    sysname PE1                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet1/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return
  • PE2 configuration file

    #                                                                               
    sysname PE2                                                                    
    #                                                                               
    vlan batch 2                                                                    
    #                                                                               
    interface GigabitEthernet1/0/1                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    interface GigabitEthernet1/0/2                                                  
     port link-type trunk                                                           
     port trunk allow-pass vlan 2                                                   
    #                                                                               
    return
Translation
Download
Updated: 2019-04-09

Document ID: EDOC1100065868

Views: 17984

Downloads: 11

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next