No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R013C00 Configuration Guide - User Access and Authentication

This document describes the configurations of User Access and Authentication Configuration, including AAA, NAC, and Policy Association.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Combined Authentication on a Layer 2 Interface

Example for Configuring Combined Authentication on a Layer 2 Interface

Networking Requirements

As shown in Figure 3-21, users in a company access the enterprise network through GE0/0/1 of the Switch (used as an access device). To effectively manage the users accessing the enterprise network, the company requires that only authorized users can access the network. In addition, many types of user terminals need to access the network, so the administrator configure combined authentication for the users.

Figure 3-21  Networking diagram for configuring combined authentication

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create and configure a RADIUS server template, an AAA scheme, and an authentication domain. Bind the RADIUS server template and the AAA scheme to the authentication domain. The Switch can then exchange information with the RADIUS server.
  2. Configure built-in Portal authentication so that terminals can connect to the network using Portal authentication.
  3. Configure 802.1X authentication so that terminals can connect to the network using 802.1X authentication.
  4. Configure MAC address authentication so that terminals can connect to the network using MAC address authentication.
NOTE:

This example only provides the configurations on the Switch. The configurations on LAN switch and RADIUS server are not provided here.

Procedure

  1. Create VLANs and configure the VLAN allowed by the interface to ensure network communication.

    # Create VLAN 10 and VLAN 20.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    

    # On the Switch, set GE0/0/1 connecting to users as an access interface, and add GE0/0/1 to VLAN 10.

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] port default vlan 10 
    [Switch-GigabitEthernet0/0/1] quit
    NOTE:

    Configure the interface type and VLANs according to the actual situation. In this example, users are added to VLAN 10.

    # On the Switch, set GE0/0/2 connecting to the RADIUS server as an access interface, and add GE0/0/2 to VLAN 20.

    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access
    [Switch-GigabitEthernet0/0/2] port default vlan 20
    [Switch-GigabitEthernet0/0/2] quit

  2. Create and configure a RADIUS server template, an AAA scheme, and an authentication domain.

    # Create and configure RADIUS server template rd1.

    [Switch] radius-server template rd1
    [Switch-radius-rd1] radius-server authentication 192.168.2.30 1812
    [Switch-radius-rd1] radius-server shared-key cipher Huawei@2012
    [Switch-radius-rd1] quit

    # Create AAA scheme abc and set the authentication mode to RADIUS.

    [Switch] aaa
    [Switch-aaa] authentication-scheme abc
    [Switch-aaa-authen-abc] authentication-mode radius
    [Switch-aaa-authen-abc] quit

    # Create authentication domain isp1, and bind AAA scheme abc and RADIUS server template rd1 to authentication domain isp1.

    [Switch-aaa] domain isp1
    [Switch-aaa-domain-isp1] authentication-scheme abc
    [Switch-aaa-domain-isp1] radius-server rd1
    [Switch-aaa-domain-isp1] quit
    [Switch-aaa] quit

    # Configure the default domain isp1 in the system view. When a user enters the user name in the format of user@isp1, the user is authenticated in the authentication domain isp1. If the user name does not carry the domain name or carries a nonexistent domain name, the user is authenticated in the default domain.

    [Switch] domain isp1

    # Test whether a user can be authenticated using RADIUS authentication. A user name test@huawei.com and password Huawei2012 have been configured on the RADIUS server.

    [Switch] test-aaa test@huawei.com Huawei2012 radius-template rd1
    Info: Account test succeed.

  3. Configure built-in Portal authentication.

    # Switch the NAC mode to common mode.

    [Switch] undo authentication unified-mode
    Warning: Switching the authentication mode will take effect after system restart
    . Some configurations are invalid after the mode is switched. For the invalid co
    mmands, see the user manual. Save the configuration file and reboot now? [Y/N] y
    NOTE:
    • By default, the NAC unified mode is used.
    • After the unified mode is switched to common mode, you must save the configuration and restart the device to make each function in the new configuration mode take effect.

    # Create a loopback interface and assign an IP address to the loopback interface.

    [HUAWEI] interface loopback 6
    [HUAWEI-LoopBack6] ip address 192.168.1.30 32
    [HUAWEI-LoopBack6] quit

    # Configure an IP address for the built-in Portal authentication server.

    [HUAWEI] portal local-server ip 192.168.1.30

    # Configure an SSL policy required for opening the built-in Portal authentication page.

    [HUAWEI] ssl policy huawei
    [HUAWEI-ssl-policy-huawei] certificate load asn1-cert servercert.der key-pair dsa key-file serverkey.der
    [HUAWEI-ssl-policy-huawei] quit
    NOTE:

    Before loading a certificate for the SSL policy, ensure that the certificate file and key pair file have been stored on the device; otherwise, the certificate fails to be loaded. In addition, the certificate file and key pair file must be saved in the security subdirectory of the system root directory. If the security subdirectory does not exist, create it.

    # Enable built-in Portal authentication.

    [HUAWEI] portal local-server https ssl-policy huawei
    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] portal local-server enable
    [HUAWEI-GigabitEthernet0/0/1] quit

  4. Configure 802.1X authentication.

    # Enable 802.1X authentication globally.

    [HUAWEI] dot1x enable
    

    # Enable 802.1X authentication on an interface.

    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] dot1x enable
    [HUAWEI-GigabitEthernet0/0/1] quit

  5. Configure MAC address authentication.

    # Enable MAC address authentication globally.

    [HUAWEI] mac-authen

    # Enable MAC address authentication on an interface.

    [HUAWEI] interface gigabitethernet 0/0/1
    [HUAWEI-GigabitEthernet0/0/1] mac-authen
    [HUAWEI-GigabitEthernet0/0/1] quit
    [HUAWEI] quit

  6. Verify the configuration.

    1. Run the display dot1x, display mac-authen, and display portal local-server commands. The command output shows that 802.1X authentication, MAC address authentication, and built-in Portal authentication have been enabled on the interface GE0/0/1.
    2. The user can access the network after passing 802.1X authentication, MAC address authentication, or built-in Portal authentication.
    3. After the user goes online, you can run the display access-user interface gigabitethernet0/0/1 command on the device to check all online user information.

Configuration Files

Switch configuration file

#
sysname Switch 
#                                                                               
vlan batch 10 20
#                                                                               
undo authentication unified-mode
#                                                                               
domain isp1
#                                                                               
dot1x enable  
mac-authen
#                                                                                             
portal local-server ip 192.168.1.30                                             
portal local-server https ssl-policy huawei
#
radius-server template rd1
 radius-server shared-key cipher %^%#t67cDelRvAQg;*"4@P/3~q_31Sn{ST\V8'Ci633)%^%#
 radius-server authentication 192.168.2.30 1812 weight 80
#
aaa
 authentication-scheme abc
  authentication-mode radius
 domain isp1
  authentication-scheme abc
  radius-server rd1
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10  
 portal local-server enable 
 dot1x enable                                                               
 mac-authen
#                                                                              
interface GigabitEthernet0/0/2            
 port link-type access                                                          
 port default vlan 20
#                                                                               
interface LoopBack6                                                             
 ip address 192.168.1.30 255.255.255.255 
#                                                                               
ssl policy huawei                                                                    
 certificate load asn1-cert servercert.der key-pair dsa key-file serverkey.der
#
return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100066170

Views: 20844

Downloads: 6

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next