No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Interface Management

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Accessing Different LTE Networks Using Dual SIM Cards

Example for Accessing Different LTE Networks Using Dual SIM Cards

Networking Requirements

As shown in Figure 12-15, the headquarters and branch of an enterprise are located in different places. Router is the egress gateway of the branch and connects to the headquarters through an LTE network (LTE network 1).

To improve data transmission reliability of the LTE link, the branch uses an LTE cellular interface supporting dual SIM cards. One SIM card functions as the master SIM card to connect to LTE network 1, the other SIM card functions as the backup SIM card to connect to LTE network 2. If dial-up fails because the account balance of the master SIM card is insufficient, the master SIM card is faulty, the LTE link signal quality is poor, or the connected LTE network is faulty, traffic is automatically switched to the backup SIM card, ensuring uninterrupted enterprise services.

Figure 12-15  Networking diagram for accessing different LTE networks using dual SIM cards

Configuration Roadmap

The configuration roadmap is as follows:

  • Create two APN profiles. Bind one APN profile to the master SIM card and the other to the backup SIM card.
  • Configure C-DCC for the dial-up connection on the LTE cellular interface.
  • Bind the APN profiles to the LTE cellular interface.
  • Configure the enterprise intranet and use Router to assign IP addresses to the branch intranet users.
  • Configure the NAT function and specify the IP address of the LTE cellular interface as the public IP address of the enterprise branch.
  • Configure a default route and specify the LTE cellular interface as the outbound interface so that traffic from the branch intranet is forwarded to the Internet through the LTE cellular interface.

Procedure

  1. Configure APN profiles.

    # Configure APN profile mainCard and bind it to the master SIM card to connect to LTE network 1. According to the carrier, the APN of LTE network 1 is LTENET1.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] apn profile mainCard
    [Router-apn-profile-mainCard] sim-id 1
    [Router-apn-profile-mainCard] apn LTENET1
    [Router-apn-profile-mainCard] quit

    # Configure APN profile backupCard and bind it to the backup SIM card to connect to LTE network 2. According to the carrier, the APN of LTE network 2 is LTENET2.

    [Router] apn profile backupCard
    [Router-apn-profile-backupCard] sim-id 2
    [Router-apn-profile-backupCard] apn LTENET2
    [Router-apn-profile-backupCard] quit

  2. Configure C-DCC for the dial-up connection on the LTE cellular interface.

    # Configure a dialer control list.

    [Router] dialer-rule
    [Router-dialer-rule] dialer-rule 1 ip permit
    [Router-dialer-rule] quit

    # Configure C-DCC for the dial-up connection on the LTE cellular interface.

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate
    [Router-Cellular0/0/0] mode lte auto
    [Router-Cellular0/0/0] dialer enable-circular
    [Router-Cellular0/0/0] dialer-group 1
    [Router-Cellular0/0/0] dialer timer autodial 20
    [Router-Cellular0/0/0] dialer number *99# autodial

  3. Bind the APN profiles to the LTE cellular interface.

    [Router-Cellular0/0/0] apn-profile mainCard priority 150
    [Router-Cellular0/0/0] apn-profile backupCard priority 120
    [Router-Cellular0/0/0] sim switch rssi-threshold 105
    [Router-Cellular0/0/0] sim switch-back enable timer 1440
    [Router-Cellular0/0/0] shutdown
    [Router-Cellular0/0/0] undo shutdown
    [Router-Cellular0/0/0] quit

  4. Configure the enterprise intranet.

    # Create VLAN 10 and add Ethernet 2/0/0 to VLAN 10.

    [Router] vlan 10
    [Router-vlan10] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type trunk
    [Router-Ethernet2/0/0] port trunk allow-pass vlan 10
    [Router-Ethernet2/0/0] quit

    # Enable DHCP.

    [Router] dhcp enable

    # Create a global address pool.

    [Router] ip pool ltepool
    [Router-ip-pool-ltepool] network 192.168.100.0 mask 255.255.255.0
    [Router-ip-pool-ltepool] gateway-list 192.168.100.1
    [Router-ip-pool-ltepool] quit

    # Configure the interface to work in global address pool mode.

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 192.168.100.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit

  5. Configure the NAT function.

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255
    [Router-acl-adv-3002] quit
    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] nat outbound 3002
    [Router-Cellular0/0/0] quit
    

  6. Configure a default route and specify Cellular0/0/0 as the outbound interface.

    [Router] ip route-static 0.0.0.0 0 cellular 0/0/0

  7. Verify the configuration.

    # After the previous configurations, traffic on the branch intranet is transmitted to LTE network 1 through the master SIM card. If dial-up fails because the account balance of the master SIM card is insufficient, the master SIM card is faulty, the LTE link signal quality is poor, or the connected LTE network is faulty, traffic is automatically switched to the backup SIM card and transmitted to the LTE network 2.

Example

  • Configuration file of Router

    #
     sysname Router
    #                                                                               
    vlan batch 10                       
    #
    dhcp enable  
    #                                                                               
    acl number 3002                                                                
     rule 5 permit ip source 192.168.100.0 0.0.0.255  
    #
    apn profile mainCard
     apn LTENET1 
    apn profile backupCard
     apn LTENET2 
     sim-id 2
    #
    interface Cellular0/0/0
     dialer enable-circular 
     dialer-group 1
     apn-profile mainCard priority 150 
     apn-profile backupCard priority 120 
     dialer timer autodial 20 
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
     sim switch-back enable timer 1440
     sim switch rssi-threshold 105  
    #
    interface Ethernet2/0/0   
     port link-type trunk  
     port trunk allow-pass vlan 10  
    #
    interface Vlanif10
     ip address 192.168.100.1 255.255.255.0   
     dhcp select global   
    #
    ip pool ltepool  
     gateway-list 192.168.100.1  
     network 192.168.100.0 mask 255.255.255.0  
    #
    dialer-rule 
     dialer-rule 1 ip permit
    #
    ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069331

Views: 21214

Downloads: 95

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next