No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Interface Management

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a 3G Cellular Interface as the Primary INerface and Another 3G Cellular Interface as the Backup Interface to Connect to the Internet

Example for Configuring a 3G Cellular Interface as the Primary INerface and Another 3G Cellular Interface as the Backup Interface to Connect to the Internet

Networking Requirements

Because some branches are located in remote areas, it is difficult to deploy fixed networks. As shown in Figure 11-12, to meet service transmission requirements, the branch uses the Router as the egress gateway and uses 3G cellular interfaces to connect to the Internet through the WCDMA network.

The branch requires high network connectivity. A very short network disconnect may affect services of the branch, so a network backup solution is necessary for the branch. Wired links can be used as backup links; however, it takes a long time and costs too much to deploy wired links. As 3G links are easy to deploy and more flexible than wired links, the branch uses 3G links as backup links to connect to the Internet. When the primary link fails, traffic is immediately switched to the backup link, enhancing the reliability of Internet access.

Figure 11-12  Connecting to the Internet through 3G dual uplinks

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the enterprise intranet and configure the Router to assign IP addresses to enterprise intranet users.
  2. Configure Cellular0/0/0 as the primary interface and configure Cellular0/0/0 to connect to the WCDMA network using C-DCC.
  3. Configure Cellular0/0/1 as the backup interface and configure Cellular0/0/1 to connect to the CDMA2000 network using C-DCC.
  4. Configure a default route for the primary interface and backup interface respectively so that traffic from the enterprise intranet is forwarded to the Internet through Cellular0/0/0 and Cellular0/0/1.

Procedure

  1. Configure the enterprise intranet.

    # Create VLAN 10 and add Ethernet2/0/0 to VLAN 10.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan 10
    [Router-vlan10] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type trunk
    [Router-Ethernet2/0/0] port trunk allow-pass vlan 10
    [Router-Ethernet2/0/0] quit

    # Enable DHCP.

    [Router] dhcp enable

    # Create a global address pool.

    [Router] ip pool 3gpool
    [Router-ip-pool-3gpool] network 10.10.10.0 mask 255.255.255.0
    [Router-ip-pool-3gpool] gateway-list 10.10.10.254
    [Router-ip-pool-3gpool] quit

    # Configure the interface to use the global address pool to allocate IP addresses to users.

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 10.10.10.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit

    # Configure an ACL to define the data flows that are allowed to pass through.

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 10.10.10.0 0.0.0.255
    [Router-acl-adv-3002] quit

  2. Configure Cellular0/0/0 as the primary interface to connect to the WCDMA network.

    # Create an APN profile.

    [Router] apn profile 3gprofile1
    [Router-apn-profile-3gprofile1] apn 3GNET
    [Router-apn-profile-3gprofile1] user name 3guser1 password cipher Password@123 authentication-mode auto
    [Router-apn-profile-3gprofile1] quit

    # Obtain an IP address dynamically

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate

    # Configure a DNS server address through PPP negotiation.

    [Router-Cellular0/0/0] ppp ipcp dns request

    # Enable C-DCC.

    [Router-Cellular0/0/0] dialer enable-circular

    # Configure a dialer number.

    [Router-Cellular0/0/0] dialer number *99# autodial

    # Configure a network connection mode.

    [Router-Cellular0/0/0] mode wcdma wcdma-precedence

    # Configure a backup interface for Cellular0/0/1.

    [Router-Cellular0/0/0] standby interface cellular 0/0/1

    # Configure NAT.

    [Router-Cellular0/0/0] nat outbound 3002

    # Bind the APN profile to the 3G cellular interface.

    [Router-Cellular0/0/0] apn-profile 3gprofile1
    [Router-Cellular0/0/0] shutdown
    [Router-Cellular0/0/0] undo shutdown
    [Router-Cellular0/0/0] quit

  3. Configure Cellular0/1/0 as the backup interface to connect to the CDMA2000 network.

    # Create an APN profile.

    [Router] apn profile 3gprofile2
    [Router-apn-profile-3gprofile2] user name 3guser2 password cipher Password@123 authentication-mode auto
    [Router-apn-profile-3gprofile2] quit

    # Configure an IP address through PPP negotiation.

    [Router] interface cellular 0/0/1
    [Router-Cellular0/0/1] ip address negotiate

    # Configure a DNS server address through PPP negotiation.

    [Router-Cellular0/0/1] ppp ipcp dns request

    # Enable C-DCC.

    [Router-Cellular0/0/1] dialer enable-circular

    # Configure a dialer number.

    [Router-Cellular0/0/1] dialer number #777 autodial

    # Configure a network connection mode.

    [Router-Cellular0/0/1] mode cdma hybrid

    # Configure NAT.

    [Router-Cellular0/0/1] nat outbound 3002

    # Bind the APN profile to the 3G cellular interface.

    [Router-Cellular0/0/0] apn-profile 3gprofile2
    [Router-Cellular0/0/0] shutdown
    [Router-Cellular0/0/0] undo shutdown
    [Router-Cellular0/0/0] quit

  4. Configure a default route.

    [Router] ip route-static 0.0.0.0 0.0.0.0 cellular 0/0/0 preference 40
    [Router] ip route-static 0.0.0.0 0.0.0.0 cellular 0/0/1 preference 80
    

  5. Verify the configuration.

    # After the configuration is completed, run the display standby state command on the Router to check the status of the primary and backup interfaces. The command output shows that Cellular0/0/0 is in UP state and Cellular0/0/1 is in STANDBY state.

    [Router] display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
    Cellular0/0/0                          UP         MUP       MU            
    Cellular0/0/1                     STANDBY     STANDBY      BU     0   
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
                                                                                    

    # Run the shutdown command on Cellular0/0/0 to simulate a link fault. Run the display standby state command on the Router to check the status of the primary and backup interfaces. The command output shows that Cellular0/0/0 is in DOWN state and Cellular0/0/1 is in UP state, indicating that the backup interface has been used.

    [Router] display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
    Cellular0/0/0                        DOWN      MDOWN          MU        
    Cellular0/0/1                          UP         UP          BU  0     
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
                                                                                    

Example

  • Configuration file of the Router

    #
     sysname Router
    #
    vlan batch 10
    #
     dhcp enable
    #
    acl number 3002
     rule 5 permit ip source 10.10.10.0 0.0.0.255  
    #
    ip pool 3gpool
     gateway-list 10.10.10.254
     network 10.10.10.0 mask 255.255.255.0 
    #
    interface Vlanif10
     ip address 10.10.10.1 255.255.255.0
     dhcp select global   
    #
    interface Ethernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 10  
    #
    interface Cellular0/0/0
     link-protocol ppp
     ppp ipcp dns request
     dialer enable-circular
     apn-profile 3gprofile1
     dialer timer autodial 10  
     dialer number *99# autodial
     standby interface Cellular0/0/1 
     nat outbound 3002
     ip address negotiate
    #
    interface Cellular0/0/1 
     link-protocol ppp
     ppp ipcp dns request
     dialer enable-circular
     apn-profile 3gprofile2
     dialer timer autodial 10  
     dialer number #777 autodial 
     nat outbound 3002
     ip address negotiate
    #
    apn profile 3gprofile1
     user name 3guser1 password cipher %@%@}7g|@uc0bBQM%]VMM28)3U".%@%@ authentication-mode auto
     apn 3GNET    
    apn profile 3gprofile2
     user name 3guser2 password cipher %@%@}6w|@uc0bBQM%]VMM28)3B".%@%@ authentication-mode auto
    #
    ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0 preference 40
    ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/1 preference 80
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069331

Views: 22994

Downloads: 131

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next