No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Interface Management

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an LTE Cellular Interface as the Backup Interface to Connect to the Internet

Example for Configuring an LTE Cellular Interface as the Backup Interface to Connect to the Internet

Networking Requirements

As shown in Figure 12-12, Router is the egress gateway of the enterprise, and the VDSL interface functions as the primary interface to connect to the Internet.

To ensure reliable access, the enterprise requires that the LTE cellular interface should function as a backup interface to connect enterprise users to the Internet when the primary interface is faulty.

NOTE:
The following figure shows only the access-side networking. Deploy devices on the aggregation and core networks according to site requirements.
Figure 12-12  Networking diagram of configuring an LTE cellular links as the backup interface to connect to the Internet

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure the enterprise intranet and configure the Router as the enterprise's egress gateway to assign IP addresses to enterprise intranet users.
  2. Configure the VDSL interface as the uplink primary interface.
  3. Configure the LTE cellular interface as the uplink backup interface.
  4. Configure a default route so that traffic from the enterprise intranet is transmitted to the Internet through the VDSL or LTE cellular interface.

Procedure

  1. Configure the enterprise intranet.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan 10
    [Router-vlan10] quit
    [Router] dhcp enable
    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 192.168.100.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit
    [Router] ip pool lan
    [Router-ip-pool-lan] gateway-list 192.168.100.1
    [Router-ip-pool-lan] network 192.168.100.0 mask 24
    [Router-ip-pool-lan] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type hybrid
    [Router-Ethernet2/0/0] port hybrid pvid vlan 10
    [Router-Ethernet2/0/0] port hybrid untagged vlan 10
    [Router-Ethernet2/0/0] quit

  2. Configure the VDSL interface as the uplink primary interface.

    NOTE:

    This example only describes the configuration of the uplink primary interface. For details about other uplink devices, see the related manuals.

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255
    [Router-acl-adv-3002] quit
    [Router] interface virtual-template 10
    [Router-Virtual-Template10] ip address ppp-negotiate
    [Router-Virtual-Template10] nat outbound 3002
    [Router-Virtual-Template10] quit
    [Router] interface atm 1/0/0
    [Router-Atm1/0/0] pvc voip 1/35
    [Router-atm-pvc-Atm1/0/0-1/35-voip] map ppp virtual-template 10
    [Router-atm-pvc-Atm1/0/0-1/35-voip] quit
    [Router-Atm1/0/0] standby interface cellular 0/0/0
    [Router-Atm1/0/0] quit
    

  3. Configure the LTE cellular interface as the uplink backup interface.

    # In this example, set the dialer number to *99#.

    # Use the APN specified by the carrier. In this example, set the APN to ltenet.

    NOTE:

    Before configuring the backup interface, ensure that the LTE data cards and SIM cards are available.

    This example only describes the configuration of the uplink backup interface. For details about other uplink devices, see the related manuals.

    [Router] dialer-rule
    [Router-dialer-rule] dialer-rule 1 ip permit
    [Router-dialer-rule] quit
    [Router] apn profile ltenet
    [Router-apn-profile-ltenet] quit
    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate
    [Router-Cellular0/0/0] dialer enable-circular
    [Router-Cellular0/0/0] dialer-group 1
    [Router-Cellular0/0/0] dialer timer idle 50
    [Router-Cellular0/0/0] dialer number *99# autodial
    [Router-Cellular0/0/0] nat outbound 3002
    [Router-Cellular0/0/0] mode lte auto
    [Router-Cellular0/0/0] apn-profile ltenet
    [Router-Cellular0/0/0] shutdown
    [Router-Cellular0/0/0] undo shutdown
    [Router-Cellular0/0/0] quit

  4. Configuring a default route.

    [Router] ip route-static 0.0.0.0 0.0.0.0 virtual-template 10 preference 40
    [Router] ip route-static 0.0.0.0 0.0.0.0 cellular 0/0/0 preference 80

  5. Verify the configuration.

    # After the configuration is complete, run the display standby state command on the Router to check the status of the primary and backup interfaces. The command output shows that ATM1/0/0 is in Up state and Cellular0/0/0 is in Standby state.

    [Router] display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
    ATM1/0/0                               UP         MUP       MU            
    Cellular0/0/0                     STANDBY     STANDBY      BU     0   
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
                                                                                    

    # Run the shutdown command on ATM1/0/0 to simulate a link fault. Run the display standby state command on the Router to check the status of the primary and backup interfaces. The command output shows that ATM1/0/0 is in Down state and Cellular0/0/0 is in Up state, indicating that the backup interface has started.

    [Router-Atm1/0/0] shutdown
    [Router-Atm1/0/0] quit    
    [RouterA] display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
    ATM1/0/0                             DOWN      MDOWN          MU        
    Cellular0/0/0                          UP         UP          BU  0     
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
                                                                                    

Configuration Files

  • Configuration file of the Router

    #
     sysname Router
    #                                                                               
    vlan batch 10                       
    #                                                                               
    dhcp enable  
    #                                                                               
    acl number 3002   
     rule 5 permit ip source 192.168.100.0 0.0.0.255 
    #
    apn profile ltenet
    #                                                                               
    ip pool lan                                                                 
     gateway-list 192.168.100.1   
     network 192.168.100.0 mask 255.255.255.0 
    #                                                                               
    interface Vlanif10 
     ip address 192.168.100.1 255.255.255.0 
     dhcp select global  
    #                                                                               
    interface Ethernet2/0/0                              
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10 
    #                                                                               
    interface Cellular0/0/0 
     dialer enable-circular 
     dialer-group 1 
     apn-profile ltenet 
     dialer timer idle 50  
     dialer number *99# autodial
     nat outbound 3002
     ip address negotiate 
    #                                                                               
    interface Atm1/0/0  
     pvc voip 1/35 
      map ppp Virtual-Template10 
     standby interface Cellular0/0/0 
    #                                                                               
    interface Virtual-Template10           
     ip address ppp-negotiate 
     nat outbound 3002 
    #                                                                               
    dialer-rule 
     dialer-rule 1 ip permit 
    #                                                                               
     ip route-static 0.0.0.0 0.0.0.0 Virtual-template10 preference 40          
     ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0 preference 80                    
    #                                                                               
    return   
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069331

Views: 21338

Downloads: 97

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next