No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Interface Management

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an LTE Cellular Interface as the Primary Interface to Connect to the Internet

Example for Configuring an LTE Cellular Interface as the Primary Interface to Connect to the Internet

Networking Requirements

A remote branch of the enterprise needs to exchange large volumes of service traffic with external networks, but it cannot obtain the wired WAN access service. As shown in Figure 12-11, the branch uses the Router as the egress gateway and uses an LTE cellular interface to connect to the Internet through the LTE network, meeting service transmission requirements.

The branch intranet is on the network segment 192.168.100.0/24 and all hosts join VLAN 10. The branch requires that the Router should assign IP addresses to branch intranet users and the users access external networks.

The branch has subscribed to a yearly-package service and connects to the Internet in dial-automatic mode. The branch obtains the following information from the carrier:

  • APN: ltenet
  • Dialer number: *99#
Figure 12-11  Networking diagram of configuring an LTE cellular interface as the primary interface to connect to the Internet

Configuration Roadmap

The configuration roadmap is as follows:

  1. Set the connection parameters of the LTE cellular interface.
  2. Configure C-DCC for dial-up connection so that the LTE cellular interface can connect to the LTE network.
  3. Configure the enterprise intranet and configure the Router to assign IP addresses to branch intranet users.
  4. Configure the NAT function to allow branch intranet users to access external networks.
  5. Configure a default route and specify the LTE cellular interface as the outbound interface so that traffic from the branch intranet is forwarded to the Internet through the LTE cellular interface.
NOTE:

Run dialer enable-circular, the dialer number and IP address assigns automatically, a dialer control list not required.

Procedure

  1. Set the connection parameters of the LTE cellular interface.

    # Create an APN profile.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] apn profile lteprofile
    [Router-apn-profile-lteprofile] apn ltenet
    [Router-apn-profile-lteprofile] quit

    # Configure a network connection mode.

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] mode lte auto

    # Bind the APN profile to the LTE cellular interface.

    [Router-Cellular0/0/0] dialer enable-circular
    [Router-Cellular0/0/0] apn-profile ltenet
    [Router-Cellular0/0/0] shutdown
    [Router-Cellular0/0/0] undo shutdown
    [Router-Cellular0/0/0] quit

  2. Configure C-DCC for dial-up connection.

    # Configure a dialer control list.

    [Router] dialer-rule
    [Router-dialer-rule] dialer-rule 1 ip permit
    [Router-dialer-rule] quit

    # Obtain IP addresses dynamically.

    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] ip address negotiate

    # Associate Cellular0/0/0 to the dialer control list.

    [Router-Cellular0/0/0] dialer-group 1
    NOTE:

    Ensure that the group-number value in the dialer-group command is the same as the dialer-rule-number value in the dialer-rule command.

    # Configure the dialer number.

    [Router-Cellular0/0/0] dialer number *99# autodial
    [Router-Cellular0/0/0] quit

  3. Configure the enterprise intranet.

    # Create VLAN 10 and add Ethernet 2/0/0 to VLAN 10.

    [Router] vlan 10
    [Router-vlan10] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type trunk
    [Router-Ethernet2/0/0] port trunk allow-pass vlan 10
    [Router-Ethernet2/0/0] quit

    # Enable DHCP.

    [Router] dhcp enable

    # Create a global address pool.

    [Router] ip pool 4gpool
    [Router-ip-pool-4gpool] network 192.168.100.0 mask 255.255.255.0
    [Router-ip-pool-4gpool] gateway-list 192.168.100.1
    [Router-ip-pool-4gpool] quit

    # Configure the interface to work in global address pool mode.

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 192.168.100.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit

  4. Configure the NAT function.

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255
    [Router-acl-adv-3002] quit
    [Router] interface cellular 0/0/0
    [Router-Cellular0/0/0] nat outbound 3002
    [Router-Cellular0/0/0] quit

  5. Configure a default route and specify Cellular0/0/0 as the outbound interface.

    [Router] ip route-static 0.0.0.0 0 cellular 0/0/0

  6. Verify the configuration.

    # View the interface status and traffic statistics. The command output shows that if traffic is forwarded through the interface, both the physical layer status and link layer status of the interface are Up and the IP address dynamically obtained by the interface is 20.1.1.2/24.

    [Router] display interface cellular 0/0/0
    Cellular0/0/0 current state : UP                                                
    Line protocol current state : UP                                     
    Description:HUAWEI, AR Series, Cellular0/0/0 Interface                          
    Route Port,The Maximum Transmit Unit is 1500, Hold timer is 10(sec)                                      
    Internet Address is 20.1.1.2/24                                                   
    Current system time: 2011-06-08 11:35:23                                        
    Modem State: Present                                                        
    Last 300 seconds input rate 555 bytes/sec 4440 bits/sec 12 packets/sec 
    Last 300 seconds output rate 11230 bytes/sec 89840 bits/sec 311 packets/sec 
        Input: 210 packets, 87205 bytes
          Unicast:                  200,       Ununicast:                  10
        Output:225340 packets, 6760917 bytes
          Unicast:                  225300,    Ununicast:                  40
        Input bandwidth utilization  : 0.01%
        Output bandwidth utilization : 0.01%
    

    # View information about all call sessions on the LTE data card. The following command output shows that the APN is ltenet, the network type is Automatic, and the network connection mode is LTE(LTE).

    <Huawei> display cellular 0/0/0 all
    Modem State:                                                                    
    Hardware Information.                                                           
    =====================                                                           
    Model = E392                                                                    
    Modem Firmware Version =  11.833.15.00.000                                      
    Hardware Version = CD2E392UM                                                  
    Integrate circuit card identity (ICCID) = 98681011274300909893                
    International Mobile Subscriber Identity (IMSI) = 460016002731442               
    International Mobile Equipment Identity (IMEI) = 861230010006485                
    Factory Serial Number (FSN) = T2Y01A9211900298                                  
    Modem Status = Online                                                           
    Profile Information.                                                            
    ====================                                                            
    Profile 1 = ACTIVE                                                              
    --------                                                                        
    PDP Type = IPv4, Header Compression = OFF                                       
    Data Compression = OFF                                                          
    Access Point Name (APN) = ltenet                                                
    Packet Session Status = Active                                                
    * - Default profile                                                             
    Network Information.                                                            
    ====================                                                            
    Current Service Status = Service available                                      
    Current Service = Combined                                                      
    Packet Service = Attached                                                       
    Packet Session Status = Active                                                
    Current Roaming Status = Home                                                   
    Network Selection Mode = Automatic                                              
    Network Connection Mode = Automatic                                             
    Current Network Connection = LTE(LTE)                                       
    Mobile Country Code (MCC) = 460                                                 
    Mobile Network Code (MNC) = 01                                                  
    Mobile Operator Information = "CHN-CULTE"                                       
    Cell ID = 55924                                                                 
    Upstream Bandwidth = 50mbps                                                    
    Downstream Bandwidth = 100mbps                                                  
    Radio Information.                                                              
    ==================                                                              
    Current Band = AUTO                                                             
    Current RSSI = -55 dBm                                                          
    Modem Security Information.                                                     
    ===========================                                                     
    PIN Verification = Disabled                                                     
    PIN Status = Ready                                                              
    Number of Retries remaining = 3                                                 
    SIM Status = OK             
    

Example

  • Configuration file of the Router

    #
     sysname Router
    #                                                                               
    vlan batch 10  
    #
    dhcp enable  
    #                                                                               
    acl number 3002                                                                
     rule 5 permit ip source 192.168.100.0 0.0.0.255  
    #
    ip pool 4gpool  
     gateway-list 192.168.100.1  
     network 192.168.100.0 mask 255.255.255.0  
    #
    interface Vlanif10
     ip address 192.168.100.1 255.255.255.0   
     dhcp select global   
    #
    interface Ethernet2/0/0   
     port link-type trunk  
     port trunk allow-pass vlan 10  
    #
    interface Cellular0/0/0
     dialer enable-circular
     dialer-group 1
     apn-profile lteprofile
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
    #
    dialer-rule
     dialer-rule 1 ip permit
    #
    apn profile lteprofile      
     apn ltenet      
    #
    ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069331

Views: 21014

Downloads: 93

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next