No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Interface Management

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Network Interworking by Using Synchronous Serial Interfaces

Example for Configuring Network Interworking by Using Synchronous Serial Interfaces

Networking Requirements

As shown in Figure 3-2, RouterA and RouterB are connected using serial interfaces. The interface on RouterA connecting to RouterB is a DTE interface, and the interface on RouterB connecting to RouterA is a DCE interface. Users want the two devices to communicate with each other.

Figure 3-2  Networking diagram for configuring network interworking by using synchronous serial interfaces

Configuration Roadmap

The configuration roadmap is as follows:

# Set physical attributes for synchronous serial interfaces to ensure that the interfaces are physically Up.

# Set link layer attributes for synchronous serial interfaces to ensure that the link protocol status of the interfaces is Up.

# Configure IP address for synchronous serial interfaces to enable the IP networks to communicate.

Procedure

  1. Set physical attributes for synchronous serial interfaces.

    # Configure RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface serial 1/0/0
    [RouterA-Serial1/0/0] virtualbaudrate 72000

    # Configure RouterB.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] interface serial 1/0/0
    [RouterB-Serial1/0/0] baudrate 72000

  2. Set link layer attributes for synchronous serial interfaces.

    # Configure RouterA.

    [RouterA-Serial1/0/0] link-protocol ppp
    [RouterA-Serial1/0/0] mtu 1400
    [RouterA-Serial1/0/0] shutdown
    [RouterA-Serial1/0/0] undo shutdown

    # Configure RouterB.

    [RouterB-Serial1/0/0] link-protocol ppp
    [RouterB-Serial1/0/0] mtu 1400
    [RouterB-Serial1/0/0] shutdown
    [RouterB-Serial1/0/0] undo shutdown

  3. Configure IP addresses for synchronous serial interfaces.

    # Configure RouterA.

    [RouterA-Serial1/0/0] ip address 10.1.1.1 30
    [RouterA-Serial1/0/0] quit

    # Configure RouterB.

    [RouterB-Serial1/0/0] ip address 10.1.1.2 30
    [RouterB-Serial1/0/0] quit

  4. Verify the configuration.

    # View the status of and traffic statistics on the synchronous serial interfaces. Use the command output of RouterA as an example. You can view that the physical status and the link layer protocol status of the serial interface are Up.

    [RouterA] display interface Serial 1/0/0
    Serial1/0/0 current state : UP
    Line protocol current state : UP
    Last line protocol up time : 2012-07-18 11:12:29
    Description:HUAWEI, AR Series, Serial1/0/0 Interface
    Route Port,The Maximum Transmit Unit is 1400, Hold timer is 10(sec)
    Internet Address is 10.1.1.1/30
    Link layer protocol is PPP
    LCP opened, IPCP opened  
    Last physical up time   : 2008-01-09 12:25:52
    Last physical down time : 2008-01-09 12:25:51
    Current system time: 2008-01-09 19:18:44
    Physical layer is synchronous, Virtualbaudrate is 72000 bps
    Interface is DTE, Cable type is V35, Clock mode is DTECLK1
    Last 300 seconds input rate 0 bytes/sec 0 bits/sec 0 packets/sec
    Last 300 seconds output rate 0 bytes/sec 0 bits/sec 0 packets/sec
    
    Input: 47266 packets, 662564 bytes                                              
      Broadcast:              0,  Multicast:              0                         
      Errors:                 0,  Runts:                  0                         
      Giants:                 0,  CRC:                    0                         
                                                                                    
      Alignments:             0,  Overruns:               0                         
      Dribbles:               0,  Aborts:                 0                         
      No Buffers:             0,  Frame Error:            0                         
                                                                                    
    Output: 47267 packets, 662592 bytes                                             
      Total Error:            0,  Overruns:               0                         
      Collisions:             0,  Deferred:        
    
    DCD=UP DTR=UP DSR=UP RTS=UP CTS=UP
        Input bandwidth utilization  : 0.09%
        Output bandwidth utilization : 0.09%

    # Check the routing table of the serial interface. Use the command output of RouterA as an example. You can view information about the routes destined for the peer end.

    [RouterA] display ip routing-table
    Route Flags: R - relay, D - download to fib, T -
    to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5        Routes : 5
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
         10.1.1.0/30  Direct 0   0         D  10.1.1.1      Serial1/0/0
           10.1.1.1/32  Direct 0    0           D  127.16.0.1       Serial1/0/0
           10.1.1.2/32  Direct 0    0           D  10.1.1.2        Serial1/0/0
           10.1.1.3/32  Direct 0    0           D  127.16.0.1       Serial1/0/0
          127.16.0.0/8   Direct 0    0           D  127.16.0.1       InLoopBack0
          127.16.0.1/32  Direct 0    0           D  127.16.0.1       InLoopBack0

    # RouterA and RouterB can ping each other successfully. Use the command output of RouterA as an example. Ping RouterB from RouterA, and you can view the following command output:

    [RouterA] ping 10.1.1.2
      PING 10.1.1.2: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=90 ms
        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=50 ms
        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=50 ms
        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=40 ms
        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=30 ms
     --- 10.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 30/52/90 ms

Configuration Files

  • Configuration file of RouterA

    #
     sysname RouterA
    #
    interface Serial1/0/0
     link-protocol ppp
     mtu 1400
     ip address 10.1.1.1 255.255.255.252
     virtualbaudrate 72000
    #
    return
  • Configuration file of RouterB

    #
     sysname RouterB
    #
    interface Serial1/0/0
     link-protocol ppp
     mtu 1400
     ip address 10.1.1.2 255.255.255.252
     baudrate 72000
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069331

Views: 21366

Downloads: 97

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next