No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Interface Management

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuring LTE Cellular Interfaces to Use the Two LTE channel for Data and VoIP Communication

Configuring LTE Cellular Interfaces to Use the Two LTE channel for Data and VoIP Communication

Networking Requirements

A remote branch of the enterprise cannot obtain wired WAN access service, and needs to exchange heavy traffic with the headquarters. The branch wants to communicate with the headquarters through the Internet. In addition, the branch also wants to exchange voice services with the headquarters at a low cost, so VoIP communication needs to be used.

The branch intranet is on the network segment 192.168.100.0/24 and all hosts join VLAN 10. The branch requires that the Router should assign IP addresses to branch intranet users and the users access external networks.

A remote branch of the enterprise cannot obtain the wired WAN access service to provide data and VoIP communication. As shown in Figure 12-14, the branch uses the Router as the egress gateway and uses an LTE cellular interface to connect to the PGW through the LTE network, meeting service transmission requirements. The PGW connects to the Internet through the Internet gateway and connects to the IMS network through the IMS gateway.

Figure 12-14  Networking diagram of configuring LTE cellular interfaces to use the multi-APN function for data and VoIP communication

Configuration Roadmap

The enterprise can use the multi-APN function of LTE cellular interfaces to implement data and VoIP communication. Two LTE channel interfaces can be configured for an LTE cellular interface. You can bind two different APN profiles respectively to the two LTE channel interfaces. One APN connects to the Internet for data communication, and the other connects to the IMS network for VoIP communication. The PGW assigns an IP address to each LTE channel interface of the LTE cellular interface.

The configuration roadmap is as follows:

  • Create two APN profiles. One profile is named the APN connecting to the Internet, and the other is named the APN connecting to the IMS network.
  • Configure an LTE cellular interface, configure a network connection mode for the interface, and enable the multi-APN function.
  • Configure C-DCC for dial-up connection on the LTE cellular interface.
  • Bind the APN profiles to the LTE cellular interface.
  • Configure the enterprise intranet and configure the Router to assign IP addresses to branch intranet users.
  • Configure the NAT function and set the IP address of the LTE channel interface as the public IP address of the enterprise branch.
  • Configure a default route and specify the LTE channel interface as the outbound interface so that traffic from the branch intranet can be forwarded to the LTE network through the LTE channel interface.

Procedure

  1. Configure APN profiles.

    # Configure an APN profile named datanet to connect to the Internet.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] apn profile datanet
    [Router-apn-profile-datanet] user name lte-example password cipher 123456 authentication-mode chap
    [Router-apn-profile-datanet] apn data
    [Router-apn-profile-datanet] quit

    # Configure an APN profile named voicenet to connect to the IMS network.

    [Router] apn profile voicenet
    [Router-apn-profile-voicenet] apn voice
    [Router-apn-profile-voicenet] quit

  2. Configure an LTE cellular interface.

    # Configure a network connection mode.

    [Router] interface cellular 1/0/0
    [Router-Cellular1/0/0] mode lte auto

    # Enable the multi-APN function on the LTE cellular interface.

    [Router-Cellular1/0/0] multi-apn enable
    [Router-Cellular1/0/0] quit

  3. Configure C-DCC for dial-up connection on the LTE cellular interface.

    # Configure a dialer control list.

    [Router] dialer-rule
    [Router-dialer-rule] dialer-rule 1 ip permit
    [Router-dialer-rule] quit

    # Configure C-DCC for dial-up connection on LTE channel interface 1 and bind the APN profile datanet to LTE channel interface 1.

    [Router] interface cellular 1/0/0:1
    [Router-Cellular1/0/0:1] ip address negotiate
    [Router-Cellular1/0/0:1] dialer enable-circular
    [Router-Cellular1/0/0:1] dialer-group 1
    [Router-Cellular1/0/0:1] dialer timer autodial 20
    [Router-Cellular1/0/0:1] dialer number *99# autodial
    [Router-Cellular1/0/0:1] apn-profile datanet
    [Router-Cellular1/0/0:1] shutdown
    [Router-Cellular1/0/0:1] undo shutdown
    [Router-Cellular1/0/0:1] quit

    # Configure C-DCC for dial-up connection on LTE channel interface 2 and bind the APN profile voicenet to LTE channel interface 2.

    [Router] interface cellular 1/0/0:2
    [Router-Cellular1/0/0:2] ip address negotiate
    [Router-Cellular1/0/0:2] dialer enable-circular
    [Router-Cellular1/0/0:2] dialer-group 1
    [Router-Cellular1/0/0:2] dialer timer autodial 20
    [Router-Cellular1/0/0:2] dialer number *99# autodial
    [Router-Cellular1/0/0:2] apn-profile voicenet
    [Router-Cellular1/0/0:2] shutdown
    [Router-Cellular1/0/0:2] undo shutdown
    [Router-Cellular1/0/0:2] quit

  4. Configure the enterprise intranet.

    # Create VLAN 10 and add Ethernet 2/0/0 to VLAN 10.

    [Router] vlan 10
    [Router-vlan10] quit
    [Router] interface ethernet 2/0/0
    [Router-Ethernet2/0/0] port link-type trunk
    [Router-Ethernet2/0/0] port trunk allow-pass vlan 10
    [Router-Ethernet2/0/0] quit

    # Enable DHCP.

    [Router] dhcp enable

    # Create a global address pool.

    [Router] ip pool 4gpool
    [Router-ip-pool-4gpool] network 192.168.100.0 mask 255.255.255.0
    [Router-ip-pool-4gpool] gateway-list 192.168.100.1
    [Router-ip-pool-4gpool] quit

    # Configure the interface to work in global address pool mode.

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 192.168.100.1 255.255.255.0
    [Router-Vlanif10] dhcp select global
    [Router-Vlanif10] quit

  5. Configure the NAT function.

    [Router] acl number 3002
    [Router-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255
    [Router-acl-adv-3002] quit
    [Router] interface cellular 1/0/0:1
    [Router-Cellular1/0/0:1] nat outbound 3002
    [Router-Cellular1/0/0:1] quit
    [Router] interface cellular 1/0/0:2
    [Router-Cellular1/0/0:2] nat outbound 3002
    [Router-Cellular1/0/0:2] quit

  6. Configure a default route and specify the LTE channel interfaces as the outbound interfaces.

    [Router] ip route-static 1.1.1.0 255.255.255.0 cellular 0/0/0:1
    [Router] ip route-static 2.2.2.0 255.255.255.0 cellular 0/0/0:2

  7. Verify the configuration.

    # After the configuration is complete, traffic of the branch intranet is transmitted to the LTE network through the LTE cellular interface and the branch users can exchange both data and VoIP services through the LTE cellular interface.

Example

  • Configuration file of the Router

    #
     sysname Router
    #                                                                               
    vlan batch 10                       
    #
    dhcp enable  
    #                                                                               
    acl number 3002                                                                
     rule 5 permit ip source 192.168.100.0 0.0.0.255  
    #
    apn profile datanet   
     apn data  
     user name lte-example password cipher %^%#Xhc5=7"mU5o)7]/JST4$8\0CD`~a{O0Z~p+YWvY~%^%# authentication-mode chap
    apn profile voicenet  
     apn voice
    #
    interface Cellular1/0/0
     mode lte auto
     multi-apn enable
    #
    interface Cellular1/0/0:1
     dialer enable-circular 
     dialer-group 1
     apn-profile datanet 
     dialer timer autodial 20 
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
    #
    interface Cellular1/0/0:2
     dialer enable-circular 
     dialer-group 1 
     apn-profile voicenet 
     dialer timer autodial 20
     dialer number *99# autodial
     nat outbound 3002  
     ip address negotiate
    #
    interface Ethernet2/0/0   
     port link-type trunk  
     port trunk allow-pass vlan 10  
    #
    interface Vlanif10
     ip address 192.168.100.1 255.255.255.0   
     dhcp select global   
    #
    ip pool 4gpool  
     gateway-list 192.168.100.1  
     network 192.168.100.0 mask 255.255.255.0  
    #
    dialer-rule 
     dialer-rule 1 ip permit
    #
    ip route-static 1.1.1.0 255.255.255.0 Cellular1/0/0:1
    ip route-static 2.2.2.0 255.255.255.0 Cellular1/0/0:2
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069331

Views: 22887

Downloads: 129

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next