No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast Static Routes to Connect RPF Routes

Example for Configuring Multicast Static Routes to Connect RPF Routes

Networking Requirements

In Figure 7-15, RouterB and RouterC run Open Shortest Path First (OSPF) to implement IP interworking, but they have no unicast route to RouterA. Router interfaces must run Protocol Independent Multicast Dense Mode (PIM-DM) to provide multicast services. The receiver host (Receiver) can receive data from Source1 and also needs to receive data from Source2.

Figure 7-15  Configuring multicast static routes to connect RPF routes

Configuration Roadmap

A reverse path forwarding (RPF) route to Source2 can be established on the path RouterC -> RouterB -> RouterA by configuring multicast static routes on RouterB and RouterC. The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces of the routers. Configure OSPF on RouterB and RouterC but not on RouterA, so that RouterB and RouterC have no unicast route to RouterA.

  2. Enable multicast routing on all routers, PIM-DM on all interfaces, and IGMP on the interface connected to the network segment of the receiver host. After these basic multicast functions are configured, the routers can establish a multicast distribution tree using default parameter settings. Multicast data can then be forwarded to Receiver along the multicast distribution tree.

  3. Configure multicast static routes to Source2 on RouterB and RouterC.

Procedure

  1. Configure IP addresses for interfaces and configure OSPF on each router. RouterB is used as an example in the following operations. Configurations of the other routers are similar.

    # Configure IP addresses and masks for interfaces on the routers.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] ip address 10.1.2.2 24
    [RouterB-GigabitEthernet1/0/0] quit
    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] ip address 10.1.3.1 24
    [RouterB-GigabitEthernet2/0/0] quit
    [RouterB] interface gigabitethernet 3/0/0
    [RouterB-GigabitEthernet3/0/0] ip address 10.1.4.1 24
    [RouterB-GigabitEthernet3/0/0] quit
    

    # Configure OSPF on RouterB and RouterC.

    [RouterB] ospf
    [RouterB-ospf-1] area 0
    [RouterB-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] quit
    [RouterB-ospf-1] quit

  2. Enable multicast routing on the routers and enable PIM-DM on all interfaces.

    # Enable multicast routing on all routers, PIM-DM on all interfaces, and IGMP on the interface connected to the network segment of the receiver host.

    # Configure RouterA.

    [RouterA] multicast routing-enable
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] pim dm
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 3/0/0
    [RouterA-GigabitEthernet3/0/0] pim dm
    [RouterA-GigabitEthernet3/0/0] quit
    

    # Configure RouterB.

    [RouterB] multicast routing-enable
    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] pim dm
    [RouterB-GigabitEthernet1/0/0] quit
    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] pim dm
    [RouterB-GigabitEthernet2/0/0] quit
    [RouterB] interface gigabitethernet 3/0/0
    [RouterB-GigabitEthernet3/0/0] pim dm
    [RouterB-GigabitEthernet3/0/0] quit

    # Configure RouterC.

    [RouterC] multicast routing-enable
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] pim dm
    [RouterC-GigabitEthernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-GigabitEthernet2/0/0] pim dm
    [RouterC-GigabitEthernet2/0/0] igmp enable
    [RouterC-GigabitEthernet2/0/0] quit

    # Source1 (10.1.3.2/24) and Source2 (10.1.5.2/24) send multicast data to group G (225.1.1.1). After Receiver joins group G, it receives the multicast data sent by Source1 but cannot receive the multicast data sent by Source2.

    # Run the display multicast rpf-info 10.1.5.2 command on RouterB and RouterC. No information is displayed, indicating that the routers have no RPF route to Source2.

  3. Configure multicast static routes.

    # Configure a multicast RPF static route to Source2 on RouterB, and configure RouterA as the RPF neighbor.

    [RouterB] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.4.2

    # Configure a multicast RPF static route to Source2 on RouterC, and configure RouterB as the RPF neighbor.

    [RouterC] ip rpf-route-static 10.1.5.0 255.255.255.0 10.1.2.2

  4. Verify the configuration.

    # Run the display multicast rpf-info 10.1.5.2 command on RouterB and RouterC to check the RPF route to Source2. The following information is displayed:

    [RouterB] display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source: 10.1.5.2
         RPF interface: GigabitEthernet3/0/0, RPF neighbor: 10.1.4.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selecting rule: preference-preferred
         Load splitting rule: disable 
    [RouterC] display multicast rpf-info 10.1.5.2
    VPN-Instance: public net
    RPF information about source 10.1.5.2:
         RPF interface: GigabitEthernet1/0/0, RPF neighbor: 10.1.2.2
         Referenced route/mask: 10.1.5.0/24
         Referenced route type: mstatic
         Route selection rule: preference-preferred
         Load splitting rule: disable 

    # Run the display pim routing-table command on RouterC to check the PIM routing table. RouterC has multicast entries for Source2, indicating that Receiver can now receive multicast data from Source2.

    [RouterC] display pim routing-table
    VPN-Instance: public net
     Total 1 (*, G) entry; 2 (S, G) entries
     
     (*, 225.1.1.1)
         Protocol: pim-dm, Flag: WC
         UpTime: 03:54:19
         Upstream interface: NULL
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: igmp, UpTime: 01:38:19, Expires: never
     
    (10.1.3.2, 225.1.1.1)     
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: GigabitEthernet2/0/0
                  Protocol: pim-dm, UpTime: 00:00:44, Expires: never  
     
    (10.1.5.2, 225.1.1.1)     
         Protocol: pim-dm, Flag: ACT
         UpTime: 00:00:44
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 10.1.2.2
             RPF prime neighbor: 10.1.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
              1: GigabitEthernet2/0/0
                  Protocol: pim-dm, UpTime: 00:00:44, Expires: never  

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.5.1 255.255.255.0
     pim dm
    #
    interface GigabitEthernet3/0/0
     ip address 10.1.4.2 255.255.255.0
     pim dm
    #
    return 
  • RouterB configuration file

    #
     sysname RouterB
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.2.2 255.255.255.0
     pim dm
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.3.1 255.255.255.0
     pim dm
    #
    interface GigabitEthernet3/0/0
     ip address 10.1.4.1 255.255.255.0
     pim dm
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.4.2
    #
    return
  • Configuration file of RouterC

    #
     sysname RouterC
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.2.1 255.255.255.0
     pim dm
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
     pim dm
     igmp enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    ip rpf-route-static 10.1.5.0 24 10.1.2.2
    #
    return 
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069332

Views: 22225

Downloads: 59

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next