No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring PIM GR

Example for Configuring PIM GR

Networking Requirements

Figure 4-24 shows a network running multicast services. On this PIM-SM network, RouterC has double control units, and both RouterA and RouterB supports GR of unicast protocols.

An active/standby switchover needs to be performed on RouterC. To ensure uninterrupted multicast services for downstream users, the interface cards of RouterC must be able to forward multicast data during the active/standby switchover.

Figure 4-24  Network diagram of PIM GR

Configuration Roadmap

PIM GR can be configured to meet the preceding requirement. The configuration roadmap is as follows:

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on each router.

  2. Enable GR for the unicast routing protocol on each router and set the GR period.

  3. Enable multicast routing on the routers, enable PIM-SM on all the interfaces of the routers, and enable IGMP on the interface of RouterC connected to host.

  4. Configure an RP. Configure the same static RP on the routers.

  5. Enable PIM GR on RouterC and set the GR period.

Procedure

  1. Assign IP addresses to interfaces and configure a unicast routing protocol on each router.

    # Configure an IP address and mask for each interface of the routers according to Figure 4-24. Configure OSPF on RouterA, RouterB, and RouterC to ensure that the routers can communicate at the network layer. The configurations of RouterA and RouterB are similar to the configuration of RouterC, and are not mentioned here.

    <Huawei> system-view
    [Huawei] sysname RouterC
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] ip address 10.110.2.1 24
    [RouterC-GigabitEthernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-GigabitEthernet2/0/0] ip address 192.168.4.2 24
    [RouterC-GigabitEthernet2/0/0] quit
    [RouterC] ospf
    [RouterC-ospf-1] area 0
    [RouterC-ospf-1-area-0.0.0.0] network 10.110.2.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.0] quit
    [RouterC-ospf-1] quit

  2. Enable GR for the unicast routing protocol on each router and set the GR period.

    # Enable GR for the unicast routing protocol on all the routers and set the GR period to 200 seconds. The configurations of RouterA and RouterB are similar to the configuration of RouterC, and are not mentioned here.

    [RouterC] ospf
    [RouterC-ospf-1] opaque-capability enable
    [RouterC-ospf-1] graceful-restart
    [RouterC-ospf-1] graceful-restart period 200
    [RouterC-ospf-1] quit

  3. Enable multicast routing on the routers, enable PIM-SM on all the interfaces, and enable IGMP on the interface of RouterC connected to hosts.

    # Enable multicast routing on all the routers and enable PIM-SM on all interfaces of the routers. The configurations of RouterA and RouterB are similar to the configuration of RouterC, and are not mentioned here.

    [RouterC] multicast routing-enable
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] pim sm
    [RouterC-GigabitEthernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-GigabitEthernet2/0/0] pim sm
    [RouterC-GigabitEthernet2/0/0] quit

    # Enable IGMP on the interface of RouterC connected to the host.

    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] igmp enable
    [RouterC-GigabitEthernet1/0/0] quit
    

  4. Configure a static RP.

    NOTE:

    To ensure high reliability of the RP, it is recommended that you set the static RP address to the IP address of a loopback interface, because a loopback interface is always up.

    # Configure the static RP on all the routers. The configurations of RouterA and RouterB are similar to the configuration of RouterC, and are not mentioned here.

    [RouterC] pim
    [RouterC-pim] static-rp 10.10.1.1
    [RouterC-pim] quit

  5. Enable PIM GR and set the PIM GR period.

    # Enable PIM GR on RouterC and set the PIM GR period to 300 seconds.

    [RouterC] pim
    [RouterC-pim] graceful-restart
    [RouterC-pim] graceful-restart period 300
    [RouterC-pim] quit

  6. Verify the configuration.

    # Multicast source 10.110.1.100 sends data to multicast group 225.1.1.1. HostA sends an IGMP Report message to join the multicast group and can receive multicast data from the multicast source. Before triggering an active/standby switchover on RouterC, run the display pim routing-table command on RouterB and RouterC to view the multicast routing tables. The command output is as follows:

    <RouterB> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.10.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 01:52:38
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 01:52:38, Expires: 00:02:53
    
     (10.110.1.100, 225.1.1.1)
         RP: 10.10.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 01:52:38
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 01:52:38, Expires: 00:03:03  
    <RouterC> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.10.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 01:51:24
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: pim-sm, UpTime: 01:51:24, Expires: -
    
     (10.110.1.100, 225.1.1.1)
         RP: 10.10.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 01:51:24
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: pim-sm, UpTime: 01:51:24, Expires: -
    

    # Trigger an active/standby on RouterC.

    [RouterC] slave switchover
    Warning: Are you sure to switch over?[Y/N]:Y
    

    # During the PIM GR process, run the display pim routing-table command on RouterB and RouterC to view the routing tables. The command output is as follows:

    <RouterB> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.10.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 02:52:38
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 02:52:38, Expires: 00:03:00
    
     (10.110.1.100, 225.1.1.1)
         RP: 10.10.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 02:52:38
         Upstream interface: GigabitEthernet1/0/0
             Upstream neighbor: 192.168.2.1
             RPF prime neighbor: 192.168.2.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet2/0/0
                 Protocol: pim-sm, UpTime: 02:52:38, Expires: 00:03:12  
    <RouterC> display pim routing-table
     VPN-Instance: public net
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 10.10.1.1
         Protocol: pim-sm, Flag: WC
         UpTime: 02:51:24
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: igmp, UpTime: 02:51:24, Expires: -
    
     (10.110.1.100, 225.1.1.1)
         RP: 10.10.1.1
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 02:51:24
         Upstream interface: GigabitEthernet2/0/0
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: GigabitEthernet1/0/0
                 Protocol: pim-sm, UpTime: 02:51:24, Expires: -
    

    The preceding information shows that the downstream interface on RouterB remains unchanged after an active/standby switchover occurs on RouterC. After the active/standby switchover, RouterC sends the backup Join messages to the upstream device and maintains the multicast forwarding entries during the GR process. This ensures nonstop multicast data forwarding.

    When RouterC is restoring multicast routing entries after the active/standby switchover, users can still receive multicast data normally. Multicast services are not affected during this process.

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 10.10.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     opaque-capability enable 
     graceful-restart period 200
     area 0.0.0.0
      network 10.10.1.1 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     static-rp 10.10.1.1 
    #
    return 
  • RouterB configuration file

    #
     sysname RouterB
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.2.2 24
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.4.1 24
     pim sm
    #
    ospf 1
     opaque-capability enable 
     graceful-restart period 200 
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 10.10.1.1 
    #
    return 
  • RouterC configuration file

    #
     sysname RouterC
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.110.2.1 24
     pim sm
     igmp enable
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.4.2 24
     pim sm
    #
    ospf 1
     opaque-capability enable 
     graceful-restart period 200 
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     static-rp 10.10.1.1 
     graceful-restart 
     graceful-restart period 300 
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069332

Views: 23865

Downloads: 65

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next