No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Multicast

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples of the interfaces supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-AS Multicast Using Static RPF Peers

Example for Configuring Inter-AS Multicast Using Static RPF Peers

Networking Requirements

As shown in Figure 6-11, two autonomous systems (ASs) exist on the network. Each AS contains at least one Protocol Independent Multicast Sparse Mode (PIM-SM) domain, and each PIM-SM domain may contain no or one multicast source and receiver. MSDP peer relationships need to be set up between PIM-SM domains to share multicast source information.

Figure 6-11  Network diagram for configuring inter-AS multicast by using static RPF peers

Configuration Roadmap

Set up an MSDP peer on the rendezvous point (RP) P in each PIM-SM domain. Specify static reverse path forwarding (RPF) peers for the MSDP peers. Source information can be transmitted across PIM-SM domains without changing unicast topology. The configuration roadmap is as follows:

  1. Configure IP addresses for the interfaces on each router, configure Open Shortest Path First (OSPF) in the ASs, configure External Border Gateway Protocol (EBGP) between ASs, and import BGP and OSPF routes into each other's routing table.

  2. Enable multicast on all routers and PIM-SM on all interfaces, and enable Internet Group Management Protocol (IGMP) on interfaces connected to network segments of receiver hosts. Configure Loopback0 interfaces, candidate bootstrap routers (C-BSRs), and candidate rendezvous points (C-RPs) on routers. Configure Loopback0 interfaces on RouterC, RouterD, and RouterF as the C-BSR and the C-RP of each PIM-SM domain.

  3. Set up MSDP peer relationships between RPs in PIM-SIM domains. Set up the MSDP peer relationship between RouterC and RouterD, and between RouterC and RouterF.

  4. Specify static RPF peers for the MSDP peers. Specify RouterD and RouterF as the static RPF peers of RouterC. Specify RouterC as the only static RPF peer of RouterD and RouterF. According to RPF rules, routers accept SA messages from static RPF peers.

Procedure

  1. Configure IP addresses for interfaces and configure a unicast routing protocol on each router.

    # According to Figure 6-11, configure IP addresses and masks for the interfaces on each router. Configure OSPF in the ASs. Configure EBGP between routerA and routerF, and between routerB and routerE. Import BGP and OSPF routes into each other's routing table. Ensure network connectivity between routers and enable routers to update routes using the unicast routing protocol. The configuration details are not mentioned here.

  2. # Enable multicast on routers and enable PIM-SM on each interface, and enable IGMP on interfaces connected to network segments of receiver hosts. In addition, configure the BSR boundary on the interfaces of routers on the AS boundary.

    # Enable multicast all routers and enable PIM-SM on each interface. The configurations on other routers are similar to the configuration on RouterC, and are not mentioned here.

    [RouterC] multicast routing-enable
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-Gigabitethernet1/0/0] pim sm
    [RouterC-Gigabitethernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-Gigabitethernet2/0/0] pim sm
    [RouterC-Gigabitethernet2/0/0] quit

    # Enable IGMP on GE3/0/0 of RouterE. The configuration on RouterG is similar to the configuration on RouterE, and is not mentioned here.

    [RouterE] interface gigabitethernet 3/0/0
    [RouterE-GigabitEthernet3/0/0] igmp enable
    [RouterE-GigabitEthernet3/0/0] quit

    # Configure a BSR boundary on GE1/0/0 of RouterA, GE2/0/0 of RouterB, GE2/0/0 of RouterE, and GE1/0/0 of RouterF. The configurations on RouterB, RouterE, and RouterF are similar to the configuration on RouterA, and are not mentioned here.

    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] pim bsr-boundary
    [RouterA-GigabitEthernet1/0/0] quit

  3. Configure Loopback0 interfaces, C-BSRs, and C-RPs on routeres.

    # Configure Loopback0 interfaces on RouterC, RouterD, and RouterF. Configure Loopback0 interfaces as C-BSRs and C-RPs. The configurations on RouterD and RouterF are similar to the configuration on RouterC, and are not mentioned here.

    [RouterC] interface loopback 0
    [RouterC-LoopBack0] ip address 10.10.1.1 255.255.255.255
    [RouterC-LoopBack0] pim sm
    [RouterC-LoopBack0] quit
    [RouterC] pim
    [RouterC-pim] c-bsr loopback 0
    [RouterC-pim] c-rp loopback 0
    [RouterC-pim] quit
    

  4. Configure static RPF peers.

    # Configure RouterD and RouterF as the static RPF peers of RouterC.

    [RouterC] ip ip-prefix list-df permit 192.168.0.0 16 greater-equal 16 less-equal 32
    [RouterC] msdp
    [RouterC-msdp] peer 192.168.3.2 connect-interface gigabitethernet 1/0/0
    [RouterC-msdp] peer 192.168.5.1 connect-interface gigabitethernet 2/0/0
    [RouterC-msdp] static-rpf-peer 192.168.3.2 rp-policy list-df
    [RouterC-msdp] static-rpf-peer 192.168.5.1 rp-policy list-df 
    [RouterC-msdp] quit

    # Configure RouterC as the only static RPF peer of RouterD and RouterF. The configuration on RouterF is similar to the configuration on RouterD, and is not mentioned here.

    [RouterD] ip ip-prefix list-c permit 192.168.0.0 16 greater-equal 16 less-equal 32
    [RouterD] msdp
    [RouterD-msdp] peer 192.168.1.1 connect-interface gigabitethernet 1/0/0
    [RouterD-msdp] static-rpf-peer 192.168.1.1 rp-policy list-c 

  5. Verify the configuration.

    # Run the display bgp peer command to view the BGP peer relationships among routeres. No command output is displayed on RouterC, which indicates that no BGP peer relationship is set up between RouterC and RouterD, or between RouterC and RouterF.

    # Run the display msdp brief command to view the status of the MSDP peers on routeres. When S1 in the PIM-SM1 domain sends multicast data, the receivers in PIM-SM2 and PIM-SM3 domains can receive the data. The following output shows summary information about MSDP peers on RouterC, RouterD and RouterF:

    <RouterC> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      2            2            0            0            0            0
     
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.3.2        Up        01:07:08        ?      8          0
      192.168.5.1        Up        00:16:39        ?      13         0
    
    <RouterD> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      1            1            0            0            0            0
     
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.1.1        Up        01:07:09        ?      8          0
    
    <RouterF> display msdp brief
    MSDP Peer Brief Information of VPN-Instance: public net
      Configured   Up           Listen       Connect      Shutdown     Down
      1            1            0            0            0            0
     
      Peer's Address     State     Up/Down time    AS     SA Count   Reset Count
      192.168.4.1        Up        00:16:40        ?      13         0
    

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.5.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     ip address 10.110.1.1 255.255.255.0
     pim sm
    #
    bgp 100
     router-id 10.10.10.3
     peer 192.168.5.1 as-number 200
    #
     ipv4-family unicast
      undo synchronization
      import-route ospf 1
      peer 192.168.5.1 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    return
    
  • RouterB configuration file

    #
     sysname RouterB
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.2 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    bgp 100
     router-id 10.10.10.2
     peer 192.168.2.1 as-number 200
    #
     ipv4-family unicast
      undo synchronization
      import-route ospf 1
      peer 192.168.2.1 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
  • RouterC configuration file

    #
     sysname RouterC
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 10.10.1.1 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-df index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.3.2 connect-interface GigabitEthernet1/0/0
     peer 192.168.5.1 connect-interface GigabitEthernet2/0/0
     static-rpf-peer 192.168.3.2 rp-policy list-df
     static-rpf-peer 192.168.5.1 rp-policy list-df
    #
    return
    
  • RouterD configuration file

    #
     sysname RouterD
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 10.10.1.2 255.255.255.255
     pim sm
    #
    ospf 1
     area 0.0.0.0
      network 10.10.1.2 0.0.0.0
      network 192.168.3.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-c index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.1.1 connect-interface GigabitEthernet1/0/0
     static-rpf-peer 192.168.1.1 rp-policy list-c
    #
    return
    
  • RouterE configuration file

    #
     sysname RouterE
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.2.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface GigabitEthernet3/0/0
     ip address 10.110.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    bgp 200
     router-id 10.10.10.4
     peer 192.168.2.2 as-number 100
    #
     ipv4-family unicast
      undo synchronization
      import-route ospf 1
      peer 192.168.2.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
    
  • RouterF configuration file

    #
     sysname RouterF
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 192.168.5.1 255.255.255.0
     pim bsr-boundary
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.6.1 255.255.255.0
     pim sm
    #
    interface LoopBack0
     ip address 10.10.1.3 255.255.255.255
     pim sm
    #
    bgp 200
     router-id 10.10.1.3
     peer 192.168.5.2 as-number 100
    #
     ipv4-family unicast
      undo synchronization
      import-route ospf 1
      peer 192.168.5.2 enable
    #
    ospf 1
     import-route bgp
     area 0.0.0.0
      network 10.10.1.3 0.0.0.0
      network 192.168.5.0 0.0.0.255
      network 192.168.6.0 0.0.0.255
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    ip ip-prefix list-c index 10 permit 192.168.0.0 16 greater-equal 16 less-equal 32
    #
    msdp
     peer 192.168.4.1 connect-interface GigabitEthernet1/0/0
     static-rpf-peer 192.168.4.1 rp-policy list-c
    #
    return
  • RouterG configuration file

    #
     sysname RouterG
    #
    multicast routing-enable
    #
    interface GigabitEthernet1/0/0
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet2/0/0
     ip address 192.168.6.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet3/0/0
     ip address 10.110.4.1 255.255.255.0
     pim sm
     igmp enable
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 10.110.4.0 0.0.0.255
      network 192.168.6.0 0.0.0.255
    #
    return
    
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069332

Views: 21938

Downloads: 59

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next