No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Service

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Routed Proxy ARP

Example for Configuring Routed Proxy ARP

Networking Requirements

As shown in Figure 2-13, branch A and branch B of a company are located in different cities. Multiple routing devices are deployed between branches, and routes are reachable. IP addresses of the routing devices are on the same network segment 10.16.0.0/16. Branch A and branch B belong to different broadcast domains; therefore, they cannot communicate on a LAN. Hosts of branches are not configured with default gateways; therefore, they cannot communicate across network segments. The company requires that branch A and branch B communicate without changing the host configurations.

NOTE:
AR100, AR120, AR150, AR160, AR200 functions as RouterA or RouterB.
Figure 2-13  Networking diagram for configuring routed proxy ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Add the interface connecting RouterA and branch A to VLAN10 and add the interface connecting RouterB and branch B to VLAN20.

  2. Enable routed proxy ARP on VLANIF interfaces of branch A and branch B to implement communication between the two branches.

Procedure

  1. Configure RouterA.

    # Create VLAN10.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] vlan 10
    [RouterA-vlan10] quit

    # Add Etherent2/0/0 to VLAN10.

    [RouterA] interface ethernet 2/0/0
    [RouterA-Ethernet2/0/0] port link-type access
    [RouterA-Ethernet2/0/0] port default vlan 10
    [RouterA-Ethernet2/0/0] quit

    # Configure an IP address for VLANIF10.

    [RouterA] interface vlanif 10
    [RouterA-Vlanif10] ip address 10.16.1.1 255.255.255.0

    # Enable routed proxy ARP on VLANIF10.

    [RouterA-Vlanif10] arp-proxy enable
    [RouterA-Vlanif10] quit

  2. Configure RouterB.

    The configuration of RouterB is similar to that of RouterA.

  3. Verify the configuration.

    # Select HostA at 10.16.1.2/16 in branch A and select HostB at 10.16.2.2/16 in branch B. Run the ping command on HostA to ping the IP address of HostB.

    C:\Documents and Settings\Administrator> ping 10.16.2.2
     PING 10.16.2.2: 56  data bytes, press CTRL_C to break                       
        Reply from 10.16.2.2: bytes=56 Sequence=1 ttl=255 time=10 ms              
        Reply from 10.16.2.2: bytes=56 Sequence=2 ttl=255 time=10 ms              
        Reply from 10.16.2.2: bytes=56 Sequence=3 ttl=255 time=10 ms              
        Reply from 10.16.2.2: bytes=56 Sequence=4 ttl=255 time=10 ms              
        Reply from 10.16.2.2: bytes=56 Sequence=5 ttl=255 time=10 ms              
                                                                                    
      --- 10.16.2.2 ping statistics ---                                           
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 10/10/10 ms                                        
                                             

    # View the ARP mapping table of HostA. You can see that the MAC address of HostB is the MAC address of VLANIF10.

    C:\Documents and Settings\Administrator> arp -a
    Interface: 10.16.1.2 --- 0x2
      Internet Address      Physical Address      Type
      10.16.2.2             00e0-fc39-80aa        dynamic

Configuration Files

  • Configuration file of RouterA

    #
     sysname RouterA
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.16.1.1 255.255.255.0
     arp-proxy enable
    #
    interface Ethernet2/0/0
     port link-type access
     port default vlan 10
    #
    return
    
  • Configuration file of RouterB

    #
     sysname RouterB
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 10.16.2.1 255.255.255.0
     arp-proxy enable
    #
    interface Ethernet2/0/0
     port link-type access
     port default vlan 20
    #
    return
    
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069333

Views: 36633

Downloads: 186

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next