No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Service

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multi-Interface ARP

Example for Configuring Multi-Interface ARP

Networking Requirements

As shown in Figure 2-17, the router connects to three NLB servers through interfaces Eth2/0/1, Eth2/0/2, and Eth2/0/3 respectively. The three interfaces belong to VLAN 10. The NLB group works in multicast mode. Each server in the NLB group has its own IP address and MAC address. The servers also share virtual IP address 10.128.246.252/24 and virtual MAC address 03bf-0a80-f6fc.

When the client attempts to connect to the virtual IP address of the NLB group, the router needs to forward packets destined for the group virtual IP address to all servers in the NLB group.

Figure 2-17  Networking diagram for configuring multi-interface ARP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces and add the interfaces to a VLAN.
  2. Configure a multi-interface MAC address entry and a static ARP entry so that the router can forward packets destined for the group virtual IP address to the three servers in the NLB group.

Procedure

  1. Create a VLAN and add interfaces to the VLAN.

    # On the router, create a VLAN and add the interfaces to the VLAN.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface ethernet 2/0/1
    [Router-Ethernet2/0/1] port link-type access
    [Router-Ethernet2/0/1] quit
    [Router] interface ethernet 2/0/2
    [Router-Ethernet2/0/2] port link-type access
    [Router-Ethernet2/0/2] quit
    [Router] interface ethernet 2/0/3
    [Router-Ethernet2/0/3] port link-type access
    [Router-Ethernet2/0/3] quit
    [Router] vlan 10
    [Router-vlan10] port ethernet 2/0/1 to 2/0/3
    [Router-vlan10] quit
    

  2. On the router, create a VLANIF interface and assign an IP address to it.

    [Router] interface vlanif 10
    [Router-Vlanif10] ip address 10.128.246.251 24
    [Router-Vlanif10] quit
    

  3. On the router, configure a multi-interface MAC address entry.

    [Router] mac-address multiport 03bf-0a80-f6fc interface ethernet 2/0/1 to ethernet 2/0/3 vlan 10
    

  4. On the router, configure a static ARP entry.

    [Router] arp static 10.128.246.252 03bf-0a80-f6fc
    [Router] quit

  5. Verify the configuration.

    # On the router, run the display mac-address multiport vlan 10 command to check the multi-interface MAC address table.

    <Router> display mac-address multiport vlan 10
    --------------------------------------------------------------------------------
    MAC Address       VLANID    Out-Interface                                       
    --------------------------------------------------------------------------------
    03bf-0a80-f6fc    10        Ethernet2/0/1                                       
                                Ethernet2/0/2                                       
                                Ethernet2/0/3                                       
                                                3 port(s)                           
    --------------------------------------------------------------------------------
     Total Group(s) : 1  

    # On the router, run the display arp static command to check the static ARP entry.

    <Router> display arp static
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE
                                              VLAN/CEVLAN PVC                     
    ------------------------------------------------------------------------------
    10.128.246.252  03bf-0a80-f6fc            S--         Multi-port:3            
    ------------------------------------------------------------------------------
    Total:1         Dynamic:0       Static:1     Interface:0 

Configuration Files

Configuration file of the router

#
 sysname Router
#
vlan batch 10
#
interface Vlanif10
 ip address 10.128.246.251 255.255.255.0
#
interface Ethernet2/0/1
 mac-address multiport 03bf-0a80-f6fc vlan 10 
 port link-type access                   
 port default vlan 10 
#
interface Ethernet2/0/2
 mac-address multiport 03bf-0a80-f6fc vlan 10    
 port link-type access                    
 port default vlan 10 
#
interface Ethernet2/0/3
 mac-address multiport 03bf-0a80-f6fc vlan 10   
 port link-type access                  
 port default vlan 10 
#
arp static 10.128.246.252 03bf-0a80-f6fc
#
return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069333

Views: 32996

Downloads: 167

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next