No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - IP Service

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document describes the concepts and configuration procedures of IP Service features on the device, and provides the configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an ISATAP Tunnel

Example for Configuring an ISATAP Tunnel

Networking Requirements

Figure 11-18 shows how an IPv6 host on the IPv4 network needs to connect to the IPv6 network through a border router. The IPv6 host and border router support ISATAP, so an ISATAP tunnel needs to be set up between the IPv6 host and the border router.

Figure 11-18  Networking diagram for configuring an ISATAP tunnel

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IPv4/IPv6 dual stack on the router so that the router can communicate with devices on the IPv4 and IPv6 networks.

  2. Configure an ISATAP tunnel on the router so that IPv6 hosts on the IPv4 network can communicate with IPv6 hosts on the IPv6 network.

  3. Configure a static route.

Procedure

  1. Configure the ISATAP router.

    # Enable the IPv4/IPv6 dual stack and configure an IP address for each interface.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] ipv6
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] ipv6 enable
    [Router-GigabitEthernet1/0/0] ipv6 address fc01::1/64
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface gigabitethernet 2/0/0
    [Router-GigabitEthernet2/0/0] ip address 2.1.1.1 255.0.0.0
    [Router-GigabitEthernet2/0/0] quit

    # Configure an ISATAP tunnel.

    [Router] interface tunnel 0/0/2
    [Router-Tunnel0/0/2] tunnel-protocol ipv6-ipv4 isatap
    [Router-Tunnel0/0/2] ipv6 enable
    [Router-Tunnel0/0/2] ipv6 address 2001::/64 eui-64
    [Router-Tunnel0/0/2] source gigabitethernet 2/0/0
    [Router-Tunnel0/0/2] undo ipv6 nd ra halt
    [Router-Tunnel0/0/2] quit

  2. Configure the ISATAP host.

    The ISATAP host is relevant to the operating system. The host running Windows 7 is used as an example.

    # Run the following command to add a static route to the border router. IPv6 has been installed by default in Windows 7 operating system.

    C:\> netsh interface ipv6 isatap set router 2.1.1.1
    C:\> netsh interface ipv6 isatap set router 2.1.1.1 enabled

    # Check ISATAP interface information on the host.

    C:\>ipconfig/all
    Tunnel adapter Automatic Tunneling Pseudo-Interface isatap.{895CA398-8C4F-4332-9558-642844FCB01B}:
       Connection-specific DNS Suffix . . . . . . . :
       Description . . . . . . . . . . . . . . . : Microsoft ISATAP Adapter #5
        Physical Address. . . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled . . . . . . . . . . . :No
       Automatic configuration. . . . . . . . . . : YES
       IP Address . . . . . . . . . . . . : 2001::200:5efe:2.1.1.2
       IP Address. . . . . . . . : fe80::200:5efe:2.1.1.2%30
       Default Gateway. . . . . . . . . . . . . : fe80::5efe:2.1.1.1%30
       DNS Servers  . . . . . . . . . . . : fc01:0:0:ffff::1%1
                                           fc01:0:0:ffff::2%1
                                           fc01:0:0:ffff::3%1
       NetBIOS over Tcpip  . . . . . . . : Disabled

    The preceding information shows that the host obtains the prefix 2001::/64 and generates the address 2001::200:5efe:2.1.1.2, and the ISATAP tunnel has been set up successfully.

  3. Configure the IPv6 host.

    # Configure a static route to the border router tunnel on the IPv6 host so that PCs on two different networks can communicate through the ISATAP tunnel.

    C:\> netsh interface ipv6 set route 2001::/64 fc01::1

  4. Verify the configuration.

    # View the IPv6 status of Tunnel0/0/2 on the ISATAP router.

    [Router] display ipv6 interface Tunnel 0/0/2
    Tunnel0/0/2 current state : UP
    IPv6 protocol current state : UP
    IPv6 is enabled, link-local address is FE80::5EFE:201:101
      Global unicast address(es):
        2001::5EFE:201:101, subnet is 2001::/64
      Joined group address(es):
        FF02::1:FF01:101
        FF02::2
        FF02::1
      MTU is 1500 bytes
      ND reachable time is 30000 milliseconds
      ND retransmit interval is 1000 milliseconds
      ND advertised reachable time is 0 milliseconds
      ND advertised retransmit interval is 0 milliseconds
      ND router advertisement max interval 600 seconds, min interval 200 seconds
      ND router advertisements live for 1800 seconds
      Hosts use stateless autoconfig for addresses

    # Ping the global unicast address of the tunnel interface on the ISATAP host running Windows XP operating system from the ISATAP router.

    [Router] ping ipv6 2001::5efe:2.1.1.2
      PING 2001::5efe:2.1.1.2 : 56  data bytes, press CTRL_C to break
        Reply from 2001::5EFE:201:102
        bytes=56 Sequence=1 hop limit=64  time = 4 ms
        Reply from 2001::5EFE:201:102
        bytes=56 Sequence=2 hop limit=64  time = 3 ms
        Reply from 2001::5EFE:201:102
        bytes=56 Sequence=3 hop limit=64  time = 2 ms
        Reply from 2001::5EFE:201:102
        bytes=56 Sequence=4 hop limit=64  time = 2 ms
        Reply from 2001::5EFE:201:102
        bytes=56 Sequence=5 hop limit=64  time = 2 ms
    
    
      --- 2001::5efe:2.1.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 2/2/4 ms

    # Ping the global unicast address of the ISATAP router from the ISATAP host running Windows XP operating system.

    C:\> ping6 2001::5efe:2.1.1.1
    
    
    Pinging 2001::5efe:2.1.1.1
    from 2001::5efe:2.1.1.2 with 32 bytes of data:
    
    
    Reply from 2001::5efe:2.1.1.1: bytes=32 time=1ms
    Reply from 2001::5efe:2.1.1.1: bytes=32 time=1ms
    Reply from 2001::5efe:2.1.1.1: bytes=32 time=1ms
    Reply from 2001::5efe:2.1.1.1: bytes=32 time=1ms
    
    
    Ping statistics for 2001::5efe:2.1.1.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 1ms, Average = 1ms

    # Ping the IPv6 host from the ISATAP host running Windows XP operating system. They can ping each other.

    C:\> ping6 fc01::2
    
    
    Pinging fc01::2 with 32 bytes of data:
    
    
    Reply from fc01::2: time<1ms
    Reply from fc01::2: time<1ms
    Reply from fc01::2: time<1ms
    Reply from fc01::2: time<1ms
    
    
    Ping statistics for fc01::2:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 0ms, Average = 0ms

Configuration Files

Configuration file of the ISATAP router

#
 sysname ISATAP
#
ipv6
#
interface GigabitEthernet1/0/0
 ipv6 enable
 ipv6 address fc01::1/64
#
interface GigabitEthernet2/0/0
 ip address 2.1.1.1 255.0.0.0
#
interface Tunnel0/0/2
ipv6 enable
ipv6 address 2001::/64 eui-64
undo ipv6 nd ra halt
tunnel-protocol ipv6-ipv4 isatap
source GigabitEthernet2/0/0
#
return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069333

Views: 33701

Downloads: 169

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next