No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples in different application scenarios of the network management feature supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LSDP

Example for Configuring LSDP

Networking Requirements

As shown in Figure 8-3, the link RouterA->RouterB->RouterD is the primary link, and the link RouterA->RouterC->RouterD is the backup link. It is required to monitor the primary link status. If the primary link fails, the backup link starts to transmit services to reduce the impact on services. When the primary link is recovered, the primary link takes over services again.

Figure 8-3  LSDP network diagram

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure interface IP addresses and static routes for primary and backup links to implement connectivity at the network layer.
  2. Configure LSDP on RouterA to detect primary link connectivity in real time.

Procedure

  1. Configure connectivity at the network layer.
    1. Configure interface IP addresses for RouterA according to the network diagram.

      <Huawei> system-view
      [Huawei] sysname RouterA
      [RouterA] interface gigabitethernet1/0/0
      [Router-GigabitEthernet1/0/0] ip address 10.1.2.1 255.255.255.0
      [Router-GigabitEthernet1/0/0] quit
      [RouterA] interface gigabitethernet2/0/0
      [Router-GigabitEthernet2/0/0] ip address 10.1.3.1 255.255.255.0
      [Router-GigabitEthernet2/0/0] quit

    2. On RouterA, configure static routes to 10.1.4.0/24 and 10.1.5.0/24 of RouterD.

      [RouterA] ip route-static 10.1.4.0 255.255.255.0 10.1.2.2 preference 40
      [RouterA] ip route-static 10.1.5.0 255.255.255.0 10.1.3.2 preference 80

  2. Configure LSDP on RouterA.

    [RouterA] interface gigabitethernet1/0/0
    [RouterA-GigabitEthernet1/0/0] lsdp 10.1.4.2 10.1.2.2
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA]

  3. Verify the configuration.

    # View the LSDP configuration and running status on RouterA.

    <RouterA> display lsdp
    ======LSDP INFO=========                                                        
    LSDP Instance Index : 1                                                         
    LSDP Test : success                                                             
    LSDP Interface Name : GigabitEthernet1/0/0                                      
    LSDP Interface Status : UP                                                      
    LSDP Interface Ip : 10.1.2.1                                                    
    LSDP Destination Ip : 10.1.4.2                                                  
    LSDP Next-hop Ip : 10.1.2.2                                                     
    LSDP Interval : 1000                                                            
    LSDP Probe-count : 3                                                            
    LSDP UpTimes : 0                                                                
    LSDP DownTimes : 0                                                              
    =========================  
    

Configuration Files

RouterA configuration file

#
 sysname RouterA
#
interface GigabitEthernet1/0/0
 lsdp 10.1.4.2 10.1.2.2
 ip address 10.1.2.1 255.255.255.0
#
 ip route-static 10.1.4.0 255.255.255.0 10.1.2.2 preference 40
 ip route-static 10.1.5.0 255.255.255.0 10.1.3.2 preference 80
#
return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069336

Views: 30161

Downloads: 177

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next