No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples in different application scenarios of the network management feature supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring RMON

Example for Configuring RMON

Networking Requirements

As shown in Figure 2-1, a subnet connects to the network through GE2/0/0. The router monitors the subnet, including:

  • Collecting real-time and history statistics on traffic and each type of packets

  • Recording logs when the traffic volume per minute exceeds the threshold

  • Monitoring broadcast and multicast traffic volume on the subnet and reporting alarm to the NMS when the traffic volume exceeds the threshold

Figure 2-1  Networking diagram of RMON configuration

Configuration Roadmap

To collect real-time and history statistics on traffic and each type of packets, configure the RMON statistics function. To report alarms to the NMS when traffic volume exceeds the threshold, configure the RMON alarm function.

The configuration roadmap is as follows:

  1. Configure IP addresses for router interfaces.
  2. Configure a reachable route between the router and NMS.
  3. Run the SNMP commands to set the router can send traps to the NMS.

  4. Enable RMON statistics function and configure the statistics table and history control table.

  5. Configure the event table, alarm table, and extended alarm table.

Procedure

  1. Configure IP addresses and reachable route for router interfaces.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] ip address 10.2.2.1 24
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface gigabitethernet 2/0/0
    [Router-GigabitEthernet2/0/0] ip address 10.3.3.1 24
    [Router-GigabitEthernet2/0/0] quit
    [Router] ospf
    [Router-ospf-1] area 0
    [Router-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [Router-ospf-1-area-0.0.0.0] network 10.3.3.0 0.0.0.255
    [Router-ospf-1-area-0.0.0.0] quit
    [Router-ospf-1] quit
    

  2. Enable the router to send traps to the NMS.

    # Enable SNMP to send traps.

    [Router] snmp-agent trap enable

    # Specify the NMS that receives the traps.

    [Router] snmp-agent target-host trap-paramsname hw v1 securityname public
    [Router] snmp-agent target-host trap-hostname hwnm address 10.1.1.1 trap-paramsname hw

  3. Configure RMON statistics function.

    # Enable the RMON statistics function on the interface.

    [Router] interface gigabitethernet 2/0/0
    [Router-GigabitEthernet2/0/0] rmon-statistics enable

    # Configure the statistics table.

    [Router-GigabitEthernet2/0/0] rmon statistics 1 owner Test300

    # Configure the history control table. Sample traffic on the subnet every 30 seconds and save the latest 10 records

    [Router-GigabitEthernet2/0/0] rmon history 1 buckets 10 interval 30 owner Test300
    [Router-GigabitEthernet2/0/0] quit

  4. Configure RMON alarm function.

    # Configure the event table. Configure the router to record logs for RMON event 1 and send traps to the NMS for RMON event 2.

    [Router] rmon event 1 log owner Test300
    [Router] rmon event 2 description forUseofPrialarm trap public owner Test300

    # Configure the alarm table. Set the sampling interval and the threshold for triggering event 1 (OID is 1.3.6.1.2.1.16.1.1.1.6.1).

    [Router] rmon alarm 1 1.3.6.1.2.1.16.1.1.1.6.1 30 absolute rising-threshold 500 1 falling-threshold 100 1 owner Test300

    # Configure the extended alarm table. Sample broadcast and multicast packets every 30 seconds. When the number of sampled packets exceeds 1000 or decreases to 0, event 2 is triggered. That is, the device sends a trap to the NMS.

    [Router] rmon prialarm 1 .1.3.6.1.2.1.16.1.1.1.6.1+.1.3.6.1.2.1.16.1.1.1.7.1 sumofbroadandmulti 30 delta rising-threshold 1000 2 falling-threshold 0 2 entrytype forever owner Test300

  5. Verify the configuration.

    # View traffic volume on the subnet.

    <Router> display rmon statistics gigabitethernet 2/0/0
    Statistics entry 1 owned by Test300 is VALID.
      Interface : GigabitEthernet2/0/0<ifEntry.402653698>
      Received  :
      octets              :142915224 , packets          :1749151
      broadcast packets   :11603     , multicast packets:756252
      undersize packets  :0          , oversize packets:0
      fragments packets   :0         , jabbers packets  :0
      CRC alignment errors:0         , collisions       :0
      Dropped packet (insufficient resources):1795
      Packets received according to length (octets):
      64     :150183    ,  65-127  :150183    ,  128-255  :1383
      256-511:3698      ,  512-1023:0         ,  1024-1518:0
    

    # View the sampling records. Only the last sampling record can be displayed using the command line. To view all the history records, use special NMS software.

    <Router> display rmon history gigabitethernet 2/0/0
    History control entry 1 owned by Test300 is VALID
      Samples Interface    :GigabitEthernet2/0/0<ifEntry.402653698>
      Sampling interval    :30(sec) with 10 buckets max
      Last Sampling time   :0days 00h:19m:43s
      Latest sampled values:
      octets               :654       , packets           :7
      broadcast packets    :7         , multicast packets :0
      undersize packets    :0         , oversize packets  :0
      fragments packets    :0         , jabbers packets   :0
      CRC alignment errors :0         , collisions        :0
      Dropped packet:      :0         , utilization       :0
      History record:
      Record No.1 (Sample time: 6days 01h:35m:22s)
      octets               :0         , packets           :0
      broadcast packets    :0         , multicast packets :0
      undersize packets    :0         , oversize packets  :0
      fragments packets    :0         , jabbers packets   :0
      CRC alignment errors :0         , collisions        :0
      Dropped packet:      :0         , utilization       :0 

    # View the RMON event configurations.

    <Router> display rmon event
    Event table 1 owned by Text300 is VALID.
      Description: null.
      Will cause log when triggered, last triggered at 0days 01h:33m:46s.
    Event table 2 owned by Test300 is VALID.
      Description: forUseofPrialarm.
      Will cause snmp-trap when triggered, last triggered at 0days 01h:38m:54s.

    # View the RMON alarm configurations.

    <Router> display rmon alarm 1
    Alarm table 1 owned by Test300 is VALID.
     Samples  absolute value   : 1.3.6.1.2.1.16.1.1.1.6.1 <etherStatsBroadcastPkts.1>
     Sampling interval         : 30(sec)
     Rising threshold          : 500(linked with event 1)
     Falling threshold         : 100(linked with event 1)
     When startup enables      : risingOrFallingAlarm
     Latest value              : 1975

    # View the RMON extended alarm configurations.

    <Router> display rmon prialarm 1
    Prialarm table 1 owned by Test300 is VALID.
      Samples delta value       : .1.3.6.1.2.1.16.1.1.1.6.1+.1.3.6.1.2.1.16.1.1.1.7.1
      Sampling interval         : 30(sec)
      Rising threshold          : 1000(linked with event 2)
      Falling threshold         : 0(linked with event 2)
      When startup enables      : risingOrFallingAlarm
      This entry will exist     : forever
      Latest value              : 16
    

    # View the event logs.

    <Router> display rmon eventlog
    Event table 1 owned by Text300 is VALID.
      Generates eventLog 1.1 at 0days 01h:33m:46s.
      Description: The 1.3.6.1.2.1.16.1.1.1.6.1 defined in alarm table 1,
         less than or equal to 100 with alarm value 0. Alarm sample type is absolute.                   

Configuration Files

Configuration file of the router

#
 sysname Router
#
interface GigabitEthernet1/0/0
 ip address 10.2.2.1 255.255.255.0
#
interface GigabitEthernet2/0/0
 ip address 10.3.3.1 255.255.255.0
 rmon-statistics enable
 rmon statistics 1 owner Test300
 rmon history 1 buckets 10 interval 30 owner Test300
#
ospf 1
 area 0.0.0.0
  network 10.2.2.0 0.0.0.255
  network 10.3.3.0 0.0.0.255
#
 snmp-agent target-host trap-hostname hwnm address 10.1.1.1 udp-port 162 trap-paramsname hw
 snmp-agent target-host trap-paramsname hw v1 securityname %@%@_=XqAFC_94uCS,3'<gYC*ZU6%@%@
 snmp-agent trap enable
#
rmon event 1 description null log owner Test300
rmon event 2 description forUseofPrialarm trap public owner Test300
rmon alarm 1 1.3.6.1.2.1.16.1.1.1.6.1 30 absolute rising-threshold 500 1 falling-threshold 100 1 owner Test300
rmon prialarm 1 .1.3.6.1.2.1.16.1.1.1.6.1+.1.3.6.1.2.1.16.1.1.1.7.1 sumofbroadandmulti 30 delta rising-threshold 1000 2 falling-threshold 0 2 entrytype forever owner Test300
#
return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069336

Views: 33307

Downloads: 189

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next