No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples in different application scenarios of the network management feature supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the LSP Trace Test for the TE Tunnel

Example for Configuring the LSP Trace Test for the TE Tunnel

Networking Requirements

In Figure 7-34:

  • The OSPF protocol runs on Router A, Router B, and Router C. The three Routers learn the 32-bit host routes on their loopback interfaces.

  • MPLS, MPLS TE, and MPLS RSVP-TE are enabled on Router A, Router B, and Router C.

  • MPLS, MPLS TE, and MPLS RSVP-TE are enabled on the GE interfaces connected to Router A, Router B, and Router C to set up a TE tunnel from Router A to Router C.

The NQA LSP trace test is used to test the TE tunnel.

Figure 7-34  Networking diagram for configuring the LSP trace test

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure Router A as the NQA client. Create an LSP trace test on Router A.

  2. Configure Router C as the NQA server.

Procedure

  1. Configure reachable routes between Router A and Router B, between Router A and Router C, and between Router B and Router C. The configuration details are not mentioned here.
  2. Enable MPLS RSVP-TE on Router A, Router B, and Router C. The configuration details are not mentioned here.

    For the configuration of MPLS RSVP-TE, refer to the Huawei AR100&AR120&AR150&AR160&AR200&AR1200&AR2200&AR3200&AR3600 Series Enterprise Routers Configuration Guide - MPLS.

  3. Configure a TE tunnel on Router A to connect Router C. The configuration details are not mentioned here.
  4. Create an NQA test on Router A.

    # Enable the NQA client and configure the LSP trace test for the TE tunnel.

    <RouterA> system-view
    [RouterA] nqa test-instance admin lsptrace
    [RouterA-nqa-admin-lsptrace] test-type lsptrace
    [RouterA-nqa-admin-lsptrace] lsp-type te
    [RouterA-nqa-admin-lsptrace] lsp-tetunnel tunnel 0/0/1

  5. Perform the test.

    [RouterA-nqa-admin-lsptrace] start now

  6. Verify the configuration.

    [RouterA-nqa-admin-lsptrace] display nqa results test-instance admin lsptrace
    
     NQA entry(admin, lsptrace) :testflag is inactive ,testtype is lsptrace
      1 . Test 1 result   The test is finished
       Completion:success                   Attempts number:1
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Status errors number:0
       Drop operation number:0
       Last good path Time:2013-01-05 14:15:09.1
       1 . Hop 1
        Send operation times: 3              Receive response times: 3
        Min/Max/Average Completion Time: 2/4/3
        Sum/Square-Sum  Completion Time: 9/29
        RTD OverThresholds number: 0
        Last Good Probe Time: 2013-01-05 14:15:09.0
        Destination ip address:10.1.1.2
        Lost packet ratio: 0 %
       2 . Hop 2
        Send operation times: 3              Receive response times: 3
        Min/Max/Average Completion Time: 2/7/4
        Sum/Square-Sum  Completion Time: 12/62
        RTD OverThresholds number: 0
        Last Good Probe Time: 2013-01-05 14:15:09.1
        Destination ip address:10.3.3.9
        Lost packet ratio: 0 %                          

Configuration Files

  • Router A configuration file

    #
    sysname RouterA
    #
     mpls lsr-id 10.1.1.9
     mpls
      mpls te
      mpls rsvp-te
      mpls te cspf
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 10.1.1.9 255.255.255.255
    #
    interface Tunnel0/0/1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 10.3.3.9
     mpls te tunnel-id 100
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      mpls-te enable
    #
    nqa test-instance admin lsptrace
     test-type  lsptrace
     lsp-type te
     lsp-tetunnel Tunnel0/0/1
    #
    return
  • Router B configuration file

    #
    sysname RouterB
    #
     mpls lsr-id 10.2.2.9
     mpls
      mpls te
      mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 10.2.2.9 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.2.2.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
      mpls-te enable
    #
    return
  • Router C configuration file

    #
    sysname RouterC
    #
     mpls lsr-id 10.3.3.9
     mpls
      mpls te
      mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls te
     mpls rsvp-te
    #
    interface LoopBack1
     ip address 10.3.3.9 255.255.255.255
    #
    interface Tunnel0/0/1
     ip address unnumbered interface LoopBack1
     tunnel-protocol mpls te
     destination 10.1.1.9
     mpls te tunnel-id 100
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.3.3.9 0.0.0.0
      network 10.2.1.0 0.0.0.255
      mpls-te enable
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069336

Views: 33942

Downloads: 193

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next