No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples in different application scenarios of the network management feature supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a UDP Test Instance

Example for Configuring a UDP Test Instance

Networking Requirements

In Figure 7-27, an NQA UDP test needs to be performed to obtain the RTT of a UDP packet transmitted between RouterA and RouterC.

Figure 7-27  Networking diagram for configuring a UDP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure RouterA as an NQA client and configure RouterC as an NQA server.

  2. Configure the port number monitored by the NQA server and create an NQA UDP test instance on the NQA client.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between Routers, as shown in Figure 7-27.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    NOTE:

    For configurations of RouterB and RouterC, see the configuration files.

  2. Configure an NQA server on RouterC.

    # Configure the monitoring IP address and UDP port number on the NQA server.

    <RouterC> system-view
    [RouterC] nqa-server udpecho 10.2.1.2 6000

  3. Configure the NQA client on RouterA.

    # Enable the NQA client and create a UDP test instance.

    [RouterA] nqa test-instance admin udp
    [RouterA-nqa-admin-udp] test-type udp
    [RouterA-nqa-admin-udp] destination-address ipv4 10.2.1.2
    [RouterA-nqa-admin-udp] destination-port 6000

  4. Start the test instance.

    [RouterA-nqa-admin-udp] start now

  5. Verify the configuration.

    [RouterA-nqa-admin-udp] display nqa results test-instance admin udp 
     NQA entry(admin, udp) :testflag is inactive ,testtype is udp
      1 . Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:1                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Status errors number:0
       Destination ip address:10.2.1.2
       Min/Max/Average Completion Time: 32/109/67
       Sum/Square-Sum  Completion Time: 203/16749
       Last Good Probe Time: 2012-7-25 16:23:49.1
       Lost packet ratio: 0 %                      

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.1 255.255.255.0
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    nqa test-instance admin udp
     test-type udp
     destination-address ipv4 10.2.1.2
     destination-port 6000
    #
    return
    
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.2.1.1 255.255.255.0
    #
    return
    
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 10.2.1.2 255.255.255.0
    #
    nqa-server udpecho 10.2.1.2 6000
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    return
    
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069336

Views: 34139

Downloads: 196

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next