No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Network Management and Monitoring

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides the basic concepts, configuration procedures, and configuration examples in different application scenarios of the network management feature supported by the device.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LLDP on a Network with Link Aggregation Configured

Example for Configuring LLDP on a Network with Link Aggregation Configured

Networking Requirements

As shown in Figure 6-8, RouterA and RouterB are connected through an Eth-Trunk. Routes between the NMS and routers are reachable, and SNMP is configured.

A network administrator wants to obtain Layer 2 information about RouterA and RouterB to know the detailed network topology and configuration conflicts.

Figure 6-8  Network with link aggregation configured

Configuration Roadmap

The LLDP function can meet the network administrator's requirement. The configuration roadmap is as follows:
  1. Add physical interfaces on RouterA and RouterB to the Eth-Trunk.
  2. Enable global LLDP on RouterA and RouterB.
  3. Configure management IP addresses for RouterA and RouterB.

Procedure

  1. Add physical interfaces on RouterA and RouterB to the Eth-Trunk.

    # Configure RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] vlan batch 100
    [RouterA] interface eth-trunk 1
    [RouterA-Eth-Trunk1] trunkport ethernet 2/0/0 to 2/0/2
    [RouterA-Eth-Trunk1] port link-type trunk
    [RouterA-Eth-Trunk1] port trunk allow-pass vlan 100
    [RouterA-Eth-Trunk1] quit

    # Configure RouterB.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] vlan batch 100
    [RouterB] interface eth-trunk 1
    [RouterB-Eth-Trunk1] trunkport ethernet 2/0/0 to 2/0/2
    [RouterB-Eth-Trunk1] port link-type trunk
    [RouterB-Eth-Trunk1] port trunk allow-pass vlan 100
    [RouterB-Eth-Trunk1] quit

  2. Enable global LLDP on RouterA and RouterB.

    # Configure RouterA.
    [RouterA] lldp enable
    # Configure RouterB.
    [RouterB] lldp enable

  3. Configure management IP addresses for RouterA and RouterB.

    # Configure RouterA. Assume that the Loopback address of RouterA is 10.10.10.1/32.
    [RouterA] lldp management-address 10.10.10.1
    # Configure RouterB. Assume that the Loopback address of RouterB is 10.10.10.1/32.
    [RouterB] lldp management-address 10.10.10.2

  4. Verify the configurations.

    • Check the RouterA configuration.

      # Check whether the physical interfaces have been added to Eth-Trunk1.

      [RouterA] display eth-trunk 1
      Eth-Trunk1's state information is:
      WorkingMode: NORMAL         Hash arithmetic: According to SA-XOR-DA
      Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8
      Operate status: up          Number Of Up Port In Trunk: 3
      --------------------------------------------------------------------------------
      PortName                      Status      Weight
      Ethernet2/0/0                 Up          1
      Ethernet2/0/1                 Up          1
      Ethernet2/0/2                 Up          1  

      # View the LLDP configurations.

      <RouterA> display lldp local
      System information
      Chassis type   :macAddress
      Chassis ID     :00e0-11fc-1710
      System name    :RouterA
      System description  :Huawei AR2240 Huawei Versatile Routing Platform Software
      VRP (R) software,Version 5.130 (AR2240 V300R003)
      Copyright (C) 2011-2013 Huawei Technologies Co., Ltd
      System capabilities supported   :bridge
      System capabilities enabled     :bridge
      LLDP Up time   :2012/5/8 11:40:49
      
      MED system information
      Device class   :Network Connectivity
      (MED inventory information of master board)
      HardwareRev       :AR01SRU1A VER.A
      FirmwareRev       :NA
      SoftwareRev       :V300R003
      SerialNum         :NA
      Manufacturer name :HUAWEI TECH CO., LTD
      Model name        :NA
      Asset tracking identifier :NA
      
      System configuration
      LLDP Status                     :enabled             (default is disabled)
      LLDP Message Tx Interval        :30                  (default is 30s)
      LLDP Message Tx Hold Multiplier :4                   (default is 4)
      LLDP Refresh Delay              :2                   (default is 2s)
      LLDP Tx Delay                   :2                   (default is 2s)
      LLDP Notification Interval      :5                   (default is 5s)
      LLDP Notification Enable        :enabled             (default is enabled)
      Management Address              :IP: 10.10.10.1  MAC: 00e0-11fc-1710
      
      
      Remote Table Statistics:
      Remote Table Last Change Time   :0 days, 5 hours, 57 minutes, 32 seconds
      Remote Neighbors Added          :15
      Remote Neighbors Deleted        :13
      Remote Neighbors Dropped        :0
      Remote Neighbors Aged           :0
      Total Neighbors                 :2
      
      Port information:
      
      Interface Ethernet2/0/0:
      LLDP Enable Status       :enabled             (default is disabled)
      Total Neighbors          :1
      
      Port ID subtype     :interfaceName
      Port ID             :Ethernet2/0/0
      Port description    :HUAWEI, AR Series,Ethernet2/0/0 Interface
        ---- More ----
      

      # Check neighbor information for RouterA.

      [RouterA] display lldp neighbor brief
      Local Intf   Neighbor Dev             Neighbor Intf             Exptime
      Eth2/0/0     RouterB                  Eth2/0/0                  115
      Eth2/0/1     RouterB                  Eth2/0/1                  115
      Eth2/0/2     RouterB                  Eth2/0/2                  115       
    • Check the RouterB configuration.

      Refer to the steps for checking RouterA.

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    vlan batch 100
    #
    lldp enable
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface Ethernet2/0/0
     eth-trunk 1
    #
    interface Ethernet2/0/1
     eth-trunk 1
    #
    interface Ethernet2/0/2
     eth-trunk 1
    #
    lldp management-address  10.10.10.1
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    vlan batch 100
    #
    lldp enable
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface Ethernet2/0/0
     eth-trunk 1
    #
    interface Ethernet2/0/1
     eth-trunk 1
    #
    interface Ethernet2/0/2
     eth-trunk 1
    #
    lldp management-address  10.10.10.2
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069336

Views: 30818

Downloads: 177

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next