No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Ethernet Interface Backup in Load Balancing Mode

Example for Configuring Ethernet Interface Backup in Load Balancing Mode

Networking Requirements

As shown in Figure 2-12, HostA communicates with HostB through RouterA. RouterA directly connects to RouterB through three interfaces.

To improve reliability of data transmission between HostA and HostB, GE1/0/0 is required to load balance service when GE2/0/0 occupies 80% of the maximum bandwidth and a backup interface with the lowest priority needs to be shut down when GE2/0/0 occupies less than 20% of the maximum bandwidth.

Figure 2-12  Networking diagram of interface backup in load balancing mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface and a static route between HostA and HostB to ensure connectivity at the network layer.

  2. Configure GE2/0/0 as the primary interface on RouterA. Configure GE1/0/0 and GE3/0/0 as backup interfaces of GE2/0/0 and set a higher priority for GE1/0/0. When the traffic volume of the primary interface exceeds the upper threshold, GE1/0/0 is started to load balance services.

  3. Set the maximum bandwidth of the primary interface and higher and lower thresholds for determining when to start a backup interface.

Procedure

  1. Configure an IP address for each interface and a static route between HostA and HostB.

    # Assign an IP address to each interface. Use RouterA as an example. The configurations of RouterB are similar to the configuration of RouterA, and are not mentioned here.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.2.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 3/0/0
    [RouterA-GigabitEthernet3/0/0] ip address 10.1.3.1 255.255.255.0
    [RouterA-GigabitEthernet3/0/0] quit

    # On RouterA, configure a static route to the network segment where HostB is located.

    [RouterA] ip route-static 192.168.2.0 24 10.1.2.2
    [RouterA] ip route-static 192.168.2.0 24 10.1.1.2
    [RouterA] ip route-static 192.168.2.0 24 10.1.3.2

    # On RouterB, configure a static route to the network segment where HostA is located.

    [Huawei] system-view
    [Huawei] sysname RouterB
    [HuaweiB] ip route-static 192.168.1.0 24 10.1.2.1
    [HuaweiB] ip route-static 192.168.1.0 24 10.1.1.1
    [HuaweiB] ip route-static 192.168.1.0 24 10.1.3.1

  2. Configure backup interfaces and set priorities of backup interfaces on RouterA.

    # Configure GE2/0/0 as the primary interface and GE1/0/0 and GE3/0/0 as backup interfaces, and set the priority of GE1/0/0 and GE3/0/0 to 30 and 20.

    [HuaweiA] interface gigabitethernet 2/0/0
    [HuaweiA-GigabitEthernet2/0/0] standby interface gigabitethernet 1/0/0 30
    [HuaweiA-GigabitEthernet2/0/0] standby interface gigabitethernet 3/0/0 20
    [HuaweiA-GigabitEthernet2/0/0] quit

  3. Set the maximum bandwidth of the primary interface on RouterA.

    # Set the maximum bandwidth of the primary interface to 10000 kbit/s.

    [HuaweiA] interface gigabitethernet 2/0/0
    [HuaweiA-GigabitEthernet2/0/0] standby bandwidth 10000
    [HuaweiA-GigabitEthernet2/0/0] quit

  4. Set higher and lower thresholds on RouterA.

    # Set the higher threshold to 80% and lower threshold to 20%.

    [HuaweiA] interface gigabitethernet 2/0/0
    [HuaweiA-GigabitEthernet2/0/0] standby threshold 80 20
    [HuaweiA-GigabitEthernet2/0/0] quit

  5. Verify the configuration.

    # Run the display standby state command on RouterA to view the status of primary and backup interfaces. You can see that the value of Loadstate is TO-HYPNOTIZE, indicating that the load balancing mode is used. The status of the primary interface GigabitEthernet2/0/0 is Up, and the status of backup interfaces GigabitEthernet1/0/0 and GigabitEthernet3/0/0 is STANDBY.

    [HuaweiA] display standby state
    Interface                      Interfacestate Backupstate Backupflag Pri Loadstate
    GigabitEthernet2/0/0                       UP         MUP        MUD     TO-HYPNOTIZE
    GigabitEthernet1/0/0                  STANDBY     STANDBY         BU  30
    GigabitEthernet3/0/0                  STANDBY     STANDBY         BU  20
    Backup-flag meaning:
    M---MAIN  B---BACKUP     V---MOVED    U---USED
    D---LOAD  P---PULLED     
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask    Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface            State             

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
     standby interface GigabitEthernet1/0/0 30
     standby interface GigabitEthernet3/0/0 20
     standby bandwidth 10000
     standby threshold 80 20
    #
    interface GigabitEthernet3/0/0
      ip address 10.1.3.1 255.255.255.0
    #
     ip route-static 192.168.2.0 24 10.1.2.2
     ip route-static 192.168.2.0 24 10.1.1.2
     ip route-static 192.168.2.0 24 10.1.3.2
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
     ip address 10.1.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet3/0/0
     ip address 10.1.3.2 255.255.255.0
    #
     ip route-static 192.168.1.0 24 10.1.2.1
     ip route-static 192.168.1.0 24 10.1.1.1
     ip route-static 192.168.1.0 24 10.1.3.1
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069338

Views: 14240

Downloads: 43

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next