No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring BFD on a Dot1q Termination Sub-interface

Example for Configuring BFD on a Dot1q Termination Sub-interface

Networking Requirements

As shown in Figure 6-26, a VRRP group is established between RouterA and RouterB and users in VLAN 10 access the ISP through the default gateway. Dot1q termination sub-interfaces on RouterA and RouterB support VRRP. It is required that faults on the link between RouterA and RouterB be fast detected to implement a rapid VRRP active/standby switchover.

Figure 6-26  Networking diagram for configuring VRRP on a Dot1q termination sub-interface

Configuration Roadmap

  1. Configure a routing protocol to implement interworking between RouterA, RouterB, and RouterC.

  2. Configure Layer 2 forwarding on Switch.

  3. Configure a Dot1q termination sub-interface on RouterA and RouterB.

  4. Configure BFD sessions on RouterA and RouterB to detect faults on the link between them.

  5. Create VRRP group 1 on GE2/0/0.1 interfaces of RouterA and RouterB to implement link backup.

Procedure

  1. Connect the devices.

    As shown in Figure 6-26, assign an IP address to each device interface. Configure an IGP protocol between RouterA, RouterB, and RouterC. OSPF is used in this example.

    # Configure RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 192.168.2.1 24
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 2/0/0.1
    [RouterA-GigabitEthernet2/0/0.1] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet2/0/0.1] quit
    [RouterA] ospf 1
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] quit

    # Configure RouterB.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] interface gigabitethernet 1/0/0
    [RouterB-GigabitEthernet1/0/0] ip address 192.168.1.1 24
    [RouterB-GigabitEthernet1/0/0] quit
    [RouterB] interface gigabitethernet 2/0/0.1
    [RouterB-GigabitEthernet2/0/0.1] ip address 10.1.1.2 24
    [RouterB-GigabitEthernet2/0/0.1] quit
    [RouterB] ospf 1
    [RouterB-ospf-1] area 0
    [RouterB-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [RouterB-ospf-1-area-0.0.0.0] quit
    [RouterB-ospf-1] quit

    # Configure RouterC.

    <Huawei> system-view
    [Huawei] sysname RouterC
    [RouterC] interface gigabitethernet 1/0/0
    [RouterC-GigabitEthernet1/0/0] ip address 192.168.2.2 24
    [RouterC-GigabitEthernet1/0/0] quit
    [RouterC] interface gigabitethernet 2/0/0
    [RouterC-GigabitEthernet2/0/0] ip address 192.168.1.2 24
    [RouterC-GigabitEthernet2/0/0] quit
    [RouterC] ospf 1
    [RouterC-ospf-1] area 0
    [RouterC-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [RouterC-ospf-1-area-0.0.0.0] quit
    [RouterC-ospf-1] quit

    After the configuration is complete, RouterA and RouterB have reachable routes to the peer, which are discovered by OSPF. RouterA and RouterB can ping each other.

    The display on RouterA is used as an example.

    [RouterA] display ip routing-table
    
    Route Flags: R - relay, D - download to fib, T -
    to vpn-instance
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7       Routes : 7
    
    Destination/Mask    Proto  Pre  Cost       Flags NextHop         Interface
        192.168.2.0/24  Direct 0    0            D   192.168.2.1     GigabitEthernet1/0/0
        192.168.2.1/32  Direct 0    0            D   127.0.0.1       InLoopBack0
        192.168.1.0/24  OSPF   10   2            D   192.168.2.2     GigabitEthernet1/0/0
          10.1.1.0/24  Direct 0    0            D   10.1.1.1       GigabitEthernet2/0/0.1
          10.1.1.1/32  Direct 0    0            D   127.0.0.1       InLoopBack0
          127.0.0.0/8   Direct 0    0            D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct 0    0            D   127.0.0.1       InLoopBack0
    
    [RouterA] ping 192.168.1.1
    PING 192.168.1.1: 56  data bytes, press CTRL_C to break
        Reply from 192.168.1.1: bytes=56 Sequence=1 ttl=254 time=7 ms
        Reply from 192.168.1.1: bytes=56 Sequence=2 ttl=254 time=1 ms
        Reply from 192.168.1.1: bytes=56 Sequence=3 ttl=254 time=5 ms
        Reply from 192.168.1.1: bytes=56 Sequence=4 ttl=254 time=1 ms
        Reply from 192.168.1.1: bytes=56 Sequence=5 ttl=254 time=8 ms
    
      --- 192.168.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/4/8 ms            

  2. Configure Layer 2 forwarding on Switch.

    <Huawei> system-view
    [Huawei] sysname Switch
    [Switch] vlan 10
    [Switch-vlan10] quit
    [Switch] interface GigabitEthernet 1/0/0
    [Switch-GigabitEthernet1/0/0] port link-type access
    [Switch-GigabitEthernet1/0/0] port default vlan 10
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface GigabitEthernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface GigabitEthernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 10
    [Switch-GigabitEthernet1/0/2] quit

  3. Configure Dot1q termination sub-interfaces.

    # Configure RouterA.

    [RouterA] interface gigabitethernet 2/0/0.1
    [RouterA-GigabitEthernet2/0/0.1] dot1q termination vid 10
    [RouterA-GigabitEthernet2/0/0.1] quit

    # Configure RouterB.

    [RouterB] interface gigabitethernet 2/0/0.1
    [RouterB-GigabitEthernet2/0/0.1] dot1q termination vid 10
    [RouterB-GigabitEthernet2/0/0.1] quit

  4. Create a BFD session.

    # Configure RouterA.

    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] bfd atob bind peer-ip 10.1.1.2 interface gigabitethernet 2/0/0.1
    [RouterA-bfd-session-atob] discriminator local 1
    [RouterA-bfd-session-atob] discriminator remote 2
    [RouterA-bfd-session-atob] commit
    [RouterA-bfd-session-atob] quit

    # Configure RouterB.

    [RouterB] bfd
    [RouterB-bfd] quit
    [RouterB] bfd atob bind peer-ip 10.1.1.1 interface gigabitethernet 2/0/0.1
    [RouterB-bfd-session-atob] discriminator local 2
    [RouterB-bfd-session-atob] discriminator remote 1
    [RouterB-bfd-session-atob] commit
    [RouterB-bfd-session-atob] quit

    After the configuration is complete, run the display bfd session all verbose command. You can see that the BFD session status is Up. The display on RouterA is used as an example.

    [RouterA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 16384     (Multi Hop) State : Up        Name : atob
    ------------------------------------------------------------------------------
      Local Discriminator    : 1                Remote Discriminator   : 2
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(GigabitEthernet2/0/0.1)
      Bind Session Type      : Static
      Bind Peer IP Address   : 10.1.1.2
      NextHop Ip Address     : 10.1.1.2
      Bind Interface         : GigabitEthernet2/0/0.1
      FSM Board Id           : 0                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000
      Echo Passive           : Disable          Acl Number             : -
      Destination Port       : 3784             TTL                    : 255
      Proc Interface Status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : -
      Session Init TmrID     : -                Session WTR TmrID      : -
      Session Echo Tx TmrID  : -
      PDT Index              : FSM-0|RCV-0|IF-0|TOKEN-0
      Session Description    : -
    ------------------------------------------------------------------------------
    
         Total UP/DOWN Session Number : 1/0
    

  5. Configure VRRP group 1 to monitor the BFD session.

    # Configure RouterA.

    [RouterA] interface gigabitethernet 2/0/0.1
    [RouterA-GigabitEthernet2/0/0.1] dot1q vrrp vid 10
    [RouterA-GigabitEthernet2/0/0.1] vrrp vrid 1 virtual 10.1.1.100
    [RouterA-GigabitEthernet2/0/0.1] vrrp vrid 1 priority 160
    [RouterA-GigabitEthernet2/0/0.1] vrrp vrid 1 track bfd-session 1
    [RouterA-GigabitEthernet2/0/0.1] quit

    # Configure RouterB.

    [RouterB] interface gigabitethernet 2/0/0.1
    [RouterB-GigabitEthernet2/0/0.1] dot1q vrrp vid 10
    [RouterB-GigabitEthernet2/0/0.1] vrrp vrid 1 virtual 10.1.1.100
    [RouterB-GigabitEthernet2/0/0.1] vrrp vrid 1 track bfd-session 2
    [RouterB-GigabitEthernet2/0/0.1] quit

  6. Verify the configuration.

    # Run the display vrrp command. You can see that the BFD session is in Up state. The display on RouterA is used as an example.

    [RouterA] display vrrp
    GigabitEthernet1/0/0 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.100
        Master IP : 10.1.1.1   
        PriorityRun : 160
        PriorityConfig : 160
        MasterPriority : 160
        Preempt : YES   Delay Time : 0 s 
        TimerRun : 1
        TimerConfig : 1
        Auth type : NONE    
        Virtual Mac :  0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled 
        Config track link-bfd down-number : 0
        Track BFD         : 1                      Priority reduced : 10
        BFD-session state : UP
        Create time : 2014-10-13 12:01:06                                                                                               
        Last change time : 2014-10-13 12:01:09 
    

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    bfd
    #
    interface GigabitEthernet 1/0/0
     ip address 192.168.2.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0.1
     dot1q termination vid 10
     dot1q vrrp vid 10
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual 10.1.1.100
     vrrp vrid 1 priority 160
     vrrp vrid 1 track bfd-session 1
    #
    bfd atob bind peer-ip 10.1.1.2 interface gigabitethernet 2/0/0.1
     discriminator local 1
     discriminator remote 2
     commit
    #
    ospf 1
     area 0.0.0.0
     network 192.168.2.0 0.0.0.255
     network 10.1.1.0 0.0.0.255
    #
    return
    
  • RouterB configuration file

    #
     sysname RouterB
    #
    bfd
    #
    interface GigabitEthernet 1/0/0
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0.1
     dot1q termination vid 10
     dot1q vrrp vid 10
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual 10.1.1.100
     vrrp vrid 1 track bfd-session 2
     #
    bfd atob bind peer-ip 10.1.1.1 interface gigabitethernet 2/0/0.1
     discriminator local 2
     discriminator remote 1
     commit
    #
    ospf 1
     area 0.0.0.0
     network 192.168.1.0 0.0.0.255
     network 10.1.1.0 0.0.0.255
    #
    return
    
  • RouterC configuration file

    #
     sysname RouterC
    #
    bfd
    #
    interface GigabitEthernet 1/0/0
      ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet 2/0/0
      ip address 192.168.1.2 255.255.255.0
    #
    ospf 1
     area 0.0.0.0
     network 192.168.1.0 0.0.0.255
     network 192.168.2.0 0.0.0.255
    #
    return
    
  • Switch configuration file

    #
     sysname Switch
    #
    vlan batch 10
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 10
    #
    return
    
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069338

Views: 15419

Downloads: 56

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next