No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Association Between VRRP and BFD to Implement a Rapid Active/Standby Switchover

Example for Configuring Association Between VRRP and BFD to Implement a Rapid Active/Standby Switchover

Networking Requirements

As shown in Figure 7-13, hosts on a LAN are dual-homed to RouterA and RouterB through the switch. A VRRP group is established on RouterA and RouterB, and RouterA is the master.

When RouterA or the link between RouterA and the switch is faulty, the switchover period is within 1s. This reduces the impact of the fault on service transmission.

Figure 7-13  Networking diagram for configuring association between VRRP and BFD to implement a rapid active/standby switchover

Configuration Roadmap

Association between VRRP and BFD is used to implement fast switching of master and backup gateways. The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a routing protocol to ensure network connectivity.
  2. Configure a VRRP group on RouterA and RouterB, set the priority of RouterA to 120 and the preemption delay to 20s so that RouterA functions as the master, and set the default priority for RouterB so that RouterB functions as the backup.
  3. Configure a static BFD session on RouterA and RouterB to monitor the link of the VRRP group.
  4. Configure association between VRRP and BFD on RouterB. When the link is faulty, an active/standby switchover can be performed rapidly.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface and configure a routing protocol. RouterA is used as an example. The configurations of RouterB and RouterC are similar to the configuration of RouterA, and are not mentioned here.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.1.1 24
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] ospf
    [RouterA-ospf-1] area 0
    [RouterA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [RouterA-ospf-1-area-0.0.0.0] quit
    [RouterA-ospf-1] quit
    

  2. Configure VRRP groups.

    # Configure VRRP group 1 on RouterA, and set the priority of RouterA to 120 and the preemption delay to 20s.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 virtual-ip 10.1.1.3
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 priority 120
    [RouterA-GigabitEthernet2/0/0] vrrp vrid 1 preempt-mode timer delay 20
    [RouterA-GigabitEthernet2/0/0] quit

    # Configure VRRP group 1 on RouterB, and set the default priority of 100 for RouterB.

    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] vrrp vrid 1 virtual-ip 10.1.1.3
    [RouterB-GigabitEthernet2/0/0] quit

  3. Configure a static BFD session.

    # Create a BFD session on RouterA.

    [RouterA] bfd
    [RouterA-bfd] quit
    [RouterA] bfd atob bind peer-ip 10.1.1.2 interface gigabitethernet 2/0/0
    [RouterA-bfd-session-atob] discriminator local 1
    [RouterA-bfd-session-atob] discriminator remote 2
    [RouterA-bfd-session-atob] min-rx-interval 50
    [RouterA-bfd-session-atob] min-tx-interval 50 
    [RouterA-bfd-session-atob] commit
    [RouterA-bfd-session-atob] quit
    

    # Create a BFD session on RouterB.

    [RouterB] bfd
    [RouterB-bfd] quit
    [RouterB] bfd btoa bind peer-ip 10.1.1.1 interface gigabitethernet 2/0/0
    [RouterB-bfd-session-btoa] discriminator local 2
    [RouterB-bfd-session-btoa] discriminator remote 1
    [RouterB-bfd-session-btoa] min-rx-interval 50
    [RouterB-bfd-session-btoa] min-tx-interval 50
    [RouterB-bfd-session-btoa] commit
    [RouterB-bfd-session-btoa] quit
    

    Run the display bfd session command on RouterA and RouterB. You can see that the BFD session is Up. The display on Router A is used as an example.

    [RouterA] display bfd session all
    --------------------------------------------------------------------------------
    Local Remote PeerIpAddr      State     Type        InterfaceName                
    --------------------------------------------------------------------------------
    1     2      10.1.1.2        Up        S_IP_IF     GigabitEthernet1/0/0         
    --------------------------------------------------------------------------------
         Total UP/DOWN Session Number : 1/0       

  4. Configure association between VRRP and BFD.

    # Configure association between VRRP and BFD on RouterB. When the BFD session becomes Down, the priority of RouterB increases by 40.

    [RouterB] interface gigabitethernet 2/0/0
    [RouterB-GigabitEthernet2/0/0] vrrp vrid 1 track bfd-session 2 increased 40
    [RouterB-GigabitEthernet2/0/0] quit

  5. Verify the configuration.

    # After the configuration is complete, run the display vrrp command on RouterA and RouterB. RouterA is the master, RouterB is the backup, and the associated BFD session is in Up state.

    [RouterA] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.1
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time      : 2012-05-22 17:32:56
        Last change time : 2012-05-22 17:33:00
    
    [RouterB] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.1
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Track BFD        : 2  Priority increased : 40
        BFD-Session State: UP
        Create time      : 2012-05-22 17:33:00
        Last change time : 2012-05-22 17:33:04

    # Run the shutdown command on GE2/0/0 of RouterA to simulate a link fault. Then run the display vrrp command on RouterA and RouterB. You can see that RouterA is in Initialize state, RouterB becomes the master, and the associated BFD session becomes Down.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] shutdown
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Initialize
        Virtual IP       : 10.1.1.3
        Master IP        : 0.0.0.0
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 0
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time      : 2012-05-22 17:32:56
        Last change time : 2012-05-22 17:33:06
    
    [RouterB] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.2
        PriorityRun      : 140
        PriorityConfig   : 100
        MasterPriority   : 140
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Track BFD        : 2  Priority increased : 40
        BFD-Session State: DOWN
        Create time      : 2012-05-22 17:33:00
        Last change time : 2012-05-22 17:33:06

    # Run the undo shutdown command on GE2/0/0 of RouterA. After 20s, run the display vrrp command on RouterA and RouterB. You can see that RouterA restores to be the master and RouterB the backup, and the associated BFD session is in Up state.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] undo shutdown
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Master
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.1
        PriorityRun      : 120
        PriorityConfig   : 120
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 20 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Create time      : 2012-05-22 17:32:56
        Last change time : 2012-05-22 17:33:50
    
    [RouterB] display vrrp
      GigabitEthernet2/0/0 | Virtual Router 1
        State          : Backup
        Virtual IP       : 10.1.1.3
        Master IP        : 10.1.1.1
        PriorityRun      : 100
        PriorityConfig   : 100
        MasterPriority   : 120
        Preempt          : YES   Delay Time : 0 s   
        TimerRun         : 1 s 
        TimerConfig      : 1 s
        Auth Type        : NONE
        Virtual Mac      :  0000-5e00-0101
        Check TTL        : YES
        Config type      : normal-vrrp
        Backup-forward   : disabled
        Track BFD : 2  Priority increased : 40
        BFD-Session State: UP
        Create time      : 2012-05-22 17:33:00
        Last change time : 2012-05-22 17:33:50

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    bfd
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.3
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
    #
    bfd atob bind peer-ip 10.1.1.2 interface GigabitEthernet2/0/0
     discriminator local 1
     discriminator remote 2
     min-tx-interval 50
     min-rx-interval 50
     commit  
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    bfd
    #
    interface GigabitEthernet2/0/0
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.3
     vrrp vrid 1 track bfd-session 2 increased 40
    #
    bfd btoa bind peer-ip 10.1.1.1 interface GigabitEthernet2/0/0
     discriminator local 2
     discriminator remote 1
     min-tx-interval 50
     min-rx-interval 50
     commit
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069338

Views: 14177

Downloads: 42

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next