No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Ethernet Interface Backup in Active/Standby Mode

Example for Configuring Ethernet Interface Backup in Active/Standby Mode

Networking Requirements

As shown in Figure 2-11, HostA communicates with HostB through RouterA. RouterA directly connects to RouterB through three interfaces.

To improve reliability of data transmission between HostA and HostB, traffic needs to be switched to GE1/0/0 when GE2/0/0 becomes faulty.

Figure 2-11  Networking diagram of interface backup in active/standby mode

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface and a static route between HostA and HostB to ensure connectivity at the network layer.

  2. Configure GE2/0/0 on RouterA as the primary interface to transmit all the services. Configure GE1/0/0 and GE3/0/0 as backup interfaces of GE2/0/0 and set a higher priority for GE1/0/0. When the primary interface is faulty, GE1/0/0 provides services.

  3. Set the switchover delay to prevent flapping caused by frequent active/standby switchovers.

Procedure

  1. Configure an IP address for each interface and a static route between HostA and HostB.

    # Assign an IP address to each interface. Use RouterA as an example. The configurations of RouterB are similar to the configuration of RouterA, and are not mentioned here.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] ip address 10.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet2/0/0] quit
    [RouterA] interface gigabitethernet 1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 10.1.2.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit
    [RouterA] interface gigabitethernet 3/0/0
    [RouterA-GigabitEthernet3/0/0] ip address 10.1.3.1 255.255.255.0
    [RouterA-GigabitEthernet3/0/0] quit

    # On RouterA, configure a static route to the network segment where HostB is located.

    [RouterA] ip route-static 192.168.2.0 24 10.1.2.2
    [RouterA] ip route-static 192.168.2.0 24 10.1.1.2
    [RouterA] ip route-static 192.168.2.0 24 10.1.3.2

    # On RouterB, configure a static route to the network segment where HostA is located.

    [RouterB] ip route-static 192.168.1.0 24 10.1.2.1
    [RouterB] ip route-static 192.168.1.0 24 10.1.1.1
    [RouterB] ip route-static 192.168.1.0 24 10.1.3.1

  2. Configure backup interfaces on RouterA.

    # Configure GE2/0/0 as the primary interface and GE1/0/0 and GE3/0/0 as backup interfaces, and set the priority of GE1/0/0 and GE3/0/0 to 30 and 20.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] standby interface gigabitethernet 1/0/0 30
    [RouterA-GigabitEthernet2/0/0] standby interface gigabitethernet 3/0/0 20
    [RouterA-GigabitEthernet2/0/0] quit

  3. Set the switchover delay on RouterA.

    # Set the switchover delay to 10s.

    [RouterA] interface gigabitethernet 2/0/0
    [RouterA-GigabitEthernet2/0/0] standby timer delay 10 10
    [RouterA-GigabitEthernet2/0/0] quit

  4. Verify the configuration.

    # Run the display standby state command on RouterA. You can see that GigabitEthernet2/0/0 is in Up state, and GigabitEthernet1/0/0 and GigabitEthernet3/0/0 are in standby state.

    [RouterA] display standby state
    Interface                      Interfacestate Backupstate Backupflag Pri Loadstate
    GigabitEthernet2/0/0                       UP         MUP         MU
    GigabitEthernet1/0/0                  STANDBY     STANDBY         BU  30
    GigabitEthernet3/0/0                  STANDBY     STANDBY         BU  20
    Backup-flag meaning:
    M---MAIN  B---BACKUP     V---MOVED    U---USED
    D---LOAD  P---PULLED     
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask    Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface            State             

    # Run the shutdown command on GE2/0/0 to simulate a link fault. Run the display standby state command on RouterA.

    You can see that GigabitEthernet2/0/0 becomes Down and GigabitEthernet1/0/0 becomes Up, indicating that the backup interface has been started.
    [RouterA] display standby state
    Interface                      Interfacestate Backupstate Backupflag Pri Loadstate
    GigabitEthernet2/0/0                              DOWN         MDOWN         MU
    GigabitEthernet1/0/0                                UP           UP          BU  30
    GigabitEthernet3/0/0                           STANDBY       STANDBY         BU  20
    Backup-flag meaning:
    M---MAIN  B---BACKUP     V---MOVED    U---USED
    D---LOAD  P---PULLED     
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask    Route-State  BackupInterface            State         
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface            State             

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.1.1 255.255.255.0
     standby interface GigabitEthernet1/0/0 30
     standby interface GigabitEthernet3/0/0 20
     standby timer delay 10 10
    #
    interface GigabitEthernet3/0/0
      ip address 10.1.3.1 255.255.255.0
    #
     ip route-static 192.168.2.0 24 10.1.2.2
     ip route-static 192.168.2.0 24 10.1.1.2
     ip route-static 192.168.2.0 24 10.1.3.2
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    interface GigabitEthernet1/0/0
      ip address 10.1.2.2 255.255.255.0
    #
    interface GigabitEthernet2/0/0
      ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet3/0/0
      ip address 10.1.3.2 255.255.255.0
    #
     ip route-static 192.168.1.0 24 10.1.2.1
     ip route-static 192.168.1.0 24 10.1.1.1
     ip route-static 192.168.1.0 24 10.1.3.1
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069338

Views: 14287

Downloads: 43

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next