No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VLAN-based Y.1731 Two-way Frame Delay Measurement

Example for Configuring VLAN-based Y.1731 Two-way Frame Delay Measurement

Networking Requirements

As networks continue to rapidly develop and applications become more and more diversified, various value-added services such as IPTV, video conferencing, and VOIP are becoming more widely used. Link connectivity and network performance determine QoS on bearer networks. Therefore, performance monitoring is especially important for service transmission.

In Figure 10-7, CFM is deployed to measure link connectivity between the CEs. To provide high-quality video services, carriers need to monitor the two-way delay over mobile bearer links in real time, while monitoring link connectivity. Monitoring the two-way delay over mobile bearer links allows the carriers to respond quickly to video service quality deterioration.

Figure 10-7  Networking of VLAN-based Y.1731 Two-way Frame Delay Measurement

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure basic CFM functions on the CEs.

  2. Configure CE2 to receive DMMs.

  3. Configure two-way frame delay measurement for the end-to-end link between the CEs.

    • Configure on-demand two-way frame delay measurement for the end-to-end link between the CEs to periodically collect statistics about the delay in frame transmission.
    • Configure proactive two-way frame delay measurement for the end-to-end link between the CEs to continuously collect statistics about the delay in frame transmission.

Procedure

  1. Configure basic Ethernet CFM functions on CE1 and CE2. Create an MD named md3 and an MA named ma3, and bind the MA to the VLAN.

    # Configure CE1.

    <Huawei> system-view
    [Huawei] sysname CE1
    [CE1] vlan 2
    [CE1-vlan2] quit
    [CE1] interface GigabitEthernet 1/0/1
    [CE1-GigabitEthernet1/0/1] portswitch
    [CE1-GigabitEthernet1/0/1] port link-type trunk
    [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [CE1-GigabitEthernet1/0/1] quit
    [CE1] cfm enable
    [CE1] cfm md md3
    [CE1-md-md3] ma ma3
    [CE1-md-md3-ma-ma3] map vlan 2
    [CE1-md-md3-ma-ma3] mep mep-id 3 interface GigabitEthernet 1/0/1 outward
    [CE1-md-md3-ma-ma3] mep ccm-send mep-id 3 enable
    [CE1-md-md3-ma-ma3] remote-mep mep-id 4 mac 0001-0300-0204
    [CE1-md-md3-ma-ma3] remote-mep ccm-receive mep-id 4 enable
    [CE1-md-md3-ma-ma3] test-id 1 mep 3 remote-mep 4

    # Configure CE2.

    <Huawei> system-view
    [Huawei] sysname CE2
    [CE2] vlan 2
    [CE2-vlan2] quit
    [CE2] interface GigabitEthernet 1/0/1
    [CE2-GigabitEthernet1/0/1] portswitch
    [CE2-GigabitEthernet1/0/1] port link-type trunk
    [CE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [CE2-GigabitEthernet1/0/1] quit
    [CE2] cfm enable
    [CE2] cfm md md3
    [CE2-md-md3] ma ma3
    [CE2-md-md3-ma-ma3] map vlan 2
    [CE2-md-md3-ma-ma3] mep mep-id 4 interface GigabitEthernet 1/0/1 outward
    [CE2-md-md3-ma-ma3] mep ccm-send mep-id 4 enable
    [CE2-md-md3-ma-ma3] remote-mep mep-id 3
    [CE2-md-md3-ma-ma3] remote-mep ccm-receive mep-id 3 enable
    [CE2-md-md3-ma-ma3] test-id 1 mep 4 remote-mep 3
    

  2. Configure CE2 to receive DMMs.

    # Configure CE2 to receive DMMs.

    [CE2-md-md3-ma-ma3] delay-measure two-way receive test-id 1
    [CE2-md-md3-ma-ma3] quit
    [CE2-md-md3] quit

  3. Configure two-way frame delay measurement for the end-to-end link between the CEs.

    • Configure on-demand two-way frame delay measurement for the end-to-end link between the CEs.

      # Configure on-demand two-way frame delay measurement on CE1.

      [CE1-md-md3-ma-ma3] delay-measure two-way send test-id 1 interval 10000 count 60
      [CE1-md-md3-ma-ma3] quit
      [CE1-md-md3] quit
    • Configure proactive two-way frame delay measurement for the end-to-end link between the CEs.

      # Configure proactive two-way frame delay measurement on CE1.

      [CE1-md-md3-ma-ma3] delay-measure two-way continual send test-id 1 interval 30000
      [CE1-md-md3-ma-ma3] quit
      [CE1-md-md3] quit
      [CE1] quit

  4. Verify the configuration.

    # After the configurations are complete, run the display y1731 statistic-type twoway-delay test-id 1 command on CE1. You can view the statistics about the two-way frame delay.

    <CE1> display y1731 statistic-type twoway-delay test-id 1
    Measurement Start Time : 2017-10-17 16:16:31+01:00         
    Latest two-way delay statistics:
    --------------------------------------------------------------------------------
    Index    Delay(usec)    Delay variation(usec)
    --------------------------------------------------------------------------------
        1             75                       11
        2             74                        1
        3             74                        0
        4             84                       10
        5             88                        4
        6             87                        1
        7             77                       10
        8             86                        9
        9             82                        4
       10             88                        6
       11             76                       12
       12             82                        6
       13             78                        4
       14             81                        3
       15             85                        4
       16             72                       13
       17             80                        8
       18             79                        1
       19             87                        8
       20             81                        6
       21             81                        0
       22             85                        4
       23             90                        5
       24             83                        7
       25             77                        6
       26             80                        3
       27             83                        3
       28             79                        4
       29             90                       11
       30             86                        4
    --------------------------------------------------------------------------------
    Average delay(usec) :         81    Average delay variation(usec) :          5
    Maximum delay(usec) :         90    Maximum delay variation(usec) :         13
    Minimum delay(usec) :         72    Minimum delay variation(usec) :          0

Configuration Files

  • CE1 configuration file

    #
    sysname CE1
    #
    vlan 2
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 3 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 3 enable
      remote-mep mep-id 4 mac 0001-0300-0204
      remote-mep ccm-receive mep-id 4 enable
      test-id 1 mep 3 remote-mep 4
      delay-measure two-way continual send test-id 1 interval 30000
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan 2
    #
    cfm enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    cfm md md3
     ma ma3
      map vlan 2
      mep mep-id 4 interface GigabitEthernet1/0/1 outward
      mep ccm-send mep-id 4 enable
      remote-mep mep-id 3
      remote-mep ccm-receive mep-id 3 enable
      test-id 1 mep 4 remote-mep 3
      delay-measure two-way receive test-id 1
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069338

Views: 13986

Downloads: 40

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next