No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

CLI-based Configuration Guide - Reliability

AR100, AR120, AR160, AR1200, AR2200, AR3200, and AR3600 V300R003

This document provides guidance for configuring reliability services, including interface backup, BFD, VRRP, and EFM.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Associating Interface Backup with NQA to Configure an ISDN Interface as the Backup of an Ethernet Interface

Example for Associating Interface Backup with NQA to Configure an ISDN Interface as the Backup of an Ethernet Interface

Networking Requirements

As shown in Figure 2-20, the egress gateway RouterA in the headquarters of company connects to the Internet through GE1/0/0. The link between GE1/0/0 and the Internet is used as the primary link, and the link between PRI1/0/0:15 and the ISDN is used as the backup link.

The company wants to monitor the primary link status. When the primary link is faulty, the backup link is started to transmit services to reduce the impact of the primary link fault on service transmission.

Figure 2-20  Networking diagram of association between interface backup and NQA

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on routes along the primary link and static routes to ensure connectivity at the network layer.

  2. Configure C-DCC on RouterA and RouterB and configure dialer numbers 600501 and 600502 so that RouterA can initiate calls to and receive calls from RouterB.

  3. Configure an NQA test instance on RouterA to monitor the primary link status.

  4. Associate interface backup with NQA on backup interface PRI1/0/0:15 of RouterA. When the NQA test instance monitors the primary link status, traffic can be rapidly switched to the backup interface.

Procedure

  1. Implement connectivity at the network layer.

    # Assign an IP address to the interface of RouterA.

    <Huawei> system-view
    [Huawei] sysname RouterA
    [RouterA] interface gigabitethernet1/0/0
    [RouterA-GigabitEthernet1/0/0] ip address 2.1.1.1 255.255.255.0
    [RouterA-GigabitEthernet1/0/0] quit

    # Assign an IP address to the interface of RouterB.

    <Huawei> system-view
    [Huawei] sysname RouterB
    [RouterB] interface gigabitethernet1/0/0
    [RouterB-GigabitEthernet1/0/0] ip address 4.1.1.2 255.255.255.0
    [RouterB-GigabitEthernet1/0/0] quit

    # Assign an IP address to the interface of RouterC.

    <Huawei> system-view
    [Huawei] sysname RouterC
    [RouterC] interface gigabitethernet1/0/0
    [RouterC-GigabitEthernet1/0/0] ip address 2.1.1.2 255.255.255.0
    [RouterC-GigabitEthernet1/0/0] quit

    # Assign an IP address to the interface of RouterD.

    <Huawei> system-view
    [Huawei] sysname RouterD
    [RouterD] interface gigabitethernet1/0/0
    [RouterD-GigabitEthernet1/0/0] ip address 4.1.1.1 255.255.255.0
    [RouterD-GigabitEthernet1/0/0] quit
    

    # On RouterA, configure a static route to 4.1.1.0/24 of RouterB.

    [RouterA] ip route-static 4.1.1.0 255.255.255.0 2.1.1.2 preference 80
    

    # On RouterB, configure a static route to 2.1.1.0/24 of RouterA.

    [RouterB] ip route-static 2.1.1.0 255.255.255.0 4.1.1.1 preference 80

  2. Configure C-DCC on RouterA.

    # Create dialer group 1 and configure a dialer rule in the group.

    [RouterA] dialer-rule
    [RouterA-dialer-rule] dialer-rule 1 ip permit
    [RouterA-dialer-rule] quit

    # Configure a serial interface.

    [RouterA] controller e1 1/0/0
    [RouterA-E1 1/0/0] pri-set
    [RouterA-E1 1/0/0] quit

    # Assign an IP address to PRI1/0/0:15, enable C-DCC, and configure the dialer number.

    [RouterA] interface serial 1/0/0:15
    [RouterA-Serial1/0/0:15] ip address 3.1.1.1 24
    [RouterA-Serial1/0/0:15] dialer enable-circular
    [RouterA-Serial1/0/0:15] dialer-group 1
    [RouterA-Serial1/0/0:15] dialer route ip 3.1.1.2 600502
    [RouterA-Serial1/0/0:15] quit

    # Configure a static route.

    [RouterA] ip route-static 3.1.1.0 255.255.255.0 Serial 1/0/0:15 preference 60

  3. Configure C-DCC on RouterB.

    # Create dialer group 2 and configure a dialer rule in the group.

    [RouterB] dialer-rule
    [RouterB-dialer-rule] dialer-rule 2 ip permit
    [RouterA-dialer-rule] quit

    # Configure a serial interface.

    [RouterB] controller e1 1/0/0
    [RouterB-E1 1/0/0] pri-set
    [RouterB-E1 1/0/0] quit

    # Assign an IP address to PRI1/0/0:15, enable C-DCC, and configure the dialer number.

    [RouterB] interface serial 1/0/0:15
    [RouterB-Serial1/0/0:15] ip address 3.1.1.2 24
    [RouterB-Serial1/0/0:15] dialer enable-circular
    [RouterB-Serial1/0/0:15] dialer-group 2
    [RouterB-Serial1/0/0:15] dialer route ip 3.1.1.1 600501
    [RouterB-Serial1/0/0:15] quit

    # Configure a static route.

    [RouterB] ip route-static 3.1.1.0 255.255.255.0 Serial 1/0/0:15 preference 60

  4. Configure an NQA test instance with the destination address of 4.1.1.2/24.

    # Configure the ICMP NQA test instance on RouterA.

    [RouterA] nqa test-instance user test
    [RouterA-nqa-user-test] test-type icmp
    [RouterA-nqa-user-test] destination-address ipv4 4.1.1.2
    [RouterA-nqa-user-test] frequency 10
    [RouterA-nqa-user-test] start now
    [RouterA-nqa-user-test] quit

  5. Associate interface backup with NQA on backup interface PRI1/0/0:15 of RouterA.

    [RouterA]interface serial 1/0/0:15
    [RouterA-Serial1/0/0:15] standby track nqa user test
    [RouterA-Serial1/0/0:15] quit

  6. Verify the configuration.

    Run the display nqa results test-instance user test command. The command output shows that the NQA test instance status is success.

    <RouterA> display nqa results test-instance user test
    NQA entry(user, test) :testflag is active ,testtype is icmp
      1 .Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 3
       Completion:success                   RTD OverThresholds number: 0
       Attempts number:1                    Drop operation number:0
       Disconnect operation number:0        Operation timeout number:0
       System busy operation number:0       Connection fail number:0
       Operation sequence errors number:0   RTT Stats errors number:0
       Destination ip address:4.1.1.2
       Min/Max/Average Completion Time: 60/90/80
       Sum/Square-Sum  Completion Time: 240/19800
       Last Good Probe Time: 2011-04-19 16:38:38.7
       Lost packet ratio: 0 %        

    # View the NQA test instance status and backup interface status on RouterA. The command output shows that the NQA test instance status is OK and the status of Serial 1/0/0:15 is STANDBY.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    --------------------------------------------------------------------------------
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
    user                                                                            
    test                                                          OK                
                                     Serial 1/0/0:15              STANDBY           

    Run the shutdown command on GE1/0/0 of RouterB to simulate a link fault. Run the display nqa results test-instance user test command on RouterA. The command output shows that the NQA test instance status is failed.

    <RouterA> display nqa results test-instance user test
    NQA entry(user, test) :testflag is active ,testtype is icmp
      1 .Test 1 result   The test is finished
       Send operation times: 3              Receive response times: 0               
       Completion:failed                    RTD OverThresholds number: 0            
       Attempts number:1                    Drop operation number:3                 
       Disconnect operation number:0        Operation timeout number:0              
       System busy operation number:0       Connection fail number:0                
       Operation sequence errors number:0   RTT Stats errors number:0               
       Destination ip address:4.1.1.2                                              
       Min/Max/Average Completion Time: 0/0/0                                       
       Sum/Square-Sum  Completion Time: 0/0                                         
       Last Good Probe Time: 0000-00-00 00:00:00.0                                  
       Lost packet ratio: 100 %    

    Run the display standby state command on RouterA. The command output shows that the NQA test instance status is ERR, and the status of backup interface Serial 1/0/0:15 is UP, indicating that the backup interface has started.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    --------------------------------------------------------------------------------
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
    user                                                                            
    test                                                          ERR                
                                     Serial 1/0/0:15              UP           

    Run the undo shutdown command on GE1/0/0 of RouterB to make the interface Up. Run the display standby state command on RouterA. The command output shows that the route status is OK and backup interface Serial 1/0/0:15 has switched to the standby state.

    <RouterA> display standby state
    Interface                  Interfacestate Backupstate Backupflag Pri   Loadstate
                                                                                    
     Backup-flag meaning:                                                           
     M---MAIN  B---BACKUP     V---MOVED    U---USED                                 
     D---LOAD  P---PULLED                                                           
                                                                                    
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track BFD information:                                                 
    Bfd-Name              Bfd-State  BackupInterface            State               
                                                                                    
    ----------------------------------------------------------------------------    
    Below is track IP route information:                                            
    Destination/Mask          Route-State  BackupInterface            State         
                                                                                    
    --------------------------------------------------------------------------------
    Below is track NQA Information:                                                 
    Instance Name                    BackupInterface              State             
    user                                                                            
    test                                                          OK                
                                     Serial 1/0/0:15              STANDBY           

Configuration Files

  • RouterA configuration file

    #
     sysname RouterA
    #
    controller E1 1/0/0                                                             
     pri-set      
    #             
    interface Serial1/0/0:15                       
     link-protocol ppp            
     ip address 3.1.1.1 255.255.255.0              
     dialer enable-circular                 
     dialer-group 1                  
     dialer route ip 3.1.1.2 600502              
     standby track nqa user test
    #                     
     dialer-rule               
     dialer-rule 1 ip permit 
    #                                             
    interface GigabitEthernet1/0/0
     ip address 2.1.1.1 255.255.255.0
    #
     ip route-static 4.1.1.0 255.255.255.0 2.1.1.2 preference 80
     ip route-static 3.1.1.0 255.255.255.0 Serial 1/0/0:15 preference 60
    #
     nqa test-instance user test
     test-type icmp
     destination-address ipv4 4.1.1.2
     frequency 10
    #
    return
  • RouterB configuration file

    #
     sysname RouterB
    #
    controller E1 1/0/0                                                             
     pri-set      
    #             
    interface Serial1/0/0:15                       
     link-protocol ppp            
     ip address 3.1.1.2 255.255.255.0              
     dialer enable-circular                 
     dialer-group 2                  
     dialer route ip 3.1.1.1 600501              
    #                     
     dialer-rule               
     dialer-rule 2 ip permit 
    #                                             
    interface GigabitEthernet1/0/0
     ip address 4.1.1.2 255.255.255.0
    #
     ip route-static 2.1.1.0 255.255.255.0 4.1.1.1 preference 80
     ip route-static 3.1.1.0 255.255.255.0 Serial 1/0/0:15 preference 60
    #
    return
  • RouterC configuration file

    #
     sysname RouterC
    #
    interface GigabitEthernet1/0/0
     ip address 2.1.1.2 255.255.255.0
    #
    return
  • RouterD configuration file

    #
     sysname RouterD
    #
    interface GigabitEthernet1/0/0
     ip address 4.1.1.1 255.255.255.0
    #
     ip route-static 2.1.1.0 255.255.255.0 4.1.1.1 preference 80
     ip route-static 3.1.1.0 255.255.255.0 Serial 1/0/0:15 preference 60
    #
    return
Translation
Download
Updated: 2019-03-06

Document ID: EDOC1100069338

Views: 14062

Downloads: 40

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next