No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Device Management

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of Device Management, including device status query, hardware management, Information Center Configuration, NTP, Synchronous Ethernet Configuration, Fault Management Configuration, Energy-Saving Management Configuration, Performance Management Configuration, Maintenance Assistant Configuration, and OPS Configuration.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring NTP Symmetric Peer Mode

Example for Configuring NTP Symmetric Peer Mode

Networking Requirements

As shown in Figure 4-12, three devices are on a local area network (LAN).

The clocks of the devices on the LAN need to be synchronized to facilitate device management. SwitchC has synchronized its clock with an authoritative clock, the Global Positioning System (GPS), through a network. The user requires SwitchD and SwitchE to synchronize their clocks to the clock of SwitchC.

Figure 4-12 Networking diagram for configuring the symmetric peer mode

Configuration Roadmap

You can configure the NTP protocol to synchronize time, and use the NTP symmetric peer mode to meet the user's requirement for time synchronization. The configuration roadmap is as follows:

  1. Configure the local clock of SwitchC as the NTP primary clock.
  2. The NTP unicast server/client mode is used to synchronize the clocks of SwitchC and SwitchD. SwitchC functions as the server, and SwitchD functions as the client.
  3. The symmetric peer mode is used to synchronize the clocks of SwitchE and SwitchD. SwitchE functions as the symmetric active peer and sends a clock synchronization request to SwitchD.

Procedure

  1. Configure IP addresses for SwitchC, SwitchD, and SwitchE.

    Configure an IP address for each interface according to Figure 4-12. After the configurations are complete, the three switches can ping each other.

    # Configure an IP address on SwitchC. For details about the configurations of SwitchD and SwitchE, see "Configuration Files".

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchC
    [*HUAWEI] commit
    [~SwitchC] vlan 100
    [*SwitchC-vlan100] quit
    [*SwitchC] interface vlanif 100
    [*SwitchC-Vlanif100] ip address 10.0.0.1 24
    [*SwitchC-Vlanif100] quit
    [*SwitchC] interface 10ge 1/0/1
    [*SwitchC-10GE1/0/1] port link-type trunk
    [*SwitchC-10GE1/0/1] port trunk pvid vlan 100
    [*SwitchC-10GE1/0/1] port trunk allow-pass vlan 100
    [*SwitchC-10GE1/0/1] quit
    [*SwitchC] commit

  2. Configure the NTP client/server mode.

    # On SwitchC, set the local clock as the NTP primary clock, set the clock stratum to 2, and enable the NTP server.

    [~SwitchC] ntp refclock-master 2
    [*SwitchC] undo ntp server disable
    [*SwitchC] commit

    # Specify on SwitchD that SwitchC functions as the NTP server of SwitchD.

    <SwitchD> system-view
    [~SwitchD] ntp unicast-server 10.0.0.1
    [*SwitchD] commit

    After the preceding configuration is complete, SwitchD can synchronize its clock with the clock of SwitchC.

    # Check the NTP status of SwitchD, and you can find that the clock status is "synchronized", indicating that the synchronization is complete. The stratum of the clock is 3, which is one stratum lower than that of the clock of SwitchC.

    [~SwitchD] display ntp status
     clock status: synchronized
     clock stratum: 3
     reference clock ID: 10.0.0.1
     nominal frequency: 100.0000 Hz                                                 
     actual frequency: 100.0000 Hz   
     clock precision: 2^18                                                          
     clock offset: 0.7388 ms                                                        
     root delay: 2.45 ms                                                            
     root dispersion: 22.08 ms                                                      
     peer dispersion: 11.20 ms                                                      
     reference time: 15:10:11.276 UTC Sep 11 2013(D5DB0668.46B1A2A4)                
     synchronization state: clock synchronized   

  3. Configure the NTP unicast symmetric peer mode.

    # Specify on SwitchE that SwitchD functions as the symmetric passive peer of SwitchE.

    <SwitchE> system-view
    [~SwitchE] ntp unicast-peer 10.0.0.2
    [*SwitchE] commit

    SwitchE is not configured with a primary clock and its clock stratum is lower than that of SwitchD, so that SwitchE synchronizes its clock with the clock of SwitchD.

  4. Verify the configuration.

    Monitor the status of SwitchE after the synchronization. The clock of SwitchE is in "synchronized" status, indicating that the synchronization is complete. The clock stratum of SwitchE is 4, which is one stratum lower than that of the symmetric passive peer SwitchD.

    # Check the clock status of SwitchE.

    [~SwitchE] display ntp status
     clock status: synchronized
     clock stratum: 4
     reference clock ID: 10.0.0.2
     nominal frequency: 100.0000 Hz               
     actual frequency: 100.0000 Hz                  
     clock precision: 2^17                                                          
     clock offset: -0.8330 ms                                                       
     root delay: 6.94 ms                                                            
     root dispersion: 33.65 ms                                                      
     peer dispersion: 22.72 ms                                                      
     reference time: 15:10:40.979 UTC Sep 11 2013(D5DB064F.FADFF822)                
     synchronization state: clock synchronized 

Configuration Files

  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    ntp ipv6 server disable
    ntp refclock-master 2
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.0.0.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    ntp server disable
    ntp ipv6 server disable
    ntp unicast-server 10.0.0.1
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.0.0.2 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    return
  • Configuration file of SwitchE

    #
    sysname SwitchE
    #
    ntp server disable
    ntp ipv6 server disable
    ntp unicast-peer 10.0.0.2
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.0.0.3 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074722

Views: 10934

Downloads: 10

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next