No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Multicast VPN Extranet in Remote Crossing Scenario (Configuring the Source VPN on the Receiver PE)

Example for Configuring Multicast VPN Extranet in Remote Crossing Scenario (Configuring the Source VPN on the Receiver PE)

Networking Requirements

As shown in Figure 7-18, PE1, PE2, and P are devices on the carrier's backbone network. CE1 and CE2 belong to VPN instances vpna and vpnb, respectively. The receiver in vpnb wants to receive the multicast data sent from the source in vpna.

Figure 7-18 Networking diagram for multicast VPN extranet configuration in remote crossing scenario (configuring the source VPN on the receiver PE)

Configuration Roadmap

The multicast VPN extranet function for the remote crossing scenario (configuring the source VPN on the receiver PE) can be configured to meet the service requirement. The configuration roadmap is as follows:

  1. Configure BGP/MPLS IP VPN to ensure connectivity of the VPN network. In the remote crossing scenario, you need to configure the source VPN on the receiver PE, that is, configure vpna on PE2 and enable the IPv4 address family in vpna.
  2. Set the tunnel mode to GRE on the PEs.
  3. Configure a Share-Group address for each VPN instance and bind an MTI to each VPN instance on the PEs.
  4. Enable multicast routing on all the PE, P, and CE devices. Configure the multicast function on the public network between the PE and P devices and the private networks between PE and CE devices. In the remote crossing scenario, you need to configure a private network RP to serve the multicast VPN extranet group. It must be a static RP.
  5. Configure a multicast routing policy for vpnb on PE2 to specify vpna as the RPF upstream interface.

Procedure

  1. Configure BGP/MPLS IP VPN.
    1. Configure Open Shortest Path First (OSPF) on the backbone network to allow communication between the PE and P devices. The configurations of P and PE2 are similar to the configuration of PE1, and are not mentioned here. See Configuration Files.

      # Configure PE1.

      <HUAWEI> system-view
      [~HUAWEI] sysname PE1
      [*HUAWEI] commit
      [~PE1] interface loopback 0
      [*PE1-LoopBack0] ip address 1.1.1.1 32
      [*PE1-LoopBack0] quit
      [*PE1] vlan batch 100
      [*PE1] interface 10ge 2/0/2
      [*PE1-10GE2/0/2] port link-type trunk
      [*PE1-10GE2/0/2] port trunk allow-pass vlan 100
      [*PE1-10GE2/0/2] quit
      [*PE1] interface vlanif 100
      [*PE1-Vlanif100] ip address 172.1.1.1 24
      [*PE1-Vlanif100] quit
      [*PE1] router id 1.1.1.1
      [*PE1] ospf
      [*PE1-ospf-1] area 0
      [*PE1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
      [*PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
      [*PE1-ospf-1-area-0.0.0.0] quit
      [*PE1-ospf-1] quit
      [*PE1] commit
      

      After the configuration is complete, OSPF neighbor relationships can be set up between PE1, P, and PE2. Run the display ospf peer command on PE1, P, and PE2, and you can see that the neighbor status is Full. Run the display ip routing-table command, and you can see that PE1 and PE2 have learned the routes to Loopback0 of each other.

    2. Enable MPLS basic capability and MPLS Label Distribution Protocol (LDP) on the MPLS backbone network to establish LDP label switching paths (LSPs) between the backbone network devices.

      # Configure PE1.

      [~PE1] mpls lsr-id 1.1.1.1
      [*PE1] mpls
      [*PE1-mpls] quit
      [*PE1] mpls ldp
      [*PE1-mpls-ldp] quit
      [*PE1] interface vlanif 100
      [*PE1-Vlanif100] mpls
      [*PE1-Vlanif100] mpls ldp
      [*PE1-Vlanif100] quit
      [*PE1] commit
      

      # Configure PE2.

      [~PE2] mpls lsr-id 2.2.2.2
      [*PE2] mpls
      [*PE2-mpls] quit
      [*PE2] mpls ldp
      [*PE2-mpls-ldp] quit
      [*PE2] interface vlanif 200
      [*PE2-Vlanif200] mpls
      [*PE2-Vlanif200] mpls ldp
      [*PE2-Vlanif200] quit
      [*PE2] commit
      

      # Configure P.

      [~P] mpls lsr-id 3.3.3.3
      [*P] mpls
      [*P-mpls] quit
      [*P] mpls ldp
      [*P-mpls-ldp] quit
      [*P] interface vlanif 100
      [*P-Vlanif100] mpls
      [*P-Vlanif100] mpls ldp
      [*P-Vlanif100] quit
      [*P] interface vlanif 200
      [*P-Vlanif200] mpls
      [*P-Vlanif200] mpls ldp
      [*P-Vlanif200] quit
      [*P] commit
      

      After the configuration is complete, LDP sessions can be set up between PE1 and P, and between P and PE2. Run the display mpls ldp session command on the PE and P devices, and you can see that LDP session status is Operational.

    3. Set up an MP-IBGP peer relationship between the PE devices.

      # Configure PE1.

      [~PE1] bgp 100
      [*PE1-bgp] peer 2.2.2.2 as-number 100
      [*PE1-bgp] peer 2.2.2.2 connect-interface loopback 0
      [*PE1-bgp] ipv4-family vpnv4
      [*PE1-bgp-af-vpnv4] peer 2.2.2.2 enable
      [*PE1-bgp-af-vpnv4] quit
      [*PE1-bgp] quit
      [*PE1] commit
      

      # Configure PE2.

      [~PE2] bgp 100
      [*PE2-bgp] peer 1.1.1.1 as-number 100
      [*PE2-bgp] peer 1.1.1.1 connect-interface loopback 0
      [*PE2-bgp] ipv4-family vpnv4
      [*PE2-bgp-af-vpnv4] peer 1.1.1.1 enable
      [*PE2-bgp-af-vpnv4] quit
      [*PE2-bgp] quit
      [*PE2] commit
      

      After the configuration is complete, run the display bgp vpnv4 all peer command on the PE devices. You can see that a BGP peer relationship has been set up between PE1 and PE2 and is in Established state.

    4. Configure VPN instances on the PEs to enable communication between the CE and PE devices.

      # Configure PE1.

      [~PE1] ip vpn-instance vpna
      [*PE1-vpn-instance-vpna] ipv4-family
      [*PE1-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
      [*PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
      [*PE1-vpn-instance-vpna-af-ipv4] quit
      [*PE1-vpn-instance-vpna] quit
      [*PE1] vlan batch 11
      [*PE1] interface 10ge 1/0/1
      [*PE1-10GE1/0/1] port link-type trunk
      [*PE1-10GE1/0/1] port trunk allow-pass vlan 11
      [*PE1-10GE1/0/1] quit
      [*PE1] interface vlanif 11
      [*PE1-Vlanif11] ip binding vpn-instance vpna 
      [*PE1-Vlanif11] ip address 10.1.1.1 24
      [*PE1-Vlanif11] quit
      [*PE1] commit
      

      # Configure PE2.

      Configure VPN instances vpna and vpnb on PE2.

      [~PE2] ip vpn-instance vpnb
      [*PE2-vpn-instance-vpnb] ipv4-family
      [*PE2-vpn-instance-vpnb-af-ipv4] route-distinguisher 200:1
      [*PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:1 both
      [*PE2-vpn-instance-vpnb-af-ipv4] vpn-target 111:1 import-extcommunity
      [*PE2-vpn-instance-vpnb-af-ipv4] quit
      [*PE2-vpn-instance-vpnb] quit
      [*PE2] ip vpn-instance vpna
      [*PE2-vpn-instance-vpna] ipv4-family
      [*PE2-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
      [*PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
      [*PE2-vpn-instance-vpna-af-ipv4] quit
      [*PE2-vpn-instance-vpna] quit
      [*PE2] vlan batch 22
      [*PE2] interface 10ge 1/0/1
      [*PE2-10GE1/0/1] port link-type trunk
      [*PE2-10GE1/0/1] port trunk allow-pass vlan 22
      [*PE2-10GE1/0/1] quit
      [*PE2] interface vlanif 22
      [*PE2-Vlanif22] ip binding vpn-instance vpnb 
      [*PE2-Vlanif22] ip address 10.1.2.1 24
      [*PE2-Vlanif22] quit
      [*PE2] commit
      

      # Assign IP addresses to interfaces on CE1 and CE2 according to Figure 7-18. The configuration procedure is not provided here. See Configuration Files.

      After the configuration is complete, each PE can successfully ping the CE attached to it using the ping -vpn-instance command.

    5. Configure a routing protocol between the PE and CE devices to import the VPN routes.

      This example uses the OSPF protocol to advertise routes between the PE and CE devices.

      # Configure PE1.

      [~PE1] ospf 2 vpn-instance vpna
      [*PE1-ospf-2] import-route bgp
      [*PE1-ospf-2] area 0
      [*PE1-ospf-2-area-0.0.0.0] network 10.1.1.0 0.0.0.255
      [*PE1-ospf-2-area-0.0.0.0] quit
      [*PE1-ospf-2] quit
      [*PE1] bgp 100
      [*PE1-bgp] ipv4-family vpn-instance vpna
      [*PE1-bgp-vpna] import-route ospf 2
      [*PE1-bgp-vpna] quit
      [*PE1-bgp] quit
      [*PE1] commit
      

      # Configure CE1.

      [~CE1] ospf 2
      [*CE1-ospf-2] area 0
      [*CE1-ospf-2-area-0.0.0.0] network 10.1.1.0 0.0.0.255
      [*CE1-ospf-2-area-0.0.0.0] network 10.138.1.0 0.0.0.255
      [*CE1-ospf-2-area-0.0.0.0] quit
      [*CE1-ospf-2] quit
      [*CE1] commit
      

      # Configure PE2.

      [~PE2] ospf 2 vpn-instance vpnb
      [*PE2-ospf-2] import-route bgp
      [*PE2-ospf-2] area 0
      [*PE2-ospf-2-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [*PE2-ospf-2-area-0.0.0.0] quit
      [*PE2-ospf-2] quit
      [*PE2] bgp 100
      [*PE2-bgp] ipv4-family vpn-instance vpnb
      [*PE2-bgp-vpnb] import-route ospf 2
      [*PE2-bgp-vpnb] quit
      [*PE2-bgp] ipv4-family vpn-instance vpna
      [*PE2-bgp-vpna] import-route ospf 2
      [*PE2-bgp-vpna] quit
      [*PE2-bgp] quit
      [*PE2] commit
      

      # Configure CE2.

      [~CE2] ospf 2
      [*CE2-ospf-2] area 0
      [*CE2-ospf-2-area-0.0.0.0] network 10.1.2.0 0.0.0.255
      [*CE2-ospf-2-area-0.0.0.0] network 10.138.2.0 0.0.0.255
      [*CE2-ospf-2-area-0.0.0.0] quit
      [*CE2-ospf-2] quit
      [*CE2] commit

  2. Specify a tunnel mode on the PEs.

    NOTE:

    The tunnel mode configured on a PE takes effect after you save the configuration and restart the PE. You can restart the device immediately or after all you complete all the configuration.

    # Configure PE1.

    [~PE1] ip tunnel mode gre
    [*PE1] commit
    

    # Configure PE2.

    [~PE2] ip tunnel mode gre
    [*PE2] commit
    

  3. Configure a Share-Group address for each VPN instance and bind an MTI to each VPN instance on the PEs.

    # Configure PE1.

    [~PE1] ip vpn-instance vpna
    [~PE1-vpn-instance-vpna] ipv4-family
    [~PE1-vpn-instance-vpna-af-ipv4] multicast routing-enable
    [*PE1-vpn-instance-vpna-af-ipv4] multicast-domain share-group 239.1.1.1 binding mtunnel 0
    [*PE1-vpn-instance-vpna-af-ipv4] multicast-domain source-interface loopback 0
    [*PE1-vpn-instance-vpna-af-ipv4] quit
    [*PE1-vpn-instance-vpna] quit
    [*PE1] commit

    # Configure PE2.

    [~PE2] ip vpn-instance vpnb
    [~PE2-vpn-instance-vpnb] ipv4-family
    [~PE2-vpn-instance-vpnb-af-ipv4] multicast routing-enable
    [*PE2-vpn-instance-vpnb-af-ipv4] multicast-domain share-group 238.1.1.1 binding mtunnel 1
    [*PE2-vpn-instance-vpnb-af-ipv4] multicast-domain source-interface loopback 0
    [*PE2-vpn-instance-vpnb-af-ipv4] quit
    [*PE2-vpn-instance-vpnb] quit
    [*PE2] ip vpn-instance vpna
    [*PE2-vpn-instance-vpna] ipv4-family
    [*PE2-vpn-instance-vpna-af-ipv4] multicast routing-enable
    [*PE2-vpn-instance-vpna-af-ipv4] multicast-domain share-group 239.1.1.1 binding mtunnel 0
    [*PE2-vpn-instance-vpna-af-ipv4] multicast-domain source-interface loopback 0
    [*PE2-vpn-instance-vpna-af-ipv4] quit
    [*PE2-vpn-instance-vpna] quit
    [*PE2] commit

  4. Configure the multicast function on the public and private networks.
    1. Configure the multicast function on the public network.

      Enable PIM-SM on the public network. Configure Loopback0 of the P device as a candidate bootstrap router (C-BSR) and candidate rendezvous point (C-RP) on the public network.

      # Configure PE1.

      [~PE1] multicast routing-enable
      [*PE1] interface vlanif 100
      [*PE1-Vlanif100] pim sm
      [*PE1-Vlanif100] quit
      [*PE1] interface loopback 0
      [*PE1-LoopBack0] pim sm
      [*PE1-LoopBack0] quit
      [*PE1] commit

      # Configure PE2.

      [~PE2] multicast routing-enable
      [*PE2] interface vlanif 200
      [*PE2-Vlanif200] pim sm
      [*PE2-Vlanif200] quit
      [*PE2] interface loopback 0
      [*PE2-LoopBack0] pim sm
      [*PE2-LoopBack0] quit
      [*PE2] commit

      # Configure P.

      [~P] multicast routing-enable
      [*P] interface vlanif 200
      [*P-Vlanif200] pim sm
      [*P-Vlanif200] quit
      [*P] interface vlanif 100
      [*P-Vlanif100] pim sm
      [*P-Vlanif100] quit
      [*P] interface loopback 0
      [*P-LoopBack0] pim sm
      [*P-LoopBack0] quit
      [*P] pim
      [*P-pim] c-bsr Loopback 0 
      [*P-pim] c-rp Loopback 0
      [*P-pim] quit
      [*P] commit

    2. Configure the multicast function on the private network.

      NOTE:

      The source and receiver VPN instances support only static RP configuration, and the static RP address must belong to the source VPN instance.

      # Configure PE1.

      [~PE1] interface vlanif 11
      [~PE1-Vlanif11] pim sm
      [*PE1-Vlanif11] quit
      [*PE1] pim vpn-instance vpna
      [*PE1-pim-vpna] static-rp 4.4.4.4
      [*PE1-pim-vpna] quit
      [*PE1] commit

      # Configure PE2.

      [~PE2] interface vlanif 22
      [~PE2-Vlanif22] pim sm
      [*PE2-Vlanif22] quit
      [*PE2] pim vpn-instance vpnb
      [*PE2-pim-vpnb] static-rp 4.4.4.4
      [*PE2-pim-vpnb] quit
      [*PE2] pim vpn-instance vpna
      [*PE2-pim-vpna] static-rp 4.4.4.4
      [*PE2-pim-vpna] quit
      [*PE2] commit

      # Configure CE1.

      [~CE1] multicast routing-enable
      [*CE1] interface loopback 0
      [*CE1-LoopBack0] pim sm
      [*CE1-LoopBack0] quit
      [*CE1] interface vlanif 10
      [*CE1-Vlanif10] pim sm
      [*CE1-Vlanif10] quit
      [*CE1] interface vlanif 11
      [*CE1-Vlanif11] pim sm
      [*CE1-Vlanif11] quit
      [*CE1] pim
      [*CE1-pim] static-rp 4.4.4.4
      [*CE1-pim] quit
      [*CE1] commit

      # Configure CE2.

      [~CE2] multicast routing-enable
      [*CE2] interface vlanif 22
      [*CE2-Vlanif22] pim sm
      [*CE2-Vlanif22] quit
      [*CE2] interface vlanif 20
      [*CE2-Vlanif20] pim sm
      [*CE2-Vlanif20] igmp enable
      [*CE2-Vlanif20] quit
      [*CE2] pim
      [*CE2-pim] static-rp 4.4.4.4
      [*CE2] commit

  5. Configure a multicast routing policy for vpnb to specify vpna as the RPF upstream interface in the PIM routing entry for group 225.1.1.0/24.

    [~PE2] ip vpn-instance vpnb
    [~PE2-vpn-instance-vpnb] ipv4-family
    [~PE2-vpn-instance-vpnb-af-ipv4] multicast extranet select-rpf vpn-instance vpna group 225.1.1.0 24
    [*PE2-vpn-instance-vpnb-af-ipv4] quit
    [*PE2-vpn-instance-vpnb] quit
    [*PE2] commit

  6. Verify the configuration.

    Check the PIM routing table on PE2. The following command output shows that vpna is the RPF upstream interface in the PIM routing entry for group 225.1.1.1, and vpnb is the receiver of the multicast extranet group in vpna.

    [~PE2] display pim vpn-instance vpnb routing-table extranet source-vpn-instance vpna
     VPN-Instance: vpnb
     Total 1 (*, G) entry; 1 (S, G) entry 
     
     Total matched 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: WC 
         UpTime: 00:00:20
         Upstream interface: MCAST_Extranet(vpna)
             Upstream neighbor: 1.1.1.1
             RPF prime neighbor: 1.1.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif22
                 Protocol: pim-sm, UpTime: 00:00:20, Expires: 00:03:10
     
     (10.138.1.1, 225.1.1.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: SPT ACT 
         UpTime: 00:00:20
         Upstream interface: MCAST_Extranet(vpna)
             Upstream neighbor: 1.1.1.1
             RPF prime neighbor: 1.1.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vlanif22
                 Protocol: pim-sm, UpTime: 00:00:21, Expires: -
    [~PE2] display pim vpn-instance vpna routing-table extranet receive-vpn-instance vpnb
     VPN-Instance: vpna
     Total 1 (*, G) entry; 1 (S, G) entry 
     
     Total matched 1 (*, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: WC EXTRANET 
         UpTime: 00:01:36
         Upstream interface: MTunnel0
             Upstream neighbor: 1.1.1.1
             RPF prime neighbor: 1.1.1.1
         Downstream interface(s) information: none
    
         Extranet receiver(s): 1
            1: vpnb
     
     (10.138.1.1, 225.1.1.1)
         RP: 4.4.4.4 
         Protocol: pim-sm, Flag: SPT ACT EXTRANET 
         UpTime: 00:01:36
         Upstream interface: MTunnel0
             Upstream neighbor: 1.1.1.1
             RPF prime neighbor: 1.1.1.1
         Downstream interface(s) information: none
    
         Extranet receiver(s): 1
            1: vpnb

Configuration Files

  • PE1 configuration file

    #
    sysname PE1
    #
    vlan batch 11 100
    #
    router id 1.1.1.1
    #
    multicast routing-enable 
    #
    ip tunnel mode gre 
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack0
      multicast-domain share-group 239.1.1.1 binding mtunnel 0
    #
    mpls lsr-id 1.1.1.1
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family 
    #
    interface Vlanif11 
     ip binding vpn-instance vpna
     ip address 10.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif100
     ip address 172.1.1.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance vpna
    #
    bgp 100
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 2.2.2.2 enable 
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.2 enable
     #
     ipv4-family vpn-instance vpna
      import-route ospf 2
    #
    ospf 1 
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0 
      network 172.1.1.0 0.0.0.255 
    #
    ospf 2 vpn-instance vpna
     import-route bgp 
     area 0.0.0.0 
      network 10.1.1.0 0.0.0.255
    #
    pim vpn-instance vpna
     static-rp 4.4.4.4  
    #
    return
  • PE2 configuration file

    #
    sysname PE2
    #
    vlan batch 22 200
    #
    router id 2.2.2.2
    # 
    multicast routing-enable
    #
    ip tunnel mode gre 
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack0
      multicast-domain share-group 239.1.1.1 binding mtunnel 0
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 200:1
      vpn-target 222:1 export-extcommunity
      vpn-target 222:1 import-extcommunity
      vpn-target 111:1 import-extcommunity  
      multicast routing-enable
      multicast-domain source-interface LoopBack0
      multicast-domain share-group 238.1.1.1 binding mtunnel 1
      multicast extranet select-rpf vpn-instance vpna group 225.1.1.0 255.255.255.0
    #
    mpls lsr-id 2.2.2.2
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif22
     ip binding vpn-instance vpnb
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip address 172.2.1.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 22
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance vpna
    #
    interface MTunnel1
     ip binding vpn-instance vpnb
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 1.1.1.1 enable 
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance vpna
       import-route ospf 2
     #
     ipv4-family vpn-instance vpnb
       import-route ospf 2
    #
    ospf 1 
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0 
      network 172.2.1.0 0.0.0.255 
    #
    ospf 2 vpn-instance vpnb
     import-route bgp
     area 0.0.0.0 
      network 10.1.2.0 0.0.0.255
    #
    pim vpn-instance vpna
     static-rp 4.4.4.4
    #
    pim vpn-instance vpnb
     static-rp 4.4.4.4
    #
    return
  • P configuration file

    #
    sysname P
    #
    vlan batch 100 200
    #
    router id 3.3.3.3
    # 
    multicast routing-enable
    #
    mpls lsr-id 3.3.3.3
    #
    mpls
    #
    mpls ldp
     #
     ipv4-family
    #
    interface Vlanif100 
     ip address 172.1.1.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface Vlanif200
     ip address 172.2.1.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    ospf 1 
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0 
      network 172.1.1.0 0.0.0.255 
      network 172.2.1.0 0.0.0.255 
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    return
  • CE1 configuration file

    #
    sysname CE1
    #
    vlan batch 10 to 11
    # 
    multicast routing-enable
    #
    interface Vlanif10 
     ip address 10.138.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif11
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 11
    #
    interface 10GE2/0/2
     port default vlan 10
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255
     pim sm
    #
    ospf 2 
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 10.1.1.0 0.0.0.255 
      network 10.138.1.0 0.0.0.255 
    #
    pim
     static-rp 4.4.4.4 
    #
    return
  • CE2 configuration file

    #
    sysname CE2
    #
    vlan batch 20 22
    # 
    multicast routing-enable
    #
    interface Vlanif20
     ip address 10.138.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif22
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 22
    #
    interface 10GE2/0/2
     port default vlan 20
    #
    ospf 2 
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255 
      network 10.138.2.0 0.0.0.255 
    #
    pim
     static-rp 4.4.4.4 
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 40376

Downloads: 13

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next