No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Multicast

CloudEngine 12800 and 12800E V200R005C10

This document describes the configurations of IP multicast, including IP multicast basics, IGMP, MLD, PIM (IPv4), PIM (IPv6), MSDP, multicast VPN, multicast route management (IPv4), multicast route management (IPv6), IGMP snooping, MLD snooping, static multicast MAC address, multicast VLAN, multicast network management.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 PIM-SM in the SSM Model

Example for Configuring IPv4 PIM-SM in the SSM Model

Networking Requirements

In Figure 4-27, the switch configured with PIM-SM is required to provide SSM services for hosts on the network so that hosts in a multicast group can receive VoD information sent from specified multicast sources.

Figure 4-27 Network diagram for configuring PIM-SM in the SSM model

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure an IP address for each interface and a unicast routing protocol. PIM is an intra-domain multicast routing protocol that depends on unicast routing protocols.

  2. Enable the multicast function on switches providing multicast services. Before configuring PIM-SM, you must enable the multicast function.

  3. Enable PIM-SM on all interfaces. You can configure other PIM-SM functions only after PIM-SM is enabled.

  4. Enable Internet Group Management Protocol (IGMP) on interfaces that connect the switch and hosts and set the IGMP version to IGMPv3. A receiver can join and leave a multicast group of a specified source by sending IGMP messages. The leaf switches maintain the multicast member relationship through IGMP.

  5. Enable PIM silent on interfaces that connect the switch and hosts to prevent malicious hosts from simulating sending PIM Hello packets. In this manner, security of PIM-SM domain is ensured.

    NOTE:

    If the user host network segment connects to multiple switches, do not enable PIM silent on interfaces that connect these switches and user hosts. For example, PIM silent cannot be enabled on SwitchB and SwitchC.

  6. Configure the same address range for SSM groups on each switch. Ensure that switches in the PIM-SM domain provide services only for multicast groups in the range of SSM group addresses. In this manner, multicast can be controlled effectively.

Procedure

  1. Configure an IP address for each interface and a unicast routing protocol.

    Configure the IP address and mask for each interface shown in Figure 4-27, and configure Open Shortest Path First (OSPF) on each switch to ensure that switches can communicate at the network layer and can dynamically update routes through the unicast routing protocol.

    # Add interfaces of SwitchA to VLANs. The configuration of SwitchB, SwitchC, SwitchD, SwitchE, and SwitchF are similar to the configuration of SwitchA, and are not mentioned.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 10 20 30
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 2/0/2
    [*SwitchA-10GE2/0/2] port link-type trunk
    [*SwitchA-10GE2/0/2] port trunk allow-pass vlan 30
    [*SwitchA-10GE2/0/2] quit
    [*SwitchA] interface 10ge 3/0/3
    [*SwitchA-10GE3/0/3] port default vlan 20
    [*SwitchA-10GE3/0/3] quit
    [*SwitchA] commit
    

    # Assign IP addresses to VLANIF interfaces on SwitchA. The configuration of SwitchB, SwitchC, SwitchD, SwitchE, and SwitchF are similar to the configuration of SwitchA, and are not mentioned.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 192.168.5.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] interface vlanif 20
    [*SwitchA-Vlanif20] ip address 10.110.1.1 24
    [*SwitchA-Vlanif20] quit
    [*SwitchA] interface vlanif 30
    [*SwitchA-Vlanif30] ip address 192.168.1.1 24
    [*SwitchA-Vlanif30] quit
    [*SwitchA] commit

    # Configure a routing protocol on SwitchA. OSPF is used in this example. The configuration of SwitchB, SwitchC, SwitchD, SwitchE, and SwitchF are similar to the configuration of SwitchA, and are not mentioned.

    [~SwitchA] ospf
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.110.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.5.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. Enable multicast, and enable PIM-SM on all interfaces.

    # Enable multicast on all switches and PIM-SM on all interfaces. The configuration of Switch B, Switch C, Switch D, Switch E, and SwitchF are similar to the configuration of Switch A, and are not mentioned.

    [~SwitchA] multicast routing-enable
    [*SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] pim sm
    [*SwitchA-Vlanif10] commit
    [~SwitchA-Vlanif10] quit
    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] pim sm
    [*SwitchA-Vlanif20] commit
    [~SwitchA-Vlanif20] quit
    [~SwitchA] interface vlanif 30
    [~SwitchA-Vlanif30] pim sm
    [*SwitchA-Vlanif30] commit
    [~SwitchA-Vlanif30] quit

  3. Enable IGMP on interfaces that connect the switch and hosts and set IGMP version to IGMPv3.

    # Enable IGMP on interfaces that connect SwitchA and user hosts. The configuration of SwitchB and SwitchC are similar to the configuration of SwitchA, and are not mentioned.

    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] igmp enable
    [*SwitchA-Vlanif20] igmp version 3
    [*SwitchA-Vlanif20] commit
    [~SwitchA-Vlanif20] quit
    

  4. Enable PIM silent on interfaces on SwitchA.

    [~SwitchA] interface vlanif 20
    [~SwitchA-Vlanif20] pim silent
    [*SwitchA-Vlanif20] commit
    [~SwitchA-Vlanif20] quit
    

  5. Configure the address range for SSM groups.

    # Set the address of SSM group to range from 232.1.1.0 to 232.1.1.24 on all switches. The configuration of Switch B, Switch C, Switch D, Switch E, and SwitchF are similar to the configuration of Switch A, and are not mentioned here.

    [~SwitchA] acl number 2000
    [*SwitchA-acl4-basic-2000] rule permit source 232.1.1.0 0.0.0.255
    [*SwitchA-acl4-basic-2000] commit
    [~SwitchA-acl4-basic-2000] quit
    [~SwitchA] pim
    [*SwitchA-pim] ssm-policy 2000
    [*SwitchA-pim] commit
    [~SwitchA-pim] quit

  6. Verify the configuration.

    # Run the display pim interface command to check the PIM configuration and status. The PIM information on SwitchC is displayed as follows:

    [~SwitchC] display pim interface
     VPN-Instance: public net
     Interface           State NbrCnt HelloInt     DR-Pri     DR-Address      
     Vlanif40            up         1       30          1     10.110.2.2 (local) 
     Vlanif50            up         1       30          1     192.168.3.2 

    # Run the display pim routing-table command to view the PIM routing table. HostA receives information sent from multicast source 10.110.3.100/24 and 10.110.4.100/24 to the multicast group 232.1.1.1/24. HostB receives information sent from multicast source 10.110.3.100/24 to multicast group 232.1.1.1/24. The following information is displayed.

    [~SwitchA] display pim routing-table
    VPN-Instance: public net
     Total 2 (S, G) entries
     
    (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:46
         Upstream interface: Vlanif10
             Upstream neighbor: 192.168.5.2
             RPF prime neighbor: 192.168.5.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:13:46, Expires:-
     
    (10.110.4.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif30
             Upstream neighbor: 192.168.1.2
             RPF prime neighbor: 192.168.1.2
        Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif20
                 Protocol: igmp, UpTime: 00:00:42, Expires:-
    
    
    [~SwitchB] display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
    (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:10:12
         Upstream interface: Vlanif90
             Upstream neighbor: 192.168.2.2
             RPF prime neighbor: 192.168.2.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:10:12, Expires:-
    
    
    [~SwitchC] display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
    
     (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:01:25
         Upstream interface: Vlanif50
             Upstream neighbor: 192.168.3.2
             RPF prime neighbor: 192.168.3.2
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif40
                 Protocol: igmp, UpTime: 00:01:25, Expires:-
    
    
    [~SwitchD] display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
     (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:00:42
         Upstream interface: Vlanif80
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif60
                 Protocol: pim-ssm, UpTime: 00:00:42, Expires:-
    
    
    [~SwitchE] display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
     (10.110.3.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:16
         Upstream interface: Vlanif60
             Upstream neighbor: 192.168.4.1
             RPF prime neighbor: 192.168.4.1
         Downstream interface(s) information:
         Total number of downstreams: 3
             1: Vlanif10
                 Protocol: pim-ssm, UpTime: 00:13:16, Expires: 00:03:22
             2: Vlanif50
                 Protocol: pim-ssm, UpTime: 00:13:16, Expires: 00:03:22
             3: Vlanif90
                 Protocol: pim-ssm, UpTime: 00:13:16, Expires: 00:03:22
    
    
    [~SwitchF] display pim routing-table
    VPN-Instance: public net
     Total 1 (S, G) entry
     
     (10.110.4.100, 232.1.1.1)
         Protocol: pim-ssm, Flag: SPT ACT
         UpTime: 00:13:16
         Upstream interface: Vlanif70
             Upstream neighbor: NULL
             RPF prime neighbor: NULL
         Downstream interface(s) information:
         Total number of downstreams: 1
             1: Vlanif30
                 Protocol: pim-ssm, UpTime: 00:15:28, Expires: 00:05:21
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif10
     ip address 192.168.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif20
     ip address 10.110.1.1 255.255.255.0
     pim silent
     pim sm 
     igmp enable
     igmp version 3
    #
    interface Vlanif30
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface 10GE3/0/3
     port default vlan 20
    #
    ospf 1
     area 0.0.0.0
      network 10.110.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 40 90
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif40
     ip address 10.110.2.1 255.255.255.0
     pim sm 
     igmp enable
     igmp version 3
    #
    interface Vlanif90
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE2/0/2
     port default vlan 40
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 40 50
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif40
     ip address 10.110.2.2 255.255.255.0
     pim sm 
     igmp enable
     igmp version 3
    #
    interface Vlanif50
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 40
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1
     area 0.0.0.0
      network 10.110.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 60 80
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif60
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface Vlanif80
     ip address 10.110.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 80
    #
    interface 10GE4/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 10.110.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    vlan batch 10 50 60 90
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif10
     ip address 192.168.5.2 255.255.255.0
     pim sm
    #
    interface Vlanif50
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif90
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface 10GE3/0/3
     port link-type trunk
     port trunk allow-pass vlan 90
    #
    interface 10GE4/0/4
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
  • SwitchF configuration file

    #
    sysname SwitchF
    #
    vlan batch 30 70
    #
    multicast routing-enable
    #
    acl number 2000
     rule 5 permit source 232.1.1.0 0.0.0.255
    #
    interface Vlanif30
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif70
     ip address 10.110.4.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/1
     port default vlan 70
    #
    interface 10GE2/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1
     area 0.0.0.0
      network 10.110.4.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    pim
     ssm-policy 2000
    #
    return
Translation
Download
Updated: 2019-04-20

Document ID: EDOC1100074724

Views: 40309

Downloads: 13

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next